aboutsummaryrefslogtreecommitdiff
path: root/devel/bonobo-conf
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-07-09 21:57:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-07-09 21:57:32 +0000
commita9c01d908a60253cf3a8274b66c6d2ec9ee4e00a (patch)
tree227fb47236954ab80f89ff3b605f1a98291ad0ad /devel/bonobo-conf
parentaea805e7015158f94dea96cbb3c6781db691518a (diff)
downloadports-a9c01d908a60253cf3a8274b66c6d2ec9ee4e00a.tar.gz
ports-a9c01d908a60253cf3a8274b66c6d2ec9ee4e00a.zip
Implement USE_GNOMENG. Users should not be able to start using Evolution
without needing any other hacks.
Notes
Notes: svn path=/head/; revision=62724
Diffstat (limited to 'devel/bonobo-conf')
-rw-r--r--devel/bonobo-conf/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/bonobo-conf/Makefile b/devel/bonobo-conf/Makefile
index 43430a857dc8..ea15373a0dc4 100644
--- a/devel/bonobo-conf/Makefile
+++ b/devel/bonobo-conf/Makefile
@@ -16,17 +16,16 @@ MAINTAINER= gnome@FreeBSD.org
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack bonobo
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>