aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-all
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-02-07 11:43:02 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-02-07 11:43:02 +0000
commit776c8a3824c220b5b01a68c46bc5f90199db256d (patch)
treecf99083e7c4f8e0c4962bca7e82298b8a6c42803 /devel/boost-all
parentcbe5b4aaff50a0b1a8bdb50f26e639a192ed1ceb (diff)
downloadports-776c8a3824c220b5b01a68c46bc5f90199db256d.tar.gz
ports-776c8a3824c220b5b01a68c46bc5f90199db256d.zip
Update to boost 1.55.0
switch back to normal library naming Add a compat symlink for .so.5 Use compiler.mk to detect compiler Use a modern compiler (doesn't work with base gcc)
Notes
Notes: svn path=/head/; revision=343213
Diffstat (limited to 'devel/boost-all')
-rw-r--r--devel/boost-all/Makefile2
-rw-r--r--devel/boost-all/common.mk2
-rw-r--r--devel/boost-all/compiled.mk29
3 files changed, 9 insertions, 24 deletions
diff --git a/devel/boost-all/Makefile b/devel/boost-all/Makefile
index 60b5dade4a0f..388137bd3ba6 100644
--- a/devel/boost-all/Makefile
+++ b/devel/boost-all/Makefile
@@ -16,8 +16,8 @@ LIBRARIES_DESC= Free portable C++ libraries
PYTHON_DESC= Boost.Python - interfacing Python and C++
NO_BUILD= yes
+NO_MTREE= yes
-NO_STAGE= yes
.include "common.mk"
LIBRARIES_RUN_DEPENDS= ${LOCALBASE}/lib/libboost_thread.so:${PORTSDIR}/devel/boost-libs
diff --git a/devel/boost-all/common.mk b/devel/boost-all/common.mk
index b551b7c03dff..a5c2b6b46b41 100644
--- a/devel/boost-all/common.mk
+++ b/devel/boost-all/common.mk
@@ -1,5 +1,5 @@
-PORTVERSION= 1.52.0
+PORTVERSION= 1.55.0
PORTVERSUFFIX= ${PORTVERSION:C/\.[0-9]+$//}
DISTNAME= boost_${PORTVERSION:S/./_/g}
diff --git a/devel/boost-all/compiled.mk b/devel/boost-all/compiled.mk
index 9b4c2a50a747..b3901a0cd07c 100644
--- a/devel/boost-all/compiled.mk
+++ b/devel/boost-all/compiled.mk
@@ -1,15 +1,17 @@
USE_LDCONFIG= yes
-BOOST_SHARED_LIB_VER= 5
PKGMESSAGE= ${WRKDIR}/pkg-message
BJAM= bjam
+USES= compiler:c++11-lang
-PLIST_SUB+= BOOST_SHARED_LIB_VER=${BOOST_SHARED_LIB_VER}
+PLIST_SUB+= BOOST_SHARED_LIB_VER=${PORTVERSION} COMPAT_LIB_VER=5
PKG_MESSAGE_FILE_THREADS= ${PORTSDIR}/devel/boost-all/pkg-message.threads
PKG_MESSAGE_FILE_PYTHON= ${PORTSDIR}/devel/boost-all/pkg-message.python
+.include <bsd.port.pre.mk>
+
BJAM_ARGS= --layout=system \
- --prefix=${PREFIX}
+ --prefix=${PREFIX} \
.if ${ARCH} == amd64
BJAM_ARGS+= cxxflags=-fPIC
@@ -20,26 +22,11 @@ BJAM_ARGS+= cxxflags=-fPIC
# of gcc/g++):
BJAM_ARGS+= cxxflags="${CXXFLAGS:N-O*}" cflags="${CFLAGS:N-O*}"
-.if ${CC:T:Mgcc*}
-BOOST_TOOLSET:= gcc
-.elif ${CC:T:Mclang}
-BOOST_TOOLSET:= clang
-.else
-_COMPILER_VERSION!= ${CC} --version
-. if ${_COMPILER_VERSION:Mgcc}
-BOOST_TOOLSET:= gcc
-. elif ${_COMPILER_VERSION:M\(GCC\)}
-BOOST_TOOLSET:= gcc
-. elif ${_COMPILER_VERSION:Mclang}
-BOOST_TOOLSET:= clang
-. else
-.error Unable to determine compiler type for ${CC}
-. endif
-. undef _COMPILER_VERSION
-.endif
+BOOST_TOOLSET= ${CHOSEN_COMPILER_TYPE}
BJAM_ARGS+= --toolset=${BOOST_TOOLSET} \
${_MAKE_JOBS}
+
.if ${PORT_OPTIONS:MVERBOSE_BUILD}
BJAM_ARGS+= -d2
.endif
@@ -59,8 +46,6 @@ BJAM_ARGS+= inlining=full
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|${PORTVERSION}|${BOOST_SHARED_LIB_VER}|g' \
- ${WRKSRC}/Jamroot
.if ${BOOST_TOOLSET} == gcc
@${ECHO} "using gcc : : ${CXX} ;" >> ${WRKSRC}/tools/build/v2/user-config.jam
.endif