aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-jam
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-08-31 23:01:31 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-08-31 23:01:31 +0000
commit607344ab949d61cdf44163457b946238a2217c8b (patch)
tree3b5b9053a930d147281cdea845e230560a496401 /devel/boost-jam
parentba43bbf0ecf4f16bda379116aeea0b8753d095af (diff)
downloadports-607344ab949d61cdf44163457b946238a2217c8b.tar.gz
ports-607344ab949d61cdf44163457b946238a2217c8b.zip
Use the special 'cc' tools which makes the build system to respects CC, CFLAGS etc.
Notes
Notes: svn path=/head/; revision=366834
Diffstat (limited to 'devel/boost-jam')
-rw-r--r--devel/boost-jam/Makefile2
-rw-r--r--devel/boost-jam/files/patch-tools__build__v2__engine__build.sh14
2 files changed, 1 insertions, 15 deletions
diff --git a/devel/boost-jam/Makefile b/devel/boost-jam/Makefile
index 7d1aa7452cc9..84085b4ae8d1 100644
--- a/devel/boost-jam/Makefile
+++ b/devel/boost-jam/Makefile
@@ -12,7 +12,7 @@ EXTRACT_AFTER_ARGS= ${DISTNAME}/tools/build/v2/engine
do-build:
cd ${WRKSRC}/tools/build/v2/engine && \
- ${MAKE_ENV} ./build.sh ${CC}
+ ${MAKE_ENV} ./build.sh cc
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/bin
diff --git a/devel/boost-jam/files/patch-tools__build__v2__engine__build.sh b/devel/boost-jam/files/patch-tools__build__v2__engine__build.sh
deleted file mode 100644
index f94d6007db3e..000000000000
--- a/devel/boost-jam/files/patch-tools__build__v2__engine__build.sh
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./tools/build/v2/engine/build.sh.orig 2012-04-26 05:35:55.000000000 +0200
-+++ ./tools/build/v2/engine/build.sh 2013-05-01 10:24:50.730247378 +0200
-@@ -128,8 +128,9 @@
- BOOST_JAM_CC="gcc -DNT"
- ;;
-
-- gcc)
-- BOOST_JAM_CC=gcc
-+ gcc*)
-+ BOOST_JAM_CC=$BOOST_JAM_TOOLSET
-+ BOOST_JAM_TOOLSET=gcc
- ;;
-
- darwin)