aboutsummaryrefslogtreecommitdiff
path: root/devel/boost
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-11-10 05:52:33 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-11-10 05:52:33 +0000
commitd3c5220ca4b8a8be1aebd294a786138707c7bf07 (patch)
tree004eb3ade8fcc8f3165ba659f909d71569c36769 /devel/boost
parentc7f03b186096976ffaa7a3ed4b978b4e2cad292a (diff)
downloadports-d3c5220ca4b8a8be1aebd294a786138707c7bf07.tar.gz
ports-d3c5220ca4b8a8be1aebd294a786138707c7bf07.zip
unbreak
upgrade to 1.30.2 PR: 58168 Submitted by: Keishi Katoux <k-shi_freebsd@k2factory.org> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=93624
Diffstat (limited to 'devel/boost')
-rw-r--r--devel/boost/Makefile44
-rw-r--r--devel/boost/distinfo2
-rw-r--r--devel/boost/files/gcc-custom-tools.jam3
-rw-r--r--devel/boost/files/gcc-tools.jam.diff16
-rw-r--r--devel/boost/files/patch-gcc.hpp59
-rw-r--r--devel/boost/pkg-plist163
6 files changed, 132 insertions, 155 deletions
diff --git a/devel/boost/Makefile b/devel/boost/Makefile
index 4bec1ad1f890..ecdd44aecbf5 100644
--- a/devel/boost/Makefile
+++ b/devel/boost/Makefile
@@ -7,40 +7,46 @@
#
PORTNAME= boost
-PORTVERSION= 1.30.0
-PORTREVISION= 1
+PORTVERSION= 1.30.2
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}
-DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= pmarquis@pobox.com
COMMENT= Free peer-reviewed portable C++ source libraries
-BROKEN= "Does not build, will be removed after Feb 2"
-
MAKE_ENV+= BOOST_ROOT=${WRKSRC} BUILD="debug release"
-MAKE_ENV+= BOOST_BUILD_PATH="${WRKDIR}/gcc-custom" TOOLS="gcc-custom"
-COMPILED_LIBS= regex signals thread
-.if defined(WITHOUT_PYTHON)
-PLIST_SUB+= BOOST_PYTHON="@comment "
-.else
-PLIST_SUB+= BOOST_PYTHON=""
+
+.if defined(WITH_PYTHON)
USE_PYTHON= yes
-MAKE_ENV+= PYTHON="${PYTHON_CMD}" PYTHON_VERSION="${_PYTHON_VERSION}"
-MAKE_ENV+= PYTHON_INCLUDES="${PYTHON_INCLUDEDIR}"
-MAKE_ENV+= PYTHON_STDLIB_PATH="${PYTHON_LIBDIR}"
+# 1.30.2 doesn't support python2.3
+PYTHON_VERSION= python2.2
COMPILED_LIBS+= python
+PLIST_SUB+= BOOST_PYTHON=""
+.else
+PLIST_SUB+= BOOST_PYTHON="@comment "
.endif
+
+.include <bsd.port.pre.mk>
+
+MAKE_ENV+= PYTHON_ROOT="${PREFIX}"
+MAKE_ENV+= PYTHON_VERSION="${_PYTHON_VERSION}"
+MAKE_ENV+= PYTHON_INCLUDES="${PYTHON_INCLUDEDIR}"
+MAKE_ENV+= PYTHON_LIB_PATH="${PYTHON_LIBDIR}"
INSTALLS_SHLIB= yes
DOCFILES= *.css *.gif *.htm *.html *.jpeg *.jpg *.png
+
BJAM= ${WRKSRC}/tools/build/jam_src/bin.freebsd/bjam
+
+COMPILED_LIBS+= date_time filesystem regex signals test thread
do-configure:
- ${MKDIR} ${WRKDIR}/gcc-custom
- ${SED} -E -e 's/%%GXX%%/${CXX}/g' -e 's/%%GCC%%/${CC}/g' < \
- ${FILESDIR}/gcc-custom-tools.jam > \
- ${WRKDIR}/gcc-custom/gcc-custom-tools.jam
+# for -pthread options
+.if ${OSVERSION} >= 500016
+ cd ${WRKSRC} && patch < ${FILESDIR}/gcc-tools.jam.diff
+.endif
do-build:
cd ${WRKSRC}/tools/build/jam_src && ./build.sh gcc
@@ -60,4 +66,4 @@ do-install:
cd ${WRKSRC} && ${FIND} libs -type d -name example\* | ${TAR} cTf - - | ${TAR} xUCf ${EXAMPLESDIR} -
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/boost/distinfo b/devel/boost/distinfo
index 56ccf8f7e9f0..f69b6e432944 100644
--- a/devel/boost/distinfo
+++ b/devel/boost/distinfo
@@ -1 +1 @@
-MD5 (boost_1_30_0.tar.gz) = fe85dec53e671ea7d830936dd7423458
+MD5 (boost-1.30.2.tar.gz) = 90aa1cc62f82f50a5dfa6def6a1be32f
diff --git a/devel/boost/files/gcc-custom-tools.jam b/devel/boost/files/gcc-custom-tools.jam
deleted file mode 100644
index 029301a6b8c9..000000000000
--- a/devel/boost/files/gcc-custom-tools.jam
+++ /dev/null
@@ -1,3 +0,0 @@
-extends-toolset gcc ;
-GXX = %%GXX%% ;
-GCC = %%GCC%% ;
diff --git a/devel/boost/files/gcc-tools.jam.diff b/devel/boost/files/gcc-tools.jam.diff
new file mode 100644
index 000000000000..d2052cf52b85
--- /dev/null
+++ b/devel/boost/files/gcc-tools.jam.diff
@@ -0,0 +1,16 @@
+*** tools/build/gcc-tools.jam.orig Tue Oct 14 21:38:52 2003
+--- tools/build/gcc-tools.jam Tue Oct 14 21:50:16 2003
+***************
+*** 122,127 ****
+--- 122,132 ----
+ GCC ?= cc ;
+ GXX ?= c++ ;
+ }
++ case FreeBSD :
++ {
++ # for current which doesn't support -pthread
++ flags gcc LINKFLAGS <threading>multi : -lc_r ;
++ }
+ case *BSD :
+ {
+ flags gcc CFLAGS <threading>multi : -pthread ;
diff --git a/devel/boost/files/patch-gcc.hpp b/devel/boost/files/patch-gcc.hpp
deleted file mode 100644
index d039c8bd4415..000000000000
--- a/devel/boost/files/patch-gcc.hpp
+++ /dev/null
@@ -1,59 +0,0 @@
-*** boost/config/compiler/gcc.hpp 2003/01/30 18:13:55 1.15
---- boost/config/compiler/gcc.hpp 2003/05/19 12:11:22 1.17
-***************
-*** 28,39 ****
- # define BOOST_NO_OPERATORS_IN_NAMESPACE
- # endif
-
- //
- // Threading support: Turn this on unconditionally here (except for
-! // MinGW, where we can know for sure). It will get turned off again
- // later if no threading API is detected.
- //
-! #if !defined(__MINGW32__) || defined(_MT)
- # define BOOST_HAS_THREADS
- #endif
-
---- 28,43 ----
- # define BOOST_NO_OPERATORS_IN_NAMESPACE
- # endif
-
-+ #ifndef __EXCEPTIONS
-+ # define BOOST_NO_EXCEPTIONS
-+ #endif
-+
- //
- // Threading support: Turn this on unconditionally here (except for
-! // those platforms where we can know for sure). It will get turned off again
- // later if no threading API is detected.
- //
-! #if !defined(__MINGW32__) && !defined(__CYGWIN__) && !defined(linux) && !defined(__linux) && !defined(__linux__)
- # define BOOST_HAS_THREADS
- #endif
-
-***************
-*** 58,68 ****
- # error "Compiler not configured - please reconfigure"
- #endif
- //
-! // last known and checked version is 3.2:
-! #if (__GNUC__ > 3) || ((__GNUC__ == 3) && (__GNUC_MINOR__ > 2))
- # if defined(BOOST_ASSERT_CONFIG)
- # error "Unknown compiler version - please run the configure tests and report the results"
- # else
- # warning "Unknown compiler version - please run the configure tests and report the results"
- # endif
- #endif
---- 62,73 ----
- # error "Compiler not configured - please reconfigure"
- #endif
- //
-! // last known and checked version is 3.3:
-! #if (__GNUC__ > 3) || ((__GNUC__ == 3) && (__GNUC_MINOR__ > 3))
- # if defined(BOOST_ASSERT_CONFIG)
- # error "Unknown compiler version - please run the configure tests and report the results"
- # else
- # warning "Unknown compiler version - please run the configure tests and report the results"
- # endif
- #endif
-+
diff --git a/devel/boost/pkg-plist b/devel/boost/pkg-plist
index 1c2caf5e3c44..8f2c0595d650 100644
--- a/devel/boost/pkg-plist
+++ b/devel/boost/pkg-plist
@@ -1808,6 +1808,11 @@ include/boost/utility_fwd.hpp
include/boost/version.hpp
include/boost/visit_each.hpp
include/boost/weak_ptr.hpp
+lib/libboost_date_time.a
+lib/libboost_date_time.so
+lib/libboost_filesystem.a
+lib/libboost_prg_exec_monitor.a
+lib/libboost_prg_exec_monitor.so
%%BOOST_PYTHON%%lib/libboost_python.a
%%BOOST_PYTHON%%lib/libboost_python.so
%%BOOST_PYTHON%%lib/libboost_python_debug.a
@@ -1818,8 +1823,12 @@ lib/libboost_regex_debug.a
lib/libboost_regex_debug.so
lib/libboost_signals.a
lib/libboost_signals.so
+lib/libboost_test_exec_monitor.a
+lib/libboost_test_exec_monitor.so
lib/libboost_thread.so
lib/libboost_threadd.so
+lib/libboost_unit_test_framework.a
+lib/libboost_unit_test_framework.so
%%PORTDOCS%%share/doc/boost/boost.css
%%PORTDOCS%%share/doc/boost/c++boost.gif
%%PORTDOCS%%share/doc/boost/doc/html/any.html
@@ -1922,6 +1931,7 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/doc/boost/libs/date_time/doc/BasicTerms.html
%%PORTDOCS%%share/doc/boost/libs/date_time/doc/BuildInfo.html
%%PORTDOCS%%share/doc/boost/libs/date_time/doc/Calculations.html
+%%PORTDOCS%%share/doc/boost/libs/date_time/doc/Changes.html
%%PORTDOCS%%share/doc/boost/libs/date_time/doc/DesignGoals.html
%%PORTDOCS%%share/doc/boost/libs/date_time/doc/References.html
%%PORTDOCS%%share/doc/boost/libs/date_time/doc/Tradeoffs.html
@@ -3386,10 +3396,12 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/doc/boost/tools/build/como-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/cwpro8-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/darwin-tools.html
+%%PORTDOCS%%share/doc/boost/tools/build/edg-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/gcc-nocygwin-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/gcc-stlport-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/gcc-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/index.html
+%%PORTDOCS%%share/doc/boost/tools/build/index_v2.html
%%PORTDOCS%%share/doc/boost/tools/build/intel-linux-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/intel-win32-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/jam_src/Jam.html
@@ -3403,14 +3415,17 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/doc/boost/tools/build/mipspro-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/msvc-stlport-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/msvc-tools.html
+%%PORTDOCS%%share/doc/boost/tools/build/sunpro-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/test/test_system.html
%%PORTDOCS%%share/doc/boost/tools/build/tru64cxx-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/vacpp-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/variables.html
%%PORTDOCS%%share/doc/boost/tools/build/vc7-tools.html
+%%PORTDOCS%%share/doc/boost/tools/build/vc7.1-tools.html
%%PORTDOCS%%share/doc/boost/tools/index.html
%%PORTDOCS%%share/doc/boost/tools/inspect/index.html
%%PORTDOCS%%share/doc/boost/tools/regression/index.htm
+%%PORTDOCS%%share/doc/boost/tools/regression/xsl_reports/xsl/master.css
%%PORTDOCS%%share/examples/boost/libs/date_time/example/Jamfile
%%PORTDOCS%%share/examples/boost/libs/date_time/example/gregorian/Jamfile.v2
%%PORTDOCS%%share/examples/boost/libs/date_time/example/gregorian/dates_as_strings.cpp
@@ -3566,9 +3581,9 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/examples/boost/libs/graph/example/makefile-target-names.dat
%%PORTDOCS%%share/examples/boost/libs/graph/example/max_flow.cpp
%%PORTDOCS%%share/examples/boost/libs/graph/example/max_flow.dat
+%%PORTDOCS%%share/examples/boost/libs/graph/example/max_flow.expected
%%PORTDOCS%%share/examples/boost/libs/graph/example/max_flow2.dat
%%PORTDOCS%%share/examples/boost/libs/graph/example/max_flow3.dat
-%%PORTDOCS%%share/examples/boost/libs/graph/example/max_flow.expected
%%PORTDOCS%%share/examples/boost/libs/graph/example/miles_span.cpp
%%PORTDOCS%%share/examples/boost/libs/graph/example/miles_span.expected
%%PORTDOCS%%share/examples/boost/libs/graph/example/min_max_paths.cpp
@@ -3775,7 +3790,6 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_lexer/cpp_lexer_token.hpp
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_lexer/lexer_base.hpp
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_lexer/lexer_token_base.hpp
-%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_lexer/makefile
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_to_html/cpp_to_html.cpp
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_to_html/cpp_to_html_vc6_7.cpp
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_to_html/readme.txt
@@ -3813,6 +3827,7 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/quickdoc/index.html
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/quickdoc/quickdoc.cpp
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/quickdoc/quickdoc.hpp
+%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/quickdoc/quickdoc.txt
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/rfcdate/mystyle.xls
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/rfcdate/peti.css
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/rfcdate/peti.dsl
@@ -3952,6 +3967,79 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/examples/boost/libs/type_traits/examples/fill_example.cpp
%%PORTDOCS%%share/examples/boost/libs/type_traits/examples/iter_swap_example.cpp
%%PORTDOCS%%share/examples/boost/libs/type_traits/examples/trivial_destructor_example.cpp
+%%PORTDOCS%%@dirrm share/examples/boost/libs/type_traits/examples
+%%PORTDOCS%%@dirrm share/examples/boost/libs/type_traits
+%%PORTDOCS%%@dirrm share/examples/boost/libs/thread/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/thread
+%%PORTDOCS%%@dirrm share/examples/boost/libs/test/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/test
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/phoenix/example/fundamental
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/phoenix/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/phoenix
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/fundamental/position_iterator
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/fundamental/calc
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/fundamental
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/xml/goodtest
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/xml
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/slex/testfiles
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/slex
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/rfcdate
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/quickdoc/doc/theme
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/quickdoc/doc
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/quickdoc
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/pascal/test_files
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/pascal
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/cpp_to_html
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/cpp_lexer
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/c/test_files
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/c
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit
+%%PORTDOCS%%@dirrm share/examples/boost/libs/smart_ptr/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/smart_ptr
+%%PORTDOCS%%@dirrm share/examples/boost/libs/signals/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/signals
+%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/timer
+%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/snippets
+%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/jgrep
+%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/iso8859_1_regex_traits
+%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/regex
+%%PORTDOCS%%@dirrm share/examples/boost/libs/python/pyste/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/python/pyste
+%%PORTDOCS%%@dirrm share/examples/boost/libs/python/example/tutorial
+%%PORTDOCS%%@dirrm share/examples/boost/libs/python/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/python
+%%PORTDOCS%%@dirrm share/examples/boost/libs/preprocessor/doc/examples
+%%PORTDOCS%%@dirrm share/examples/boost/libs/preprocessor/doc
+%%PORTDOCS%%@dirrm share/examples/boost/libs/preprocessor
+%%PORTDOCS%%@dirrm share/examples/boost/libs/numeric/interval/examples
+%%PORTDOCS%%@dirrm share/examples/boost/libs/numeric/interval
+%%PORTDOCS%%@dirrm share/examples/boost/libs/numeric
+%%PORTDOCS%%@dirrm share/examples/boost/libs/multi_array/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/multi_array
+%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl/example/fsm/aux_
+%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl/example/fsm
+%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl
+%%PORTDOCS%%@dirrm share/examples/boost/libs/graph/example/figs
+%%PORTDOCS%%@dirrm share/examples/boost/libs/graph/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/graph
+%%PORTDOCS%%@dirrm share/examples/boost/libs/function/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/function
+%%PORTDOCS%%@dirrm share/examples/boost/libs/format/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/format
+%%PORTDOCS%%@dirrm share/examples/boost/libs/filesystem/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/filesystem
+%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time/example/posix_time
+%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time/example/gregorian
+%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time
+%%PORTDOCS%%@dirrm share/examples/boost/libs
+%%PORTDOCS%%@dirrm share/examples/boost
+%%PORTDOCS%%@dirrm share/doc/boost/tools/regression/xsl_reports/xsl
+%%PORTDOCS%%@dirrm share/doc/boost/tools/regression/xsl_reports
%%PORTDOCS%%@dirrm share/doc/boost/tools/regression
%%PORTDOCS%%@dirrm share/doc/boost/tools/inspect
%%PORTDOCS%%@dirrm share/doc/boost/tools/build/test
@@ -4091,77 +4179,6 @@ lib/libboost_threadd.so
%%PORTDOCS%%@dirrm share/doc/boost/doc/html
%%PORTDOCS%%@dirrm share/doc/boost/doc
%%PORTDOCS%%@dirrm share/doc/boost
-%%PORTDOCS%%@dirrm share/examples/boost/libs/type_traits/examples
-%%PORTDOCS%%@dirrm share/examples/boost/libs/type_traits
-%%PORTDOCS%%@dirrm share/examples/boost/libs/thread/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/thread
-%%PORTDOCS%%@dirrm share/examples/boost/libs/test/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/test
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/phoenix/example/fundamental
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/phoenix/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/phoenix
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/fundamental/position_iterator
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/fundamental/calc
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/fundamental
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/xml/goodtest
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/xml
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/slex/testfiles
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/slex
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/rfcdate
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/quickdoc/doc/theme
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/quickdoc/doc
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/quickdoc
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/pascal/test_files
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/pascal
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/cpp_to_html
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/cpp_lexer
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/c/test_files
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/c
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit
-%%PORTDOCS%%@dirrm share/examples/boost/libs/smart_ptr/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/smart_ptr
-%%PORTDOCS%%@dirrm share/examples/boost/libs/signals/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/signals
-%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/timer
-%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/snippets
-%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/jgrep
-%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/iso8859_1_regex_traits
-%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/regex
-%%PORTDOCS%%@dirrm share/examples/boost/libs/python/pyste/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/python/pyste
-%%PORTDOCS%%@dirrm share/examples/boost/libs/python/example/tutorial
-%%PORTDOCS%%@dirrm share/examples/boost/libs/python/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/python
-%%PORTDOCS%%@dirrm share/examples/boost/libs/preprocessor/doc/examples
-%%PORTDOCS%%@dirrm share/examples/boost/libs/preprocessor/doc
-%%PORTDOCS%%@dirrm share/examples/boost/libs/preprocessor
-%%PORTDOCS%%@dirrm share/examples/boost/libs/numeric/interval/examples
-%%PORTDOCS%%@dirrm share/examples/boost/libs/numeric/interval
-%%PORTDOCS%%@dirrm share/examples/boost/libs/numeric
-%%PORTDOCS%%@dirrm share/examples/boost/libs/multi_array/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/multi_array
-%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl/example/fsm/aux_
-%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl/example/fsm
-%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl
-%%PORTDOCS%%@dirrm share/examples/boost/libs/graph/example/figs
-%%PORTDOCS%%@dirrm share/examples/boost/libs/graph/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/graph
-%%PORTDOCS%%@dirrm share/examples/boost/libs/function/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/function
-%%PORTDOCS%%@dirrm share/examples/boost/libs/format/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/format
-%%PORTDOCS%%@dirrm share/examples/boost/libs/filesystem/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/filesystem
-%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time/example/posix_time
-%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time/example/gregorian
-%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time
-%%PORTDOCS%%@dirrm share/examples/boost/libs
-%%PORTDOCS%%@dirrm share/examples/boost
@dirrm include/boost/utility
@dirrm include/boost/type_traits/detail
@dirrm include/boost/type_traits