aboutsummaryrefslogtreecommitdiff
path: root/devel/bugzilla
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2007-05-27 13:16:35 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2007-05-27 13:16:35 +0000
commit95113314ed0df7cbd2ae19f073ac92d2b3b4a191 (patch)
tree41bc870e045a6b38e8898af9d4c411a4da7718ab /devel/bugzilla
parenta717cbeb82ec1c0d20dbe00d99fb71929bc4abfa (diff)
downloadports-95113314ed0df7cbd2ae19f073ac92d2b3b4a191.tar.gz
ports-95113314ed0df7cbd2ae19f073ac92d2b3b4a191.zip
Upgrade Bugzilla to 3.0; repocopy 2.x branch to devel/bugzilla2
Notes
Notes: svn path=/head/; revision=192026
Diffstat (limited to 'devel/bugzilla')
-rw-r--r--devel/bugzilla/Makefile70
-rw-r--r--devel/bugzilla/distinfo6
-rw-r--r--devel/bugzilla/pkg-plist97
3 files changed, 129 insertions, 44 deletions
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index 4bb9ee40bb50..3d98a30d7515 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME?= bugzilla
-PORTVERSION?= 2.22.2
-PORTREVISION= 1
+PORTVERSION?= 3.0
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= webtools webtools/archived
@@ -15,25 +14,31 @@ MASTER_SITE_SUBDIR= webtools webtools/archived
MAINTAINER?= skv@FreeBSD.org
COMMENT?= Bug-tracking system developed by Mozilla Project
-OPTIONS= MYSQL "MySQL database support" on \
+OPTIONS= MYSQL "MySQL database support" off \
PGSQL "PostgreSQL database support" off \
+ GRAPH_REPORTS "Graphical Reports" on \
CHARTING_MODULES "Bug charting support" on \
+ PATCH_VIEWER "Patch Viewer" on \
+ MORE_HTML "More HTML in Product/Group Descriptions" on \
+ INBOUND_EMAIL "Inbound Email" off \
+ MOVE_BUGZ "Move Bugs Between Installations" off \
+ BMP2PNG "BMP Attachments to PNGs" off \
+ XMLRPC "XML-RPC Interface" off \
+ MODPERL2 "With mod_perl2 support" off \
GRAPHVIZ "Use GraphViz" off \
EXPORT_IMPORT "Import/export bugs (via XML)" off \
CONTRIB "Install user-contributed scripts" off \
- LDAP "Enable LDAP support" off
+ LDAP "LDAP Authentication" off
RUN_DEPENDS+= \
${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
- ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig \
${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
- ${SITE_PERL}/Text/Wrap.pm:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap \
${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper \
${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
- ${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/Mail/Mailer.pm:${PORTSDIR}/mail/p5-Mail-Tools \
- ${SITE_PERL}/PatchReader.pm:${PORTSDIR}/devel/p5-PatchReader
+ ${SITE_PERL}/Email/Send.pm:${PORTSDIR}/mail/p5-Email-Send \
+ ${SITE_PERL}/Email/MIME/Modifier.pm:${PORTSDIR}/mail/p5-Email-MIME-Modifier
CONFLICTS?= ja-bugzilla-2.*
@@ -52,7 +57,6 @@ BUGZILLADIR= ${PREFIX}/www/data/bugzilla
PLIST_SUB+= BUGZILLADIR=${BUGZILLADIR:S!^${PREFIX}/!!}
-CONTRIB_DOCS= README README.Mailif bugmail_help.html bugzilla.procmailrc
DATA_DIRS_LIST= images js skins/standard skins/standard/global \
skins/standard/index
@@ -69,11 +73,47 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-P
USE_PGSQL= yes
.endif
-.ifdef WITH_CHARTING_MODULES
+.ifdef WITH_GRAPH_REPORTS
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
- ${SITE_PERL}/Chart/Base.pm:${PORTSDIR}/graphics/p5-chart \
${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
- ${SITE_PERL}/GD/Text/Align.pm:${PORTSDIR}/graphics/p5-GD-TextUtil
+ ${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil \
+ ${SITE_PERL}/Template/Plugin/GD/Image:${PORTSDIR}/www/p5-Template-GD
+.endif
+
+.ifdef WITH_CHARTING_MODULES
+RUN_DEPENDS+= ${SITE_PERL}/Chart/Base.pm:${PORTSDIR}/graphics/p5-chart
+.endif
+
+.ifdef WITH_PATCH_VIEWER
+RUN_DEPENDS+= ${SITE_PERL}/PatchReader.pm:${PORTSDIR}/devel/p5-PatchReader
+.endif
+
+.ifdef WITH_MORE_HTML
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/HTML/Scrubber.pm:${PORTSDIR}/www/p5-HTML-Scrubber
+.endif
+
+.ifdef WITH_INBOUND_EMAIL
+RUN_DEPENDS+= ${SITE_PERL}/Email/MIME/Attachment/Stripper.pm:${PORTSDIR}/mail/p5-Email-MIME-Attachment-Stripper \
+ ${SITE_PERL}/Email/Reply:${PORTSDIR}/mail/p5-Email-Reply
+.endif
+
+.ifdef WITH_MOVE_BUGZ
+RUN_DEPENDS+= ${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+ ${SITE_PERL}/XML/Twig.pm:${PORTSDIR}/textproc/p5-XML-Twig
+.endif
+
+.ifdef WITH_BMP2PNG
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
+.endif
+
+.ifdef WITH_XMLRPC
+RUN_DEPENDS+= ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+.endif
+
+.ifdef WITH_MODPERL2
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2 \
+ ${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI
.endif
.ifdef WITH_GRAPHVIZ
@@ -127,10 +167,6 @@ do-install:
@cd ${WRKSRC}/contrib && \
${FIND} . -type d -exec ${MKDIR} "${BUGZILLADIR}/contrib/{}" \; && \
${FIND} . -type f -exec ${INSTALL_DATA} "{}" "${BUGZILLADIR}/contrib/{}" \;
-.ifndef NOPORTDOCS
- ${MKDIR} ${DOCSDIR}/contrib
- ${INSTALL_DATA} ${CONTRIB_DOCS:S!^!${WRKSRC}/contrib/!} ${DOCSDIR}/contrib
-.endif
.endif
.if !defined(BATCH)
@${ECHO_MSG}
diff --git a/devel/bugzilla/distinfo b/devel/bugzilla/distinfo
index bb739ca52659..a22d6730f476 100644
--- a/devel/bugzilla/distinfo
+++ b/devel/bugzilla/distinfo
@@ -1,3 +1,3 @@
-MD5 (bugzilla-2.22.2.tar.gz) = fb7fdcaacf5efad6f3bd5a1a810c467f
-SHA256 (bugzilla-2.22.2.tar.gz) = 211bc10439b968fb67a4d7ddd25223d969bd347dab23b2a87ef4ecb9f249cce0
-SIZE (bugzilla-2.22.2.tar.gz) = 1937836
+MD5 (bugzilla-3.0.tar.gz) = 9a56a47cdbfcb70a85ad73d923ac7e9d
+SHA256 (bugzilla-3.0.tar.gz) = bd2f4e05fb1ef4edda3ed3234e195331ca777b5d3cce9c88269a6cedeaba0049
+SIZE (bugzilla-3.0.tar.gz) = 2170586
diff --git a/devel/bugzilla/pkg-plist b/devel/bugzilla/pkg-plist
index 00ca5a0e4de0..78aaf97a7091 100644
--- a/devel/bugzilla/pkg-plist
+++ b/devel/bugzilla/pkg-plist
@@ -1,7 +1,3 @@
-%%CONTRIB%%%%PORTDOCS%%%%DOCSDIR%%/contrib/README
-%%CONTRIB%%%%PORTDOCS%%%%DOCSDIR%%/contrib/README.Mailif
-%%CONTRIB%%%%PORTDOCS%%%%DOCSDIR%%/contrib/bugmail_help.html
-%%CONTRIB%%%%PORTDOCS%%%%DOCSDIR%%/contrib/bugzilla.procmailrc
%%PORTDOCS%%%%DOCSDIR%%/html/Bugzilla-Guide.html
%%PORTDOCS%%%%DOCSDIR%%/html/about.html
%%PORTDOCS%%%%DOCSDIR%%/html/administration.html
@@ -18,9 +14,10 @@
%%PORTDOCS%%%%DOCSDIR%%/html/credits.html
%%PORTDOCS%%%%DOCSDIR%%/html/cust-change-permissions.html
%%PORTDOCS%%%%DOCSDIR%%/html/cust-hooks.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cust-skins.html
%%PORTDOCS%%%%DOCSDIR%%/html/cust-templates.html
%%PORTDOCS%%%%DOCSDIR%%/html/customization.html
-%%PORTDOCS%%%%DOCSDIR%%/html/dbmodify.html
+%%PORTDOCS%%%%DOCSDIR%%/html/custom-fields.html
%%PORTDOCS%%%%DOCSDIR%%/html/disclaimer.html
%%PORTDOCS%%%%DOCSDIR%%/html/edit-values.html
%%PORTDOCS%%%%DOCSDIR%%/html/extraconfig.html
@@ -70,6 +67,7 @@
%%PORTDOCS%%%%DOCSDIR%%/html/security-os.html
%%PORTDOCS%%%%DOCSDIR%%/html/security-webserver.html
%%PORTDOCS%%%%DOCSDIR%%/html/security.html
+%%PORTDOCS%%%%DOCSDIR%%/html/timetracking.html
%%PORTDOCS%%%%DOCSDIR%%/html/trbl-dbdsponge.html
%%PORTDOCS%%%%DOCSDIR%%/html/trbl-index.html
%%PORTDOCS%%%%DOCSDIR%%/html/trbl-passwd-encryption.html
@@ -77,7 +75,6 @@
%%PORTDOCS%%%%DOCSDIR%%/html/trbl-relogin-everyone.html
%%PORTDOCS%%%%DOCSDIR%%/html/trbl-relogin-some.html
%%PORTDOCS%%%%DOCSDIR%%/html/trbl-testserver.html
-%%PORTDOCS%%%%DOCSDIR%%/html/trouble-filetemp.html
%%PORTDOCS%%%%DOCSDIR%%/html/troubleshooting.html
%%PORTDOCS%%%%DOCSDIR%%/html/upgrading.html
%%PORTDOCS%%%%DOCSDIR%%/html/useradmin.html
@@ -87,7 +84,7 @@
%%PORTDOCS%%%%DOCSDIR%%/html/versions.html
%%PORTDOCS%%%%DOCSDIR%%/html/voting.html
%%PORTDOCS%%%%DOCSDIR%%/html/whining.html
-%%PORTDOCS%%%%DOCSDIR%%/html/x763.html
+%%PORTDOCS%%%%DOCSDIR%%/html/x834.html
%%PORTDOCS%%%%DOCSDIR%%/images/bzLifecycle.png
%%PORTDOCS%%%%DOCSDIR%%/images/bzLifecycle.xml
%%PORTDOCS%%%%DOCSDIR%%/images/callouts/1.gif
@@ -104,6 +101,7 @@
%%PORTDOCS%%%%DOCSDIR%%/xml/Bugzilla-Guide.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/about.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/administration.xml
+%%PORTDOCS%%%%DOCSDIR%%/xml/bugzilla.ent
%%PORTDOCS%%%%DOCSDIR%%/xml/conventions.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/customization.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/dbschema.mysql
@@ -122,14 +120,18 @@
%%PORTDOCS%%%%DOCSDIR%%/xml/troubleshooting.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/using.xml
%%BUGZILLADIR%%/Bugzilla/Attachment.pm
+%%BUGZILLADIR%%/Bugzilla/Attachment/PatchReader.pm
%%BUGZILLADIR%%/Bugzilla/Auth.pm
-%%BUGZILLADIR%%/Bugzilla/Auth/Login/WWW.pm
-%%BUGZILLADIR%%/Bugzilla/Auth/Login/WWW/CGI.pm
-%%BUGZILLADIR%%/Bugzilla/Auth/Login/WWW/Env.pm
-%%BUGZILLADIR%%/Bugzilla/Auth/Login/WWW/CGI/Cookie.pm
-%%BUGZILLADIR%%/Bugzilla/Auth/README
+%%BUGZILLADIR%%/Bugzilla/Auth/Login.pm
+%%BUGZILLADIR%%/Bugzilla/Auth/Verify.pm
+%%BUGZILLADIR%%/Bugzilla/Auth/Login/CGI.pm
+%%BUGZILLADIR%%/Bugzilla/Auth/Login/Cookie.pm
+%%BUGZILLADIR%%/Bugzilla/Auth/Login/Env.pm
+%%BUGZILLADIR%%/Bugzilla/Auth/Login/Stack.pm
+%%BUGZILLADIR%%/Bugzilla/Auth/Persist/Cookie.pm
%%BUGZILLADIR%%/Bugzilla/Auth/Verify/DB.pm
%%BUGZILLADIR%%/Bugzilla/Auth/Verify/LDAP.pm
+%%BUGZILLADIR%%/Bugzilla/Auth/Verify/Stack.pm
%%BUGZILLADIR%%/Bugzilla/Bug.pm
%%BUGZILLADIR%%/Bugzilla/BugMail.pm
%%BUGZILLADIR%%/Bugzilla/CGI.pm
@@ -166,10 +168,20 @@
%%BUGZILLADIR%%/Bugzilla/Flag.pm
%%BUGZILLADIR%%/Bugzilla/FlagType.pm
%%BUGZILLADIR%%/Bugzilla/Group.pm
+%%BUGZILLADIR%%/Bugzilla/Hook.pm
+%%BUGZILLADIR%%/Bugzilla/Install.pm
+%%BUGZILLADIR%%/Bugzilla/Install/DB.pm
+%%BUGZILLADIR%%/Bugzilla/Install/Filesystem.pm
+%%BUGZILLADIR%%/Bugzilla/Install/Localconfig.pm
+%%BUGZILLADIR%%/Bugzilla/Install/Requirements.pm
+%%BUGZILLADIR%%/Bugzilla/Keyword.pm
+%%BUGZILLADIR%%/Bugzilla/Mailer.pm
%%BUGZILLADIR%%/Bugzilla/Milestone.pm
+%%BUGZILLADIR%%/Bugzilla/Object.pm
%%BUGZILLADIR%%/Bugzilla/Product.pm
%%BUGZILLADIR%%/Bugzilla/Search.pm
%%BUGZILLADIR%%/Bugzilla/Search/Quicksearch.pm
+%%BUGZILLADIR%%/Bugzilla/Search/Saved.pm
%%BUGZILLADIR%%/Bugzilla/Series.pm
%%BUGZILLADIR%%/Bugzilla/Template.pm
%%BUGZILLADIR%%/Bugzilla/Template/Plugin/Bugzilla.pm
@@ -178,8 +190,16 @@
%%BUGZILLADIR%%/Bugzilla/Token.pm
%%BUGZILLADIR%%/Bugzilla/User.pm
%%BUGZILLADIR%%/Bugzilla/User/Setting.pm
+%%BUGZILLADIR%%/Bugzilla/User/Setting/Skin.pm
+%%BUGZILLADIR%%/Bugzilla/Update.pm
%%BUGZILLADIR%%/Bugzilla/Util.pm
%%BUGZILLADIR%%/Bugzilla/Version.pm
+%%BUGZILLADIR%%/Bugzilla/WebService.pm
+%%BUGZILLADIR%%/Bugzilla/WebService/Bugzilla.pm
+%%BUGZILLADIR%%/Bugzilla/WebService/Bug.pm
+%%BUGZILLADIR%%/Bugzilla/WebService/Constants.pm
+%%BUGZILLADIR%%/Bugzilla/WebService/Product.pm
+%%BUGZILLADIR%%/Bugzilla/WebService/User.pm
%%BUGZILLADIR%%/Bugzilla.pm
%%BUGZILLADIR%%/QUICKSTART
%%BUGZILLADIR%%/README
@@ -191,36 +211,37 @@
%%BUGZILLADIR%%/colchange.cgi
%%BUGZILLADIR%%/collectstats.pl
%%BUGZILLADIR%%/config.cgi
+%%BUGZILLADIR%%/js/attachment.js
%%BUGZILLADIR%%/js/duplicates.js
+%%BUGZILLADIR%%/js/expanding-tree.js
%%BUGZILLADIR%%/js/productform.js
%%BUGZILLADIR%%/js/TUI.js
+%%BUGZILLADIR%%/skins/standard/IE-fixes.css
%%BUGZILLADIR%%/skins/standard/admin.css
%%BUGZILLADIR%%/skins/standard/buglist.css
+%%BUGZILLADIR%%/skins/standard/create_attachment.css
+%%BUGZILLADIR%%/skins/standard/dependency-tree.css
%%BUGZILLADIR%%/skins/standard/duplicates.css
%%BUGZILLADIR%%/skins/standard/editusers.css
%%BUGZILLADIR%%/skins/standard/global.css
%%BUGZILLADIR%%/skins/standard/index.css
%%BUGZILLADIR%%/skins/standard/panel.css
%%BUGZILLADIR%%/skins/standard/params.css
+%%BUGZILLADIR%%/skins/standard/release-notes.css
%%BUGZILLADIR%%/skins/standard/show_multiple.css
%%BUGZILLADIR%%/skins/standard/summarize-time.css
%%BUGZILLADIR%%/skins/standard/voting.css
%%BUGZILLADIR%%/skins/standard/global/body-back.gif
%%BUGZILLADIR%%/skins/standard/global/header.png
%%BUGZILLADIR%%/skins/standard/index/front.png
-%%CONTRIB%%%%BUGZILLADIR%%/contrib/BugzillaEmail.pm
%%CONTRIB%%%%BUGZILLADIR%%/contrib/README
-%%CONTRIB%%%%BUGZILLADIR%%/contrib/README.Mailif
-%%CONTRIB%%%%BUGZILLADIR%%/contrib/bug_email.pl
-%%CONTRIB%%%%BUGZILLADIR%%/contrib/bugmail_help.html
%%CONTRIB%%%%BUGZILLADIR%%/contrib/bugzilla-submit/README
%%CONTRIB%%%%BUGZILLADIR%%/contrib/bugzilla-submit/bugdata.txt
%%CONTRIB%%%%BUGZILLADIR%%/contrib/bugzilla-submit/bugzilla-submit
%%CONTRIB%%%%BUGZILLADIR%%/contrib/bugzilla-submit/bugzilla-submit.xml
-%%CONTRIB%%%%BUGZILLADIR%%/contrib/bugzilla.procmailrc
-%%CONTRIB%%%%BUGZILLADIR%%/contrib/bugzilla_email_append.pl
%%CONTRIB%%%%BUGZILLADIR%%/contrib/bugzilla_ldapsync.rb
%%CONTRIB%%%%BUGZILLADIR%%/contrib/bzdbcopy.pl
+%%CONTRIB%%%%BUGZILLADIR%%/contrib/bz_webservice_demo.pl
%%CONTRIB%%%%BUGZILLADIR%%/contrib/cmdline/bugcount
%%CONTRIB%%%%BUGZILLADIR%%/contrib/cmdline/bugids
%%CONTRIB%%%%BUGZILLADIR%%/contrib/cmdline/buglist
@@ -237,6 +258,7 @@
%%CONTRIB%%%%BUGZILLADIR%%/contrib/jb2bz.py
%%CONTRIB%%%%BUGZILLADIR%%/contrib/merge-users.pl
%%CONTRIB%%%%BUGZILLADIR%%/contrib/mysqld-watcher.pl
+%%CONTRIB%%%%BUGZILLADIR%%/contrib/recode.pl
%%CONTRIB%%%%BUGZILLADIR%%/contrib/sendbugmail.pl
%%CONTRIB%%%%BUGZILLADIR%%/contrib/sendunsentbugmail.pl
%%CONTRIB%%%%BUGZILLADIR%%/contrib/syncLDAP.pl
@@ -248,6 +270,7 @@
%%BUGZILLADIR%%/duplicates.xul
%%BUGZILLADIR%%/editclassifications.cgi
%%BUGZILLADIR%%/editcomponents.cgi
+%%BUGZILLADIR%%/editfields.cgi
%%BUGZILLADIR%%/editflagtypes.cgi
%%BUGZILLADIR%%/editgroups.cgi
%%BUGZILLADIR%%/editkeywords.cgi
@@ -259,12 +282,13 @@
%%BUGZILLADIR%%/editvalues.cgi
%%BUGZILLADIR%%/editversions.cgi
%%BUGZILLADIR%%/editwhines.cgi
+%%BUGZILLADIR%%/email_in.pl
%%BUGZILLADIR%%/enter_bug.cgi
-%%BUGZILLADIR%%/globals.pl
%%BUGZILLADIR%%/images/padlock.png
%%BUGZILLADIR%%/importxml.pl
%%BUGZILLADIR%%/index.cgi
%%BUGZILLADIR%%/long_list.cgi
+%%BUGZILLADIR%%/mod_perl.pl
%%BUGZILLADIR%%/page.cgi
%%BUGZILLADIR%%/post_bug.cgi
%%BUGZILLADIR%%/process_bug.cgi
@@ -278,6 +302,7 @@
%%BUGZILLADIR%%/robots.txt
%%BUGZILLADIR%%/runtests.pl
%%BUGZILLADIR%%/sanitycheck.cgi
+%%BUGZILLADIR%%/search_plugin.cgi
%%BUGZILLADIR%%/show_activity.cgi
%%BUGZILLADIR%%/show_bug.cgi
%%BUGZILLADIR%%/showattachment.cgi
@@ -285,7 +310,6 @@
%%BUGZILLADIR%%/showdependencytree.cgi
%%BUGZILLADIR%%/sidebar.cgi
%%BUGZILLADIR%%/summarize_time.cgi
-%%BUGZILLADIR%%/template/en/default/account/auth/ldap-error.html.tmpl
%%BUGZILLADIR%%/template/en/default/account/auth/login.html.tmpl
%%BUGZILLADIR%%/template/en/default/account/auth/login-small.html.tmpl
%%BUGZILLADIR%%/template/en/default/account/cancel-token.txt.tmpl
@@ -294,7 +318,8 @@
%%BUGZILLADIR%%/template/en/default/account/email/change-new.txt.tmpl
%%BUGZILLADIR%%/template/en/default/account/email/change-old.txt.tmpl
%%BUGZILLADIR%%/template/en/default/account/email/confirm.html.tmpl
-%%BUGZILLADIR%%/template/en/default/account/exists.html.tmpl
+%%BUGZILLADIR%%/template/en/default/account/email/confirm-new.html.tmpl
+%%BUGZILLADIR%%/template/en/default/account/email/request-new.txt.tmpl
%%BUGZILLADIR%%/template/en/default/account/password/forgotten-password.txt.tmpl
%%BUGZILLADIR%%/template/en/default/account/password/set-forgotten-password.html.tmpl
%%BUGZILLADIR%%/template/en/default/account/prefs/account.html.tmpl
@@ -303,6 +328,7 @@
%%BUGZILLADIR%%/template/en/default/account/prefs/prefs.html.tmpl
%%BUGZILLADIR%%/template/en/default/account/prefs/saved-searches.html.tmpl
%%BUGZILLADIR%%/template/en/default/account/prefs/settings.html.tmpl
+%%BUGZILLADIR%%/template/en/default/account/profile-activity.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/confirm-action.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/sudo.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/table.html.tmpl
@@ -323,6 +349,9 @@
%%BUGZILLADIR%%/template/en/default/admin/components/list.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/components/select-product.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/components/updated.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/custom_fields/create.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/custom_fields/edit.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/custom_fields/list.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/fieldvalues/confirm-delete.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/fieldvalues/create.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/fieldvalues/created.html.tmpl
@@ -409,9 +438,12 @@
%%BUGZILLADIR%%/template/en/default/admin/versions/select-product.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/versions/updated.html.tmpl
%%BUGZILLADIR%%/template/en/default/attachment/choose.html.tmpl
+%%BUGZILLADIR%%/template/en/default/attachment/confirm-delete.html.tmpl
%%BUGZILLADIR%%/template/en/default/attachment/content-types.html.tmpl
%%BUGZILLADIR%%/template/en/default/attachment/create.html.tmpl
%%BUGZILLADIR%%/template/en/default/attachment/created.html.tmpl
+%%BUGZILLADIR%%/template/en/default/attachment/createformcontents.html.tmpl
+%%BUGZILLADIR%%/template/en/default/attachment/delete_reason.txt.tmpl
%%BUGZILLADIR%%/template/en/default/attachment/diff-file.html.tmpl
%%BUGZILLADIR%%/template/en/default/attachment/diff-footer.html.tmpl
%%BUGZILLADIR%%/template/en/default/attachment/diff-header.html.tmpl
@@ -425,6 +457,7 @@
%%BUGZILLADIR%%/template/en/default/bug/comments.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/create/comment-guided.txt.tmpl
%%BUGZILLADIR%%/template/en/default/bug/create/comment.txt.tmpl
+%%BUGZILLADIR%%/template/en/default/bug/create/confirm-create-dupe.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/create/create-guided.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/create/create.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/create/created.html.tmpl
@@ -433,6 +466,7 @@
%%BUGZILLADIR%%/template/en/default/bug/dependency-graph.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/dependency-tree.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/edit.html.tmpl
+%%BUGZILLADIR%%/template/en/default/bug/field.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/knob.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/navigate.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/process/bugmail.html.tmpl
@@ -452,13 +486,18 @@
%%BUGZILLADIR%%/template/en/default/config.js.tmpl
%%BUGZILLADIR%%/template/en/default/config.rdf.tmpl
%%BUGZILLADIR%%/template/en/default/email/sudo.txt.tmpl
+%%BUGZILLADIR%%/template/en/default/email/newchangedmail.txt.tmpl
+%%BUGZILLADIR%%/template/en/default/email/votes-removed.txt.tmpl
+%%BUGZILLADIR%%/template/en/default/email/whine.txt.tmpl
%%BUGZILLADIR%%/template/en/default/filterexceptions.pl
%%BUGZILLADIR%%/template/en/default/flag/list.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/banner.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/choose-classification.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/choose-product.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/code-error.html.tmpl
+%%BUGZILLADIR%%/template/en/default/global/common-links.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/confirm-user-match.html.tmpl
+%%BUGZILLADIR%%/template/en/default/global/docslinks.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/field-descs.none.tmpl
%%BUGZILLADIR%%/template/en/default/global/footer.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/header.html.tmpl
@@ -466,6 +505,7 @@
%%BUGZILLADIR%%/template/en/default/global/help.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/hidden-fields.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/initialize.none.tmpl
+%%BUGZILLADIR%%/template/en/default/global/js-products.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/message.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/messages.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/message.txt.tmpl
@@ -474,6 +514,7 @@
%%BUGZILLADIR%%/template/en/default/global/setting-descs.none.tmpl
%%BUGZILLADIR%%/template/en/default/global/site-navigation.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/tabs.html.tmpl
+%%BUGZILLADIR%%/template/en/default/global/textarea.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/useful-links.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/user-error.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/userselect.html.tmpl
@@ -497,6 +538,7 @@
%%BUGZILLADIR%%/template/en/default/pages/linkify.html.tmpl
%%BUGZILLADIR%%/template/en/default/pages/quicksearch.html.tmpl
%%BUGZILLADIR%%/template/en/default/pages/quicksearchhack.html.tmpl
+%%BUGZILLADIR%%/template/en/default/pages/release-notes.html.tmpl
%%BUGZILLADIR%%/template/en/default/pages/sudo.html.tmpl
%%BUGZILLADIR%%/template/en/default/pages/voting.html.tmpl
%%BUGZILLADIR%%/template/en/default/reports/chart.csv.tmpl
@@ -511,6 +553,7 @@
%%BUGZILLADIR%%/template/en/default/reports/edit-series.html.tmpl
%%BUGZILLADIR%%/template/en/default/reports/keywords.html.tmpl
%%BUGZILLADIR%%/template/en/default/reports/menu.html.tmpl
+%%BUGZILLADIR%%/template/en/default/reports/old-charts.html.tmpl
%%BUGZILLADIR%%/template/en/default/reports/report-bar.png.tmpl
%%BUGZILLADIR%%/template/en/default/reports/report-line.png.tmpl
%%BUGZILLADIR%%/template/en/default/reports/report-pie.png.tmpl
@@ -529,12 +572,14 @@
%%BUGZILLADIR%%/template/en/default/search/search-advanced.html.tmpl
%%BUGZILLADIR%%/template/en/default/search/search-create-series.html.tmpl
%%BUGZILLADIR%%/template/en/default/search/search-help.html.tmpl
+%%BUGZILLADIR%%/template/en/default/search/search-plugin.xml.tmpl
%%BUGZILLADIR%%/template/en/default/search/search-report-graph.html.tmpl
%%BUGZILLADIR%%/template/en/default/search/search-report-select.html.tmpl
%%BUGZILLADIR%%/template/en/default/search/search-report-table.html.tmpl
%%BUGZILLADIR%%/template/en/default/search/search-specific.html.tmpl
%%BUGZILLADIR%%/template/en/default/search/tabs.html.tmpl
%%BUGZILLADIR%%/template/en/default/sidebar.xul.tmpl
+%%BUGZILLADIR%%/template/en/default/welcome-admin.html.tmpl
%%BUGZILLADIR%%/template/en/default/whine/mail.html.tmpl
%%BUGZILLADIR%%/template/en/default/whine/mail.txt.tmpl
%%BUGZILLADIR%%/template/en/default/whine/multipart-mime.txt.tmpl
@@ -548,6 +593,7 @@
%%BUGZILLADIR%%/whine.pl
%%BUGZILLADIR%%/whineatnews.pl
%%BUGZILLADIR%%/xml.cgi
+%%BUGZILLADIR%%/xmlrpc.cgi
@dirrm %%BUGZILLADIR%%/template/en/extension
@dirrm %%BUGZILLADIR%%/template/en/default/whine
@dirrm %%BUGZILLADIR%%/template/en/default/search
@@ -575,6 +621,7 @@
@dirrm %%BUGZILLADIR%%/template/en/default/admin/groups
@dirrm %%BUGZILLADIR%%/template/en/default/admin/fieldvalues
@dirrm %%BUGZILLADIR%%/template/en/default/admin/flag-type
+@dirrm %%BUGZILLADIR%%/template/en/default/admin/custom_fields
@dirrm %%BUGZILLADIR%%/template/en/default/admin/components
@dirrm %%BUGZILLADIR%%/template/en/default/admin/classifications
@dirrm %%BUGZILLADIR%%/template/en/default/admin
@@ -590,18 +637,21 @@
%%CONTRIB%%@dirrm %%BUGZILLADIR%%/contrib/cmdline
%%CONTRIB%%@dirrm %%BUGZILLADIR%%/contrib/bugzilla-submit
%%CONTRIB%%@dirrm %%BUGZILLADIR%%/contrib
+@dirrm %%BUGZILLADIR%%/Bugzilla/WebService
+@dirrm %%BUGZILLADIR%%/Bugzilla/User/Setting
@dirrm %%BUGZILLADIR%%/Bugzilla/User
@dirrm %%BUGZILLADIR%%/Bugzilla/Template/Plugin
@dirrm %%BUGZILLADIR%%/Bugzilla/Template
@dirrm %%BUGZILLADIR%%/Bugzilla/Search
+@dirrm %%BUGZILLADIR%%/Bugzilla/Install
@dirrm %%BUGZILLADIR%%/Bugzilla/DB/Schema
@dirrm %%BUGZILLADIR%%/Bugzilla/DB
@dirrm %%BUGZILLADIR%%/Bugzilla/Config
@dirrm %%BUGZILLADIR%%/Bugzilla/Auth/Verify
-@dirrm %%BUGZILLADIR%%/Bugzilla/Auth/Login/WWW/CGI
-@dirrm %%BUGZILLADIR%%/Bugzilla/Auth/Login/WWW
+@dirrm %%BUGZILLADIR%%/Bugzilla/Auth/Persist
@dirrm %%BUGZILLADIR%%/Bugzilla/Auth/Login
@dirrm %%BUGZILLADIR%%/Bugzilla/Auth
+@dirrm %%BUGZILLADIR%%/Bugzilla/Attachment
@dirrmtry %%BUGZILLADIR%%/Bugzilla
@dirrmtry %%BUGZILLADIR%%/data
@dirrmtry %%BUGZILLADIR%%/graphs
@@ -618,6 +668,5 @@
%%PORTDOCS%%@dirrm %%DOCSDIR%%/images/callouts
%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-%%CONTRIB%%%%PORTDOCS%%@dirrm %%DOCSDIR%%/contrib
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry www/data