aboutsummaryrefslogtreecommitdiff
path: root/devel/bzr/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-03-04 05:04:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-03-04 05:04:45 +0000
commit678d4b9b5f7ea17702f04bb8fccfaa93acb960a3 (patch)
treeb8a1b742a80bb37650f1c43872d517b2688f4689 /devel/bzr/Makefile
parentfb96a24d16b4a5ada97d1ae325715b0891327941 (diff)
downloadports-678d4b9b5f7ea17702f04bb8fccfaa93acb960a3.tar.gz
ports-678d4b9b5f7ea17702f04bb8fccfaa93acb960a3.zip
- Update to 2.5
PR: 165445 Submitted by: Matthew D.Fuller <fullermd@over-yonder.net> (maintainer)
Notes
Notes: svn path=/head/; revision=292632
Diffstat (limited to 'devel/bzr/Makefile')
-rw-r--r--devel/bzr/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/bzr/Makefile b/devel/bzr/Makefile
index a56a02cdce01..54e7abb795bf 100644
--- a/devel/bzr/Makefile
+++ b/devel/bzr/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= bazaar-ng
-PORTVERSION= 2.4.2
+PORTVERSION= 2.5.0
CATEGORIES= devel
-MASTER_SITES= https://launchpadlibrarian.net/83821237/
+MASTER_SITES= https://launchpadlibrarian.net/94128585/
DISTNAME= bzr-${PORTVERSION}
MAINTAINER= fullermd@over-yonder.net
@@ -17,7 +17,8 @@ COMMENT= Distributed version control system by Canonical
# Often not needed, but it's cheap insurance
BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython
-OPTIONS= SFTP "Enable Paramiko for SFTP support" on
+OPTIONS= SFTP "Enable Paramiko for SFTP support" on \
+ CA_BUNDLE "Include CA bundle for SSL cert validation" on
USE_PYTHON= 2.6+
USE_PYDISTUTILS= yes
@@ -31,6 +32,10 @@ MAN1= bzr.1
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/paramiko/__init__.py:${PORTSDIR}/security/py-paramiko
.endif
+.if !defined(WITHOUT_CA_BUNDLE)
+RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+.endif
+
post-install:
${INSTALL_MAN} ${WRKSRC}/bzr.1 ${MAN1PREFIX}/man/man1/