aboutsummaryrefslogtreecommitdiff
path: root/devel/c2lib
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2003-07-15 11:01:37 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2003-07-15 11:01:37 +0000
commit37615417197bda67e7cba3aa22ea05e6f5ee4d8f (patch)
tree522ea28807a61ea3d332ba3d52879db52a592054 /devel/c2lib
parent154b043dfdea09a4d07ed76f999cac56072b157d (diff)
downloadports-37615417197bda67e7cba3aa22ea05e6f5ee4d8f.tar.gz
ports-37615417197bda67e7cba3aa22ea05e6f5ee4d8f.zip
In memory of AlanE:
- Update to 1.4.2 - Makefile cleanup - Reword pkg-descr, add Author tag - Adopt this orphan Give maintainership to submitter. Submitted by: Sergey Kolobov <sergei@kolobov.com> PR: 53178
Notes
Notes: svn path=/head/; revision=84915
Diffstat (limited to 'devel/c2lib')
-rw-r--r--devel/c2lib/Makefile34
-rw-r--r--devel/c2lib/distinfo2
-rw-r--r--devel/c2lib/pkg-descr13
-rw-r--r--devel/c2lib/pkg-plist8
4 files changed, 27 insertions, 30 deletions
diff --git a/devel/c2lib/Makefile b/devel/c2lib/Makefile
index eddad6de7e6b..08ae517cdd36 100644
--- a/devel/c2lib/Makefile
+++ b/devel/c2lib/Makefile
@@ -1,5 +1,3 @@
-# ex:ts=8 -*-mode: makefile-*-
-#
# New ports collection makefile for: c2lib
# Date created: 2002-12-22
# Whom: Alan Eldridge <alane@FreeBSD.org>
@@ -8,34 +6,28 @@
#
PORTNAME= c2lib
-PORTVERSION= 1.4.1
-PORTREVISION= 0
-PORTEPOCH= 0
+PORTVERSION= 1.4.2
CATEGORIES= devel
MASTER_SITES= http://www.annexia.org/freeware/${PORTNAME}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sergei@kolobov.com
COMMENT= Library of basic structures and memory allocators for C
-BUILD_DEPENDS+= cdoc:${.CURDIR}/../../devel/cdoc
-BUILD_DEPENDS+= make+:${.CURDIR}/../../devel/makeplus
-LIB_DEPENDS+= pcre.0:${.CURDIR}/../../devel/pcre
+BUILD_DEPENDS= cdoc:${PORTSDIR}/devel/cdoc \
+ make+:${PORTSDIR}/devel/makeplus
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-PREFIX?= ${LOCALBASE}
-MAKE_ENV+= CC="${CC}"
-.include <bsd.port.pre.mk>
+INSTALLS_SHLIB= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+PLIST_SUB= VERSION=${PORTVERSION}
-do-configure:
- cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} make+ configure
+.include "${.CURDIR}/files/manpages.mk"
do-build:
- cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} make+
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} make+
do-install:
- cd ${WRKSRC}; ${SETENV} ${MAKE_ENV}\
- make+ install prefix=${PREFIX} manprefix=${PREFIX}
-
-.include "${FILESDIR}/manpages.mk"
-.include <bsd.port.post.mk>
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} make+ install
-#EOF
+.include <bsd.port.mk>
diff --git a/devel/c2lib/distinfo b/devel/c2lib/distinfo
index 93c71444ad6c..5078d9146942 100644
--- a/devel/c2lib/distinfo
+++ b/devel/c2lib/distinfo
@@ -1 +1 @@
-MD5 (c2lib-1.4.1.tar.gz) = 72e1e9ba877b6530b7603f14ff777d42
+MD5 (c2lib-1.4.2.tar.gz) = ba49054f196d73d8132d72609d7c453d
diff --git a/devel/c2lib/pkg-descr b/devel/c2lib/pkg-descr
index 948a95d3e868..4eb2def156c4 100644
--- a/devel/c2lib/pkg-descr
+++ b/devel/c2lib/pkg-descr
@@ -1,5 +1,10 @@
-c2lib is a library of basic structures and memory allocators for C.
-It is designed to look similar to C++ STL with many powerful string
-features borrowed also from Perl.
+c2lib is a library of basic tools for use by C programmers.
+It contains a pool allocator, many string functions, STL-like
+vector and hash types and miscellaneous utilities.
-WWW: http://www.annexia.org/freeware/c2lib/
+Its features were heavily influenced by both Perl's string handling
+and C++'s Standard Template Library (STL). The library has been designed
+to be very easy to use and is fully documented in manual pages.
+
+Author: Richard W.M. Jones <rich@annexia.org>
+WWW: http://www.annexia.org/freeware/c2lib/
diff --git a/devel/c2lib/pkg-plist b/devel/c2lib/pkg-plist
index 91639bdeafd3..1b7e7e2a0b7b 100644
--- a/devel/c2lib/pkg-plist
+++ b/devel/c2lib/pkg-plist
@@ -5,11 +5,11 @@ include/c2lib/pre.h
include/c2lib/pstring.h
include/c2lib/tree.h
include/c2lib/vector.h
+@dirrm include/c2lib
lib/libc2lib.a
lib/libc2lib.so
lib/libc2lib.so.1
-lib/libc2lib.so.1.4.1
+lib/libc2lib.so.%%VERSION%%
share/rws/symtabs/libc2lib.syms
-@dirrm share/rws/symtabs
-@dirrm share/rws
-@dirrm include/c2lib
+@unexec rmdir share/rws/symtabs 2>/dev/null || true
+@unexec rmdir share/rws 2>/dev/null || true