aboutsummaryrefslogtreecommitdiff
path: root/devel/c2lib
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-06-05 14:45:38 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-06-05 14:45:38 +0000
commit1e4af11849b24bde5c9b30783a7866f8421186ce (patch)
tree48a4c7fcc0040c22444c1104e16cd42e677b5768 /devel/c2lib
parentf31bc69eea63de250e15b5c43c3204a69aef61b5 (diff)
downloadports-1e4af11849b24bde5c9b30783a7866f8421186ce.tar.gz
ports-1e4af11849b24bde5c9b30783a7866f8421186ce.zip
Update to 1.2.14, assume maintainership.
Notes
Notes: svn path=/head/; revision=60652
Diffstat (limited to 'devel/c2lib')
-rw-r--r--devel/c2lib/Makefile7
-rw-r--r--devel/c2lib/distinfo2
-rw-r--r--devel/c2lib/files/man326
3 files changed, 32 insertions, 3 deletions
diff --git a/devel/c2lib/Makefile b/devel/c2lib/Makefile
index 769430878711..1c447b6dad0e 100644
--- a/devel/c2lib/Makefile
+++ b/devel/c2lib/Makefile
@@ -7,11 +7,11 @@
#
PORTNAME= c2lib
-PORTVERSION= 1.2.12
+PORTVERSION= 1.2.14
CATEGORIES= devel
MASTER_SITES= http://www.annexia.org/freeware/c2lib/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tobez@FreeBSD.org
USE_LIBTOOL= yes
USE_GMAKE= yes
@@ -21,6 +21,9 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
REALCURDIR="${.CURDIR}" \
DISTNAME="${DISTNAME}"
+post-install:
+ ${RM} ${PREFIX}/lib/libc2.la
+
.include <bsd.port.pre.mk>
MAN3!= ${CAT} ${FILESDIR}/man3
diff --git a/devel/c2lib/distinfo b/devel/c2lib/distinfo
index 17961990ce6b..4688b66c620a 100644
--- a/devel/c2lib/distinfo
+++ b/devel/c2lib/distinfo
@@ -1 +1 @@
-MD5 (c2lib-1.2.12.tar.gz) = 4626b33ff9ba5d401b59d069794b9afb
+MD5 (c2lib-1.2.14.tar.gz) = d1c2ae7c3c7333ab910b68d7118c0125
diff --git a/devel/c2lib/files/man3 b/devel/c2lib/files/man3
index 06a33212e147..ce854a37f014 100644
--- a/devel/c2lib/files/man3
+++ b/devel/c2lib/files/man3
@@ -21,11 +21,13 @@ _vector_push_back.3
_vector_push_front.3
_vector_replace.3
_vector_sort.3
+collision_moving_sphere_and_face.3
copy_hash.3
copy_sash.3
copy_shash.3
copy_vector.3
delete_pool.3
+face_translate_along_normal.3
global_pool.3
hash_erase.3
hash_exists.3
@@ -40,13 +42,20 @@ hash_set_buckets_allocated.3
hash_size.3
hash_values.3
hash_values_in_pool.3
+identity_matrix.3
+make_identity_matrix.3
+make_zero_vec.3
new_hash.3
+new_identity_matrix.3
+new_matrix.3
new_pool.3
new_sash.3
new_shash.3
new_subpool.3
new_subvector.3
+new_vec.3
new_vector.3
+new_zero_vec.3
pcalloc.3
pchomp.3
pchrs.3
@@ -57,10 +66,19 @@ pgetlinec.3
pgetlinex.3
pitoa.3
pjoin.3
+plane_coefficients.3
+plane_translate_along_normal.3
pmalloc.3
pmatch.3
pmatchx.3
pmemdup.3
+point_distance_to_face.3
+point_distance_to_line.3
+point_distance_to_line_segment.3
+point_distance_to_plane.3
+point_face_angle_sum.3
+point_is_inside_plane.3
+point_lies_in_face.3
pool_get_stats.3
pool_register_cleanup_fn.3
pool_register_fd.3
@@ -117,6 +135,13 @@ shash_set_buckets_allocated.3
shash_size.3
shash_values.3
shash_values_in_pool.3
+vec_angle_between.3
+vec_dot_product.3
+vec_magnitude.3
+vec_magnitude2d.3
+vec_magnitude_in_direction.3
+vec_normalize.3
+vec_normalize2d.3
vector_allocated.3
vector_clear.3
vector_compare.3
@@ -143,3 +168,4 @@ vector_reverse.3
vector_size.3
vector_sort.3
vector_swap.3
+zero_vec.3