aboutsummaryrefslogtreecommitdiff
path: root/devel/c2man
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-14 14:04:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-14 14:04:09 +0000
commit51464b8c30e973d4f403083309049b279cfc3bdb (patch)
treef89eb77e8d2c8c05c2366a74ad7d4e848cf9a3dd /devel/c2man
parentd1f1a20d0d92ebfbe34f07fdd1b00da757d2613c (diff)
downloadports-51464b8c30e973d4f403083309049b279cfc3bdb.tar.gz
ports-51464b8c30e973d4f403083309049b279cfc3bdb.zip
add c2man
Generates man pages from C sources PR: 29805 Submitted by: Bernd Luevelsmeyer <bdluevel@heitec.net>
Notes
Notes: svn path=/head/; revision=48753
Diffstat (limited to 'devel/c2man')
-rw-r--r--devel/c2man/Makefile20
-rw-r--r--devel/c2man/distinfo1
-rw-r--r--devel/c2man/files/patch-Makefile.SH35
-rw-r--r--devel/c2man/pkg-comment1
-rw-r--r--devel/c2man/pkg-descr9
-rw-r--r--devel/c2man/pkg-plist1
-rw-r--r--devel/c2man/scripts/configure2
7 files changed, 69 insertions, 0 deletions
diff --git a/devel/c2man/Makefile b/devel/c2man/Makefile
new file mode 100644
index 000000000000..33e5a7e4ffa3
--- /dev/null
+++ b/devel/c2man/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: c2man
+# Date created: 2001-08-15
+# Whom: bdluevel@heitec.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= c2man
+PORTVERSION= 2.0.42
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.research.canon.com.au/pub/misc/c2man/
+DISTNAME= $(PORTNAME)-$(PORTVERSION:C/\.([0-9]*)$/@\1/)
+
+MAINTAINER= bdluevel@heitec.net
+
+NO_WRKSUBDIR= yes
+
+MAN1= c2man.1
+
+.include <bsd.port.mk>
diff --git a/devel/c2man/distinfo b/devel/c2man/distinfo
new file mode 100644
index 000000000000..c88f2524df9e
--- /dev/null
+++ b/devel/c2man/distinfo
@@ -0,0 +1 @@
+MD5 (c2man-2.0@42.tar.gz) = 8640b6860f39c105a737dca40626b252
diff --git a/devel/c2man/files/patch-Makefile.SH b/devel/c2man/files/patch-Makefile.SH
new file mode 100644
index 000000000000..b89c6bef86ff
--- /dev/null
+++ b/devel/c2man/files/patch-Makefile.SH
@@ -0,0 +1,35 @@
+--- .vimbk/Makefile.SH.vimbk Fri Feb 25 03:20:36 2000
++++ Makefile.SH Fri Aug 17 16:14:51 2001
+@@ -25,7 +25,6 @@
+ # UNIX makefile for manual page generator
+ # Note: any changes made here will be lost next time Configure is run!.
+
+-CC=$cc $optimize
+ YACC=$yacc $yaccflags
+ LEX=$lex $lexflags
+ SED=$sed
+@@ -42,7 +41,6 @@
+
+ mansrc=$mansrc
+ manext=$manext
+-CFLAGS=$ccflags
+ WARNFLAGS=$warnflags
+ LDFLAGS=$ldflags
+ LIBS=$libs $liblex $libyacc
+@@ -71,14 +69,8 @@
+ all: c2man c2man.1
+
+ install: all
+- $(CP) c2man $(bin)
+- $(CP) c2man.1 $(mansrc)/c2man.$(manext)
+- -mkdir $(privlib)
+- chmod 755 $(privlib)
+- -mkdir $(privlib)/eg
+- chmod 755 $(privlib)/eg
+- $(CP) eg/*.[chly] $(privlib)/eg
+- chmod 755 $(privlib)/eg/*
++ $(BSD_INSTALL_PROGRAM) c2man $(PREFIX)/bin/
++ $(BSD_INSTALL_MAN) c2man.1 $(PREFIX)/man/man1/
+
+ uninstall:
+ $(RM) -f $(bin)/c2man $(mansrc)/c2man.$(manext)
diff --git a/devel/c2man/pkg-comment b/devel/c2man/pkg-comment
new file mode 100644
index 000000000000..4c923d1380da
--- /dev/null
+++ b/devel/c2man/pkg-comment
@@ -0,0 +1 @@
+Generates man pages from C sources
diff --git a/devel/c2man/pkg-descr b/devel/c2man/pkg-descr
new file mode 100644
index 000000000000..012a2ea923b8
--- /dev/null
+++ b/devel/c2man/pkg-descr
@@ -0,0 +1,9 @@
+c2man is an automatic documentation tool that extracts comments
+from C source code to generate functional interface
+documentation in the same format as sections 2 & 3 of the Unix
+Programmer's Manual. It requires minimal effort from the
+programmer by looking for comments in the usual places near the
+objects they document, rather than imposing a rigid
+function-comment syntax or requiring that the programmer learn
+and use a typesetting language. Acceptable documentation can
+often be generated from existing code with no modifications.
diff --git a/devel/c2man/pkg-plist b/devel/c2man/pkg-plist
new file mode 100644
index 000000000000..4e30d92b3f4c
--- /dev/null
+++ b/devel/c2man/pkg-plist
@@ -0,0 +1 @@
+bin/c2man
diff --git a/devel/c2man/scripts/configure b/devel/c2man/scripts/configure
new file mode 100644
index 000000000000..e746a8c85179
--- /dev/null
+++ b/devel/c2man/scripts/configure
@@ -0,0 +1,2 @@
+#!/bin/sh
+cd ${WRKSRC} && ./Configure -des