aboutsummaryrefslogtreecommitdiff
path: root/devel/cdecl
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-09 18:37:19 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-09 18:37:19 +0000
commit102f4279414804a8d550dbbc4fa6c9cda171f558 (patch)
treee19b5fb3e27fe0d998ff5a1e047e4ea293f775be /devel/cdecl
parent082d1d2b8cde270fba0fa9a4ec26f11bc9d0a9b2 (diff)
downloadports-102f4279414804a8d550dbbc4fa6c9cda171f558.tar.gz
ports-102f4279414804a8d550dbbc4fa6c9cda171f558.zip
Honour CPPFLAGS and LDFLAGS to fix readline support on current.
Notes
Notes: svn path=/head/; revision=364461
Diffstat (limited to 'devel/cdecl')
-rw-r--r--devel/cdecl/files/patch-Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/devel/cdecl/files/patch-Makefile b/devel/cdecl/files/patch-Makefile
index 0a87521198f8..7f9b2c48b2cc 100644
--- a/devel/cdecl/files/patch-Makefile
+++ b/devel/cdecl/files/patch-Makefile
@@ -1,14 +1,15 @@
---- ./Makefile.orig 1996-01-16 06:36:38.000000000 +0100
-+++ ./Makefile 2013-06-10 00:05:02.101069622 +0200
+--- Makefile.orig 1996-01-16 00:36:38.000000000 -0500
++++ Makefile 2014-08-09 14:36:10.000000000 -0400
@@ -15,13 +15,13 @@
#
# add -DUSE_READLINE To compile in support for the GNU readline library.
-CFLAGS= -s -O2 -DUSE_READLINE
-CC= gcc
-+CFLAGS+= -s -DUSE_READLINE
+-LIBS= -lreadline -ltermcap
++CFLAGS+= -s -DUSE_READLINE ${CPPFLAGS}
+CC?= gcc
- LIBS= -lreadline -ltermcap
++LIBS= -lreadline -ltermcap ${LDFLAGS}
ALLFILES= makefile cdgram.y cdlex.l cdecl.c cdecl.1 testset testset++
-BINDIR= /usr/bin
-MANDIR= /usr/man/man1
@@ -24,11 +25,11 @@
install: cdecl
- $(INSTALL) cdecl $(BINDIR)
-+ ${BSD_INSTALL_PROGRAM} cdecl $(STAGEDIR)$(BINDIR)
- ln $(BINDIR)/cdecl $(BINDIR)/c++decl
-+ ln -s $(BINDIR)/cdecl $(STAGEDIR)$(BINDIR)/c++decl
- $(INSTALL_DATA) cdecl.1 $(MANDIR)
- $(INSTALL_DATA) c++decl.1 $(MANDIR)
++ ${BSD_INSTALL_PROGRAM} cdecl $(STAGEDIR)$(BINDIR)
++ ln -s $(BINDIR)/cdecl $(STAGEDIR)$(BINDIR)/c++decl
+ ${BSD_INSTALL_MAN} cdecl.1 $(STAGEDIR)$(MANDIR)
+ ln -s $(MANDIR)/cdecl.1 $(STAGEDIR)$(MANDIR)/c++decl.1