aboutsummaryrefslogtreecommitdiff
path: root/devel/cdecl
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1999-09-05 05:07:08 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1999-09-05 05:07:08 +0000
commit2bc00d96c9ec88c43deb3cda8fe9640c03f70148 (patch)
tree7dced93a5b34590c4362ce7da052b1bb807f615a /devel/cdecl
parent2973fb8992fb7ca62d0227ddeccec8c69eae7832 (diff)
downloadports-2bc00d96c9ec88c43deb3cda8fe9640c03f70148.tar.gz
ports-2bc00d96c9ec88c43deb3cda8fe9640c03f70148.zip
Cdecl composes compilable C declarations and typecasts from descriptive
English phrases, and can also explain a complicated typecast or declaration. It handles ANSI C, C++, pre-ANSI C, and K&R C, and has TAB completion of keywords and line editing and history (provided by the GNU readline library).
Notes
Notes: svn path=/head/; revision=21269
Diffstat (limited to 'devel/cdecl')
-rw-r--r--devel/cdecl/Makefile30
-rw-r--r--devel/cdecl/distinfo1
-rw-r--r--devel/cdecl/files/patch-0120
-rw-r--r--devel/cdecl/files/patch-0212
-rw-r--r--devel/cdecl/pkg-comment1
-rw-r--r--devel/cdecl/pkg-descr4
-rw-r--r--devel/cdecl/pkg-plist4
7 files changed, 72 insertions, 0 deletions
diff --git a/devel/cdecl/Makefile b/devel/cdecl/Makefile
new file mode 100644
index 000000000000..5f5e1953e9f9
--- /dev/null
+++ b/devel/cdecl/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: cdecl
+# Version required: 2.5
+# Date created: Sat Sep 04, 1999
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+DISTNAME= cdecl-2.5
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.netsw.org/netsw/SoftEng/Lang/C/Tools/cdecl/ \
+ ftp://ftp.cc.gatech.edu/ac121/linux/devel/lang/c/ \
+ ftp://ftp.deva.net/pub/sources/programming/ \
+ ftp://ftp.bitcon.no//pub/linux/linuxberg/files/console/dev/ \
+ ftp://ftp.uakom.sk/pub/linux/devel/lang/c/
+
+MAINTAINER= obrien@FreeBSD.org
+
+ALL_TARGET=
+MAN1= cdecl.1
+MLINKS= cdecl.1 c++decl.1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/cdecl
+ ${INSTALL_DATA} ${WRKSRC}/testset* ${PREFIX}/share/doc/cdecl
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/cdecl/distinfo b/devel/cdecl/distinfo
new file mode 100644
index 000000000000..f4f6f5dd380b
--- /dev/null
+++ b/devel/cdecl/distinfo
@@ -0,0 +1 @@
+MD5 (cdecl-2.5.tar.gz) = 29895dab52e85b2474a59449e07b7996
diff --git a/devel/cdecl/files/patch-01 b/devel/cdecl/files/patch-01
new file mode 100644
index 000000000000..4d74568f2775
--- /dev/null
+++ b/devel/cdecl/files/patch-01
@@ -0,0 +1,20 @@
+--- Makefile.orig Mon Jan 15 21:36:38 1996
++++ Makefile Sat Sep 4 22:02:21 1999
+@@ -15,13 +15,13 @@
+ #
+ # add -DUSE_READLINE To compile in support for the GNU readline library.
+
+-CFLAGS= -s -O2 -DUSE_READLINE
++CFLAGS+= -s -DUSE_READLINE
+ CC= gcc
+ LIBS= -lreadline -ltermcap
+ ALLFILES= makefile cdgram.y cdlex.l cdecl.c cdecl.1 testset testset++
+-BINDIR= /usr/bin
+-MANDIR= /usr/man/man1
+-CATDIR= /usr/man/cat1
++BINDIR= $(PREFIX)/bin
++MANDIR= $(PREFIX)/man/man1
++CATDIR= $(PREFIX/usr/man/cat1
+ INSTALL= install -c
+ INSTALL_DATA= install -c -m 644
+
diff --git a/devel/cdecl/files/patch-02 b/devel/cdecl/files/patch-02
new file mode 100644
index 000000000000..d9d1ca49a0ff
--- /dev/null
+++ b/devel/cdecl/files/patch-02
@@ -0,0 +1,12 @@
+--- cdecl.c.orig Mon Jan 15 19:54:46 1996
++++ cdecl.c Sat Sep 4 20:02:59 1999
+@@ -67,6 +67,9 @@
+ # include <stddef.h>
+ # include <string.h>
+ # include <stdarg.h>
++# ifndef DOS
++# include <errno.h> /* only M$-DOS environments have ``errno'' in stdlib.h */
++# endif /* ndef DOS */
+ #else
+ # ifndef NOVARARGS
+ # include <varargs.h>
diff --git a/devel/cdecl/pkg-comment b/devel/cdecl/pkg-comment
new file mode 100644
index 000000000000..4cc0da1e053e
--- /dev/null
+++ b/devel/cdecl/pkg-comment
@@ -0,0 +1 @@
+Explains complicated C/C++ declarations in plain English
diff --git a/devel/cdecl/pkg-descr b/devel/cdecl/pkg-descr
new file mode 100644
index 000000000000..a0a2833ea44d
--- /dev/null
+++ b/devel/cdecl/pkg-descr
@@ -0,0 +1,4 @@
+Cdecl composes compilable C declarations and typecasts from descriptive
+English phrases, and can also explain a complicated typecast or declaration.
+It handles ANSI C, C++, pre-ANSI C, and K&R C, and has TAB completion of
+keywords and line editing and history (provided by the GNU readline library).
diff --git a/devel/cdecl/pkg-plist b/devel/cdecl/pkg-plist
new file mode 100644
index 000000000000..941fbe9c0aae
--- /dev/null
+++ b/devel/cdecl/pkg-plist
@@ -0,0 +1,4 @@
+bin/cdecl
+bin/c++decl
+share/doc/cdecl/testset
+share/doc/cdecl/testset++