aboutsummaryrefslogtreecommitdiff
path: root/devel/cdk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-12-31 11:49:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-12-31 11:49:36 +0000
commitc19848a8f3122f250f30459d1586f388abc9bf6d (patch)
tree8eb57a38f1ca3a448cf2f123c550811237a31e60 /devel/cdk
parent61b3d5757936eca4873001c93020482132b5dbcd (diff)
downloadports-c19848a8f3122f250f30459d1586f388abc9bf6d.tar.gz
ports-c19848a8f3122f250f30459d1586f388abc9bf6d.zip
- update to 5.0.20120323
- remove useless LICENSE_FILE - convert to new option framework
Notes
Notes: svn path=/head/; revision=309720
Diffstat (limited to 'devel/cdk')
-rw-r--r--devel/cdk/Makefile21
-rw-r--r--devel/cdk/distinfo4
-rw-r--r--devel/cdk/files/patch-man__cdk_display.399
-rw-r--r--devel/cdk/pkg-plist3
4 files changed, 12 insertions, 115 deletions
diff --git a/devel/cdk/Makefile b/devel/cdk/Makefile
index e046f6d80b8d..392a8e56d828 100644
--- a/devel/cdk/Makefile
+++ b/devel/cdk/Makefile
@@ -1,13 +1,8 @@
-# ex:ts=8
-# New ports collection makefile for: cdk
-# Date created: 6 May 1999
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= cdk
-PORTVERSION= 5.0.20090215
+PORTVERSION= 5.0.20120323
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ftp://invisible-island.net/cdk/
@@ -18,14 +13,14 @@ MAINTAINER= bapt@FreeBSD.org
COMMENT= Curses Development Kit for speedy development of full screen programs
LICENSE= BSD
-LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_GMAKE= yes
USE_NCURSES= yes
GNU_CONFIGURE= yes
PORTDOCS= COPYING EXPANDING INSTALL NOTES README TODO
MAKE_JOBS_UNSAFE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
CONFIGURE_ARGS+=--with-ncurses
ALL_TARGET= default examples demos cli cdkshlib
@@ -35,7 +30,7 @@ USE_LDCONFIG= yes
.include "${.CURDIR}/maninfo.mk"
post-extract:
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile.in
.endif
@@ -44,14 +39,14 @@ post-patch:
-e 's|gcc|${CC}|g' ${WRKSRC}/Makefile.in
pre-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
PLIST_SUB+= EXAMPLES=""
.else
PLIST_SUB+= EXAMPLES="@comment "
.endif
post-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${INSTALL} -d ${EXAMPLESDIR}
${INSTALL} -d ${EXAMPLESDIR}/cli
cd ${WRKSRC}/cli; \
@@ -64,4 +59,4 @@ post-install:
${FIND} . | ${CPIO} -pdm -R ${LIBOWN}:${LIBGRP} ${EXAMPLESDIR}/examples
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/cdk/distinfo b/devel/cdk/distinfo
index 1d2d6568ff98..b939d29b7e11 100644
--- a/devel/cdk/distinfo
+++ b/devel/cdk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cdk-5.0-20090215.tgz) = b388c3a91a86153dfb2e0e583e213457859e61b228959145dffd102eb42ffb9d
-SIZE (cdk-5.0-20090215.tgz) = 429288
+SHA256 (cdk-5.0-20120323.tgz) = a7a8210a85b1505f3f9e794cd11afad1c66f42306e6387b197bd006b24534c74
+SIZE (cdk-5.0-20120323.tgz) = 466993
diff --git a/devel/cdk/files/patch-man__cdk_display.3 b/devel/cdk/files/patch-man__cdk_display.3
deleted file mode 100644
index 24df4e12b1f9..000000000000
--- a/devel/cdk/files/patch-man__cdk_display.3
+++ /dev/null
@@ -1,99 +0,0 @@
---- ./man/cdk_display.3.orig 2006-04-17 12:45:02.000000000 +0200
-+++ ./man/cdk_display.3 2010-11-22 12:30:11.667537601 +0100
-@@ -54,7 +54,7 @@
- .nf
- .ce
- \fI----------------------------------------\fR
--#include <cdk.h>
-+#include <cdk/cdk.h>
-
- void main()
- {
-@@ -66,11 +66,13 @@
- /* Initialize the Cdk screen. */
- screen = initscr();
- cdkscreen = initCDKScreen (screen);
-+ /* Start CDK Colors */
-+ initCDKColor();
-
- /* Set the labels up. */
-- mesg[0] = "</1>This line should have a yellow foreground and a blue background.<!1>";
-- mesg[1] = "</2>This line should have a white foreground and a blue background.<!2>";
-- mesg[2] = "</3>This line should have a yellow foreground and a red background.<!3>";
-+ mesg[0] = "</31>This line should have a yellow foreground and a blue background.<!31>";
-+ mesg[1] = "</05>This line should have a white foreground and a blue background.<!05>";
-+ mesg[2] = "</26>This line should have a yellow foreground and a red background.<!26>";
- mesg[3] = "<C>This line should be set to whatever the screen default is.";
-
- /* Declare the labels. */
-@@ -121,7 +123,7 @@
- .nf
- .ce
- \fI----------------------------------------\fR
--#include <cdk.h>
-+#include <cdk/cdk.h>
-
- void main()
- {
-@@ -133,11 +135,13 @@
- /* Initialize the Cdk screen. */
- screen = initscr();
- cdkscreen = initCDKScreen (screen);
-+ /* Start CDK Colors */
-+ initCDKColor();
-
- /* Set the labels up. */
-- mesg[0] = "</B/1>Bold text yellow foreground / blue background.<!1>";
-- mesg[1] = "</U/2>Underlined text white foreground / blue background.<!2>";
-- mesg[2] = "</K/3>Blinking text yellow foreground / red background.<!3>";
-+ mesg[0] = "</B/31>Bold text yellow foreground / blue background.<!31>";
-+ mesg[1] = "</U/05>Underlined text white foreground / blue background.<!05>";
-+ mesg[2] = "</K/26>Blinking text yellow foreground / red background.<!26>";
- mesg[3] = "<C>This line uses the screen default colors.";
-
- /* Declare the labels. */
-@@ -190,7 +194,7 @@
- .ce
- \fI----------------------------------------\fR
- .nf
--#include <cdk.h>
-+#include <cdk/cdk.h>
-
- void main()
- {
-@@ -202,10 +206,12 @@
- /* Initialize the Cdk screen. */
- screen = initscr();
- cdkscreen = initCDKScreen (screen);
-+ /* Start CDK Colors */
-+ initCDKColor();
-
- /* Set the labels up. */
-- mesg[0] = "<R></B/1>This line should have a yellow foreground and a blue background.<!1>";
-- mesg[1] = "</U/2>This line should have a white foreground and a blue background.<!2>";
-+ mesg[0] = "<R></B/31>This line should have a yellow foreground and a blue background.<!31>";
-+ mesg[1] = "</U/05>This line should have a white foreground and a blue background.<!05>";
- mesg[2] = "<B=+>This is a bullet.";
- mesg[3] = "<I=10>This is indented 10 characters.";
- mesg[4] = "<C>This line should be set to whatever the screen default is.";
-@@ -295,7 +301,7 @@
- .ce
- \fI----------------------------------------\fR
- .nf
--#include "cdk.h"
-+#include <cdk/cdk.h>
-
- void main()
- {
-@@ -313,9 +319,9 @@
- initCDKColor();
-
- /* Set the labels up. */
-- mesg[0] = "<C><#UL><#HL(25)><#UR>";
-+ mesg[0] = "<C><#UL><#HL(26)><#UR>";
- mesg[1] = "<C><#VL></R>This text should be boxed.<!R><#VL>";
-- mesg[2] = "<C><#LL><#HL(25)><#LR>";
-+ mesg[2] = "<C><#LL><#HL(26)><#LR>";
- mesg[3] = "<C>While this is not.";
-
- /* Declare the labels. */
diff --git a/devel/cdk/pkg-plist b/devel/cdk/pkg-plist
index 8486ad25002e..a30b6f38663a 100644
--- a/devel/cdk/pkg-plist
+++ b/devel/cdk/pkg-plist
@@ -4,11 +4,12 @@ include/cdk/binding.h
include/cdk/button.h
include/cdk/buttonbox.h
include/cdk/calendar.h
-include/cdk/cdk.h
+include/cdk.h
include/cdk/cdk_compat.h
include/cdk/cdk_config.h
include/cdk/cdk_objs.h
include/cdk/cdk_params.h
+include/cdk/cdk_test.h
include/cdk/cdk_util.h
include/cdk/cdk_version.h
include/cdk/cdkscreen.h