aboutsummaryrefslogtreecommitdiff
path: root/devel/chora
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-12-26 10:26:54 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-12-26 10:26:54 +0000
commit3d4ff15bb4d545f5437ab0c0c69ff9d6b049c50d (patch)
treeae442c8a47cbe238cf9072810931b8681bef82dd /devel/chora
parenta033fd5e913c8b8a3256cf6fb100a87e2da09ace (diff)
downloadports-3d4ff15bb4d545f5437ab0c0c69ff9d6b049c50d.tar.gz
ports-3d4ff15bb4d545f5437ab0c0c69ff9d6b049c50d.zip
Upgrade to 2.0.
The major changes compared to the Chora 1.x versions are: * Subversion support * Patchset information * Cvsgraph integration * Simple commit statistics * Access keys. * mod_rewrite support for prettier URLs.
Notes
Notes: svn path=/head/; revision=125203
Diffstat (limited to 'devel/chora')
-rw-r--r--devel/chora/Makefile94
-rw-r--r--devel/chora/distinfo4
-rw-r--r--devel/chora/files/patch-aa32
-rw-r--r--devel/chora/files/patch-config::sourceroots.php.dist45
-rw-r--r--devel/chora/files/pkg-message.in8
-rw-r--r--devel/chora/pkg-plist160
6 files changed, 174 insertions, 169 deletions
diff --git a/devel/chora/Makefile b/devel/chora/Makefile
index c77f21429bf7..ff1e9bb7f006 100644
--- a/devel/chora/Makefile
+++ b/devel/chora/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= chora
-PORTVERSION= 1.2.2
+PORTVERSION= 2.0
CATEGORIES= devel www
MASTER_SITES= ftp://ftp.horde.org/pub/chora/ \
ftp://ftp.planetmirror.com/pub/horde/chora/ \
@@ -16,6 +16,7 @@ MASTER_SITES= ftp://ftp.horde.org/pub/chora/ \
ftp://ftp.nl.horde.org/mirror/horde-ftp/pub/chora/ \
ftp://ftp.uk.horde.org/mirrors/ftp.horde.org/pub/chora/ \
http://ftp.horde.org/pub/chora/
+DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
MAINTAINER= thierry@FreeBSD.org
COMMENT= The Horde CVS web-viewer
@@ -23,26 +24,32 @@ COMMENT= The Horde CVS web-viewer
#-----------------------------------------------------------------------
# You may define these options:
#
-# - WITHOUT_ENSCRIPT : if you do not need syntax highlighting;
+# - WITHOUT_SVN : if you don't need subversion;
+#
+# - WITHOUT_CVSPS : if you don't need cvsps;
+#
+# - WITHOUT_CVSGRAPH : if you don't need cvsgraph;
#
# - A4 or DJ : if you run enscript with this paper size.
#
#-----------------------------------------------------------------------
-RUN_DEPENDS= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde2
-.if !defined(WITHOUT_ENSCRIPT)
-.if defined(A4)
-RUN_DEPENDS+= ${LOCALBASE}/bin/enscript:${PORTSDIR}/print/enscript-a4
-.elif defined(DJ)
-RUN_DEPENDS+= ${LOCALBASE}/bin/enscript:${PORTSDIR}/print/enscript-letterdj
-.else
-RUN_DEPENDS+= ${LOCALBASE}/bin/enscript:${PORTSDIR}/print/enscript-letter
+RUN_DEPENDS+= ${LOCALBASE}/www/horde/rpc.php:${PORTSDIR}/www/horde
+
+.if !defined(WITHOUT_SVN)
+RUN_DEPENDS+= ${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion
.endif
+
+.if !defined(WITHOUT_CVSPS)
+RUN_DEPENDS+= ${LOCALBASE}/bin/cvsps:${PORTSDIR}/devel/cvsps-devel
+.endif
+
+.if !defined(WITHOUT_CVSGRAPH)
+RUN_DEPENDS+= ${LOCALBASE}/bin/cvsgraph:${PORTSDIR}/devel/cvsgraph
.endif
NO_BUILD= yes
USE_REINPLACE= yes
-REINPLACE_ARGS= -i.beforeChora
# Specify where your repository belongs.
# (You can reconfigure it after installation anyway)
@@ -50,26 +57,46 @@ REINPLACE_ARGS= -i.beforeChora
CVSROOT= /home/cvs
.endif
-DOCS= COPYING README docs/BUGS docs/CHANGES docs/CREDITS \
- docs/GOALS docs/INSTALL docs/RELEASE_NOTES
-CONFFILE= conf.php cvsroots.php html.php longIntro.txt \
- mime_drivers.php prefs.php
-SUB_DIRS= config graphics lib locale po templates
+DOCS= COPYING README docs/BUGS docs/CHANGES docs/CREDITS \
+ docs/INSTALL docs/RELEASE_NOTES docs/TODO
+CONFFILE= cvsgraph.conf longIntro.txt mime_drivers.php prefs.php \
+ sourceroots.php
+SUB_DIRS= config lib locale po templates themes
PKGMESSAGE= ${WRKDIR}/pkg-message
LHORDEDIR?= www/horde
-LCHORADIR?= ${LHORDEDIR}/chora
+LCHORADIR= ${LHORDEDIR}/chora
-PLIST_SUB= HORDEDIR=${LHORDEDIR} CHORADIR=${LCHORADIR}
+PLIST_SUB= CHORADIR=${LCHORADIR}
-HORDEDIR= ${PREFIX}/${LHORDEDIR}
CHORADIR= ${PREFIX}/${LCHORADIR}
CONFDIR= ${CHORADIR}/config
HORDE_INC= ${LOCALBASE}/etc/horde
-post-patch:
- @${RM} ${WRKSRC}/config/cvsroots.php.dist.orig
+PATCH2RM= sourceroots.php.dist.orig sourceroots.php.dist.bak conf.xml.bak
+
+pre-configure:
+ @${SED} -e "s:/home/httpd/html/horde/chora:${CHORADIR}:" \
+ ${FILESDIR}/httpd.conf.chora > ${WRKDIR}/httpd.conf.chora
+ @${REINPLACE_CMD} -e "s|/usr/local|${LOCALBASE}|" \
+ -e "s|/usr/bin/cvsgraph|${LOCALBASE}/bin/cvsgraph|" \
+ -e "s|/usr/bin/svn|${LOCALBASE}/bin/svn|" \
+ ${WRKSRC}/config/conf.xml
+ @${REINPLACE_CMD} -e "s|%%CVSROOT%%|${CVSROOT}|" \
+ -e "s|%%CONFDIR%%|${CONFDIR}|" \
+ ${WRKSRC}/config/sourceroots.php.dist
+.for FILE in ${PATCH2RM}
+ @${RM} ${WRKSRC}/config/${FILE}
+.endfor
+
+pre-install:
+.if !defined(WITHOUT_CVSPS)
+ @if ! pkg_info -I -x cvsps-devel > /dev/null ; then \
+ ${ECHO_MSG} "Error: cvsps-devel is required, not cvsps." ; \
+ ${FALSE} ; \
+ fi
+.endif
do-install:
@${MKDIR} ${CHORADIR}
@@ -82,25 +109,9 @@ do-install:
${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
fi
.endfor
- @${REINPLACE_CMD} -e "s|%%CVSROOT%%|${CVSROOT}|;s|%%CONFDIR%%|${CONFDIR}|" \
- ${CONFDIR}/cvsroots.php
- @${RM} ${CONFDIR}/cvsroots.php.beforeChora
- @${CHOWN} -R www:www ${CHORADIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${CHORADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
- @${CP} -p ${FILESDIR}/httpd.conf.chora ${HORDE_INC}
- @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/chora:${CHORADIR}:g" \
- ${HORDE_INC}/httpd.conf.chora
- @${RM} ${HORDE_INC}/httpd.conf.chora.beforeChora
- @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTCHORA::" \
- ${HORDEDIR}/config/registry.php
-.if !defined(WITHOUT_ENSCRIPT)
- @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTCHORA::" \
- ${HORDEDIR}/config/mime_drivers.php
-.endif
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.afterChora
- @${CP} -p ${HORDEDIR}/config/mime_drivers.php \
- ${HORDEDIR}/config/mime_drivers.php.afterChora
+ @${INSTALL_DATA} ${WRKDIR}/httpd.conf.chora ${HORDE_INC}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@@ -110,10 +121,9 @@ do-install:
.endif
post-install:
+ @${SED} -e "s:%%CHORADIR%%:${CHORADIR}:;s:%%CONFDIR%%:${CONFDIR}:" \
+ < ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
@${ECHO_MSG}
- @${SED} -e "s:%%CHORADIR%%:${CHORADIR}:g;s:%%PORTSDIR%%:${PORTSDIR}:g" \
- -e "s:%%CONFDIR%%:${CONFDIR}:g" < ${FILESDIR}/pkg-message.in \
- > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/devel/chora/distinfo b/devel/chora/distinfo
index 37e5acf2f0ff..8f273f6f5b9f 100644
--- a/devel/chora/distinfo
+++ b/devel/chora/distinfo
@@ -1,2 +1,2 @@
-MD5 (chora-1.2.2.tar.gz) = 32017a2430971d501429b7dd5c1f5b95
-SIZE (chora-1.2.2.tar.gz) = 201926
+MD5 (chora-h3-2.0.tar.gz) = 11f4b8ad6e0706026aefd0ee29eff7a5
+SIZE (chora-h3-2.0.tar.gz) = 655837
diff --git a/devel/chora/files/patch-aa b/devel/chora/files/patch-aa
deleted file mode 100644
index 544301000550..000000000000
--- a/devel/chora/files/patch-aa
+++ /dev/null
@@ -1,32 +0,0 @@
---- config/cvsroots.php.dist.orig Wed Mar 20 21:30:06 2002
-+++ config/cvsroots.php.dist Sun May 19 09:41:40 2002
-@@ -30,6 +30,15 @@
-
- $cvsroots = array();
-
-+$cvsroots['myprojects'] = array(
-+ 'name' => 'Here',
-+ 'location' => '%%CVSROOT%%',
-+ 'title' => 'To be configured in %%CONFDIR%%/cvsroots.php',
-+ 'intro' => 'longIntro.txt',
-+ 'default' => true
-+);
-+
-+/*
- $cvsroots['php4'] = array(
- 'name' => 'PHP4',
- 'location' => '/home/cvs/php4',
-@@ -47,8 +56,9 @@
- 'restrictions' => array('^/?hordeweb/config/defaults.php')
- );
-
--$cvsroots['openbsd'] = array(
-- 'name' => 'OpenBSD',
-- 'location' => '/home/cvs/openbsd',
-- 'title' => 'OpenBSD CVS Repository'
-+$cvsroots['freebsd'] = array(
-+ 'name' => 'FreeBSD',
-+ 'location' => '/home/cvs/freebsd',
-+ 'title' => 'FreeBSD CVS Repository'
- );
-+*/
diff --git a/devel/chora/files/patch-config::sourceroots.php.dist b/devel/chora/files/patch-config::sourceroots.php.dist
new file mode 100644
index 000000000000..18c1a987243b
--- /dev/null
+++ b/devel/chora/files/patch-config::sourceroots.php.dist
@@ -0,0 +1,45 @@
+--- config/sourceroots.php.dist.orig Wed Aug 27 16:08:21 2003
++++ config/sourceroots.php.dist Thu Dec 2 23:30:08 2004
+@@ -11,7 +11,7 @@
+ * 'name' [M] : Short name for the repository.
+ *
+ * 'location' [M] : Location on the filesystem of the repository.
+- *
++ *
+ * 'title' [M] : Long title for the repository.
+ *
+ * 'type' [M] : Indicates software used, either 'cvs' or 'svn'.
+@@ -31,6 +31,17 @@
+ * whose contents should be protected and not displayed.
+ */
+
++$sourceroots['myprojects'] = array(
++ 'name' => 'Here',
++ 'location' => '%%CVSROOT%%',
++ 'title' => 'To be configured in %%CONFDIR%%/sourceroots.php',
++ 'intro' => 'longIntro.txt',
++ 'default' => true,
++ 'type' => 'cvs',
++);
++
++/*
++
+ $sourceroots['php4'] = array(
+ 'name' => 'PHP4',
+ 'location' => '/home/cvs/php4',
+@@ -64,9 +75,11 @@
+ 'type' => 'svn',
+ );
+
+-$sourceroots['openbsd'] = array(
+- 'name' => 'OpenBSD',
+- 'location' => '/home/cvs/openbsd',
+- 'title' => 'OpenBSD CVS Repository',
++$sourceroots['freebsd'] = array(
++ 'name' => 'FreeBSD',
++ 'location' => '/home/cvs/freebsd',
++ 'title' => 'FreeBSD CVS Repository',
+ 'type' => 'cvs',
+ );
++
++*/
diff --git a/devel/chora/files/pkg-message.in b/devel/chora/files/pkg-message.in
index 4bdcac58b667..34b4d8550554 100644
--- a/devel/chora/files/pkg-message.in
+++ b/devel/chora/files/pkg-message.in
@@ -2,12 +2,10 @@
Chora has been installed in %%CHORADIR%% with your blank
configuration files.
-Horde must be configured; if not, see
-%%PORTSDIR%%/www/horde2/pkg-message.
+Horde must be configured; if not, see `pkg_info -D -x horde'.
-Then, you will have to tune the configuration files located in
-%%CONFDIR%%/, specially the files conf.php and
-cvsroots.php.
+Then, you may have to tune the configuration files located in
+%%CONFDIR%%/, specially the file sourceroots.php.
To protect your configuration files, you have to restart Apache.
************************************************************************
diff --git a/devel/chora/pkg-plist b/devel/chora/pkg-plist
index 173e9399000d..8faaac5507cb 100644
--- a/devel/chora/pkg-plist
+++ b/devel/chora/pkg-plist
@@ -1,59 +1,43 @@
+etc/horde/httpd.conf.chora
%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/GOALS
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
+%%PORTDOCS%%%%DOCSDIR%%/TODO
%%CHORADIR%%/annotate.php
+%%CHORADIR%%/browse.php
%%CHORADIR%%/co.php
%%CHORADIR%%/config/.htaccess
-%%CHORADIR%%/config/README
-%%CHORADIR%%/config/conf.php
-%%CHORADIR%%/config/conf.php.dist
-%%CHORADIR%%/config/cvsroots.php
-%%CHORADIR%%/config/cvsroots.php.dist
-%%CHORADIR%%/config/html.php
-%%CHORADIR%%/config/html.php.dist
+%%CHORADIR%%/config/conf.xml
+%%CHORADIR%%/config/cvsgraph.conf
+%%CHORADIR%%/config/cvsgraph.conf.dist
%%CHORADIR%%/config/longIntro.txt
%%CHORADIR%%/config/longIntro.txt.dist
%%CHORADIR%%/config/mime_drivers.php
%%CHORADIR%%/config/mime_drivers.php.dist
%%CHORADIR%%/config/prefs.php
%%CHORADIR%%/config/prefs.php.dist
+%%CHORADIR%%/config/sourceroots.php
+%%CHORADIR%%/config/sourceroots.php.dist
%%CHORADIR%%/cvs.php
+%%CHORADIR%%/cvsgraph.php
%%CHORADIR%%/diff.php
-%%CHORADIR%%/graphics/back.gif
-%%CHORADIR%%/graphics/chora.gif
-%%CHORADIR%%/graphics/deleted.gif
-%%CHORADIR%%/graphics/down.gif
-%%CHORADIR%%/graphics/folder.gif
-%%CHORADIR%%/graphics/mime/text.gif
-%%CHORADIR%%/graphics/up.gif
%%CHORADIR%%/history.php
%%CHORADIR%%/index.php
%%CHORADIR%%/lib/.htaccess
-%%CHORADIR%%/lib/CVSLib.php
-%%CHORADIR%%/lib/CVSLib/Annotate.php
-%%CHORADIR%%/lib/CVSLib/Checkout.php
-%%CHORADIR%%/lib/CVSLib/Diff.php
-%%CHORADIR%%/lib/CVSLib/Directory.php
-%%CHORADIR%%/lib/CVSLib/Error.php
-%%CHORADIR%%/lib/CVSLib/File.php
-%%CHORADIR%%/lib/CVSLib/Log.php
-%%CHORADIR%%/lib/CVSLib/Rev.php
%%CHORADIR%%/lib/Chora.php
-%%CHORADIR%%/lib/MIME/Viewer/text.php
-%%CHORADIR%%/lib/README.CVSLib
%%CHORADIR%%/lib/base.php
-%%CHORADIR%%/lib/constants.php
%%CHORADIR%%/lib/version.php
%%CHORADIR%%/locale/.htaccess
%%CHORADIR%%/locale/cs_CZ/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/de_DE/LC_MESSAGES/chora.mo
+%%CHORADIR%%/locale/de_DE/help.xml
%%CHORADIR%%/locale/en_US/help.xml
%%CHORADIR%%/locale/es_ES/LC_MESSAGES/chora.mo
+%%CHORADIR%%/locale/es_ES/help.xml
%%CHORADIR%%/locale/fi_FI/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/fr_FR/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/nb_NO/LC_MESSAGES/chora.mo
@@ -61,18 +45,17 @@
%%CHORADIR%%/locale/pl_PL/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/pt_BR/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/ro_RO/LC_MESSAGES/chora.mo
+%%CHORADIR%%/locale/sk_SK/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/sv_SE/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/zh_CN/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/zh_TW/LC_MESSAGES/chora.mo
-%%CHORADIR%%/menu.php
+%%CHORADIR%%/patchsets.php
%%CHORADIR%%/po/.htaccess
-%%CHORADIR%%/po/Makefile
%%CHORADIR%%/po/README
%%CHORADIR%%/po/chora.pot
%%CHORADIR%%/po/cs_CZ.po
%%CHORADIR%%/po/de_DE.po
%%CHORADIR%%/po/es_ES.po
-%%CHORADIR%%/po/extract.pl
%%CHORADIR%%/po/fi_FI.po
%%CHORADIR%%/po/fr_FR.po
%%CHORADIR%%/po/nb_NO.po
@@ -80,21 +63,18 @@
%%CHORADIR%%/po/pl_PL.po
%%CHORADIR%%/po/pt_BR.po
%%CHORADIR%%/po/ro_RO.po
-%%CHORADIR%%/po/shtool
+%%CHORADIR%%/po/sk_SK.po
%%CHORADIR%%/po/sv_SE.po
%%CHORADIR%%/po/zh_CN.po
%%CHORADIR%%/po/zh_TW.po
-%%CHORADIR%%/po/xgettext.sh
-%%CHORADIR%%/prefs.php
-%%CHORADIR%%/status.php
+%%CHORADIR%%/stats.php
%%CHORADIR%%/templates/.htaccess
%%CHORADIR%%/templates/annotate/footer.inc
%%CHORADIR%%/templates/annotate/header.inc
%%CHORADIR%%/templates/annotate/line.inc
-%%CHORADIR%%/templates/checkout/footer.inc
-%%CHORADIR%%/templates/checkout/header.inc
-%%CHORADIR%%/templates/common-footer.inc
+%%CHORADIR%%/templates/checkout/checkout.inc
%%CHORADIR%%/templates/common-header.inc
+%%CHORADIR%%/templates/cvsgraph/cvsgraph.inc
%%CHORADIR%%/templates/diff/hr/add.inc
%%CHORADIR%%/templates/diff/hr/change.inc
%%CHORADIR%%/templates/diff/hr/empty.inc
@@ -117,60 +97,64 @@
%%CHORADIR%%/templates/history/rev.inc
%%CHORADIR%%/templates/history/row_end.inc
%%CHORADIR%%/templates/history/row_start.inc
-%%CHORADIR%%/templates/index/css.inc
-%%CHORADIR%%/templates/index/notconfigured.inc
-%%CHORADIR%%/templates/log/header.inc
%%CHORADIR%%/templates/log/request.inc
%%CHORADIR%%/templates/log/rev.inc
-%%CHORADIR%%/templates/menu/menu.inc
-etc/horde/httpd.conf.chora
+%%CHORADIR%%/templates/menu.inc
+%%CHORADIR%%/templates/patchsets/ps.inc
+%%CHORADIR%%/templates/stats/stats.inc
+%%CHORADIR%%/themes/burntorange/screen.css
+%%CHORADIR%%/themes/graphics/back.png
+%%CHORADIR%%/themes/graphics/chora.png
+%%CHORADIR%%/themes/graphics/deleted.png
+%%CHORADIR%%/themes/graphics/favicon.ico
+%%CHORADIR%%/themes/graphics/folder.png
+%%CHORADIR%%/themes/screen.css
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%CHORADIR%%/config
-@dirrm %%CHORADIR%%/graphics/mime
-@dirrm %%CHORADIR%%/graphics
-@dirrm %%CHORADIR%%/lib/CVSLib
-@dirrm %%CHORADIR%%/lib/MIME/Viewer
-@dirrm %%CHORADIR%%/lib/MIME
-@dirrm %%CHORADIR%%/lib
-@dirrm %%CHORADIR%%/locale/cs_CZ/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/cs_CZ
-@dirrm %%CHORADIR%%/locale/de_DE/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/de_DE
-@dirrm %%CHORADIR%%/locale/en_US
-@dirrm %%CHORADIR%%/locale/es_ES/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/es_ES
-@dirrm %%CHORADIR%%/locale/fi_FI/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/fi_FI
-@dirrm %%CHORADIR%%/locale/fr_FR/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/fr_FR
-@dirrm %%CHORADIR%%/locale/nb_NO/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/nb_NO
-@dirrm %%CHORADIR%%/locale/nl_NL/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/nl_NL
-@dirrm %%CHORADIR%%/locale/pl_PL/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/pl_PL
-@dirrm %%CHORADIR%%/locale/pt_BR/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/pt_BR
-@dirrm %%CHORADIR%%/locale/ro_RO/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/ro_RO
-@dirrm %%CHORADIR%%/locale/sv_SE/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/sv_SE
-@dirrm %%CHORADIR%%/locale/zh_CN/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/zh_CN
-@dirrm %%CHORADIR%%/locale/zh_TW/LC_MESSAGES
-@dirrm %%CHORADIR%%/locale/zh_TW
-@dirrm %%CHORADIR%%/locale
-@dirrm %%CHORADIR%%/po
-@dirrm %%CHORADIR%%/templates/annotate
-@dirrm %%CHORADIR%%/templates/checkout
+@dirrm %%CHORADIR%%/themes/graphics
+@dirrm %%CHORADIR%%/themes/burntorange
+@dirrm %%CHORADIR%%/themes
+@dirrm %%CHORADIR%%/templates/stats
+@dirrm %%CHORADIR%%/templates/patchsets
+@dirrm %%CHORADIR%%/templates/log
+@dirrm %%CHORADIR%%/templates/history
+@dirrm %%CHORADIR%%/templates/directory
@dirrm %%CHORADIR%%/templates/diff/hr
@dirrm %%CHORADIR%%/templates/diff
-@dirrm %%CHORADIR%%/templates/directory
-@dirrm %%CHORADIR%%/templates/history
-@dirrm %%CHORADIR%%/templates/index
-@dirrm %%CHORADIR%%/templates/log
-@dirrm %%CHORADIR%%/templates/menu
+@dirrm %%CHORADIR%%/templates/cvsgraph
+@dirrm %%CHORADIR%%/templates/checkout
+@dirrm %%CHORADIR%%/templates/annotate
@dirrm %%CHORADIR%%/templates
-@dirrm %%CHORADIR%%
-@unexec if cmp -s %D/www/horde/config/mime_drivers.php %D/www/horde/config/mime_drivers.php.afterChora; then rm -f %D/www/horde/config/mime_drivers.php.afterChora; mv %D/www/horde/config/mime_drivers.php.beforeChora %D/www/horde/config/mime_drivers.php; fi
-@unexec if cmp -s %D/www/horde/config/registry.php %D/www/horde/config/registry.php.afterChora; then rm -f %D/www/horde/config/registry.php.afterChora; mv %D/www/horde/config/registry.php.beforeChora %D/www/horde/config/registry.php; fi
+@dirrm %%CHORADIR%%/po
+@dirrm %%CHORADIR%%/locale/zh_TW/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/zh_TW
+@dirrm %%CHORADIR%%/locale/zh_CN/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/zh_CN
+@dirrm %%CHORADIR%%/locale/sv_SE/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/sv_SE
+@dirrm %%CHORADIR%%/locale/sk_SK/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/sk_SK
+@dirrm %%CHORADIR%%/locale/ro_RO/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/ro_RO
+@dirrm %%CHORADIR%%/locale/pt_BR/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/pt_BR
+@dirrm %%CHORADIR%%/locale/pl_PL/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/pl_PL
+@dirrm %%CHORADIR%%/locale/nl_NL/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/nl_NL
+@dirrm %%CHORADIR%%/locale/nb_NO/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/nb_NO
+@dirrm %%CHORADIR%%/locale/fr_FR/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/fr_FR
+@dirrm %%CHORADIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/fi_FI
+@dirrm %%CHORADIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/es_ES
+@dirrm %%CHORADIR%%/locale/en_US
+@dirrm %%CHORADIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/de_DE
+@dirrm %%CHORADIR%%/locale/cs_CZ/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/cs_CZ
+@dirrm %%CHORADIR%%/locale
+@dirrm %%CHORADIR%%/lib
+@unexec rmdir %D/%%CHORADIR%%/config 2>/dev/null || true
+@unexec rmdir %D/%%CHORADIR%% 2>/dev/null || true