aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-split-sequence-sbcl
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 10:34:41 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 10:34:41 +0000
commit99f202e9f8996dbc842aeee1a9ebc6119cea2f97 (patch)
tree2c2eab3c75ba92a511177d343d874f799fb49e30 /devel/cl-split-sequence-sbcl
parent62956fc232b345fbcb5c9217ecce306ce29194a2 (diff)
downloadports-99f202e9f8996dbc842aeee1a9ebc6119cea2f97.tar.gz
ports-99f202e9f8996dbc842aeee1a9ebc6119cea2f97.zip
New Port: Splitting Common Lisp Sequences (SBCL Binaries)
split-sequence binaries for lang/sbcl PR: ports/52374 Submitted by: Henrik Motakef <henrik.motakef@web.de>
Notes
Notes: svn path=/head/; revision=89639
Diffstat (limited to 'devel/cl-split-sequence-sbcl')
-rw-r--r--devel/cl-split-sequence-sbcl/Makefile41
-rw-r--r--devel/cl-split-sequence-sbcl/pkg-descr8
-rw-r--r--devel/cl-split-sequence-sbcl/pkg-plist2
3 files changed, 51 insertions, 0 deletions
diff --git a/devel/cl-split-sequence-sbcl/Makefile b/devel/cl-split-sequence-sbcl/Makefile
new file mode 100644
index 000000000000..dbd5a523db45
--- /dev/null
+++ b/devel/cl-split-sequence-sbcl/Makefile
@@ -0,0 +1,41 @@
+# New ports collection Makefile for: cl-split-sequence-sbcl
+# Date created: 12 May 2003
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+
+PORTNAME= split-sequence
+PORTVERSION= 20011114.1
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
+ ftp://ftp.ntnu.no/pub/lisp/cclan/ \
+ ftp://www.aarg.net/pub/cclan/ \
+ http://thingamy.com/cclan/ \
+ http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -sbcl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= henrik.motakef@web.de
+COMMENT= Partinitoning Common Lisp sequences
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/split-sequence/split-sequence.asd:${PORTSDIR}/devel/cl-split-sequence \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/split-sequence/split-sequence.asd:${PORTSDIR}/devel/cl-split-sequence \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+
+do-build:
+ FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
+ sbcl --noinform --userinit /dev/null \
+ --eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
+ --eval "(asdf:oos 'asdf:compile-op :split-sequence)" \
+ --eval "(quit)"
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/split-sequence/sbclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/split-sequence/sbclfasl/
+
+.include <bsd.port.mk>
diff --git a/devel/cl-split-sequence-sbcl/pkg-descr b/devel/cl-split-sequence-sbcl/pkg-descr
new file mode 100644
index 000000000000..7f0ca707f9d9
--- /dev/null
+++ b/devel/cl-split-sequence-sbcl/pkg-descr
@@ -0,0 +1,8 @@
+split-sequence is a small library to split sequences in to a list of
+subsequences delimited by an object satisfying a test function. It is
+a member of the Common Lisp Utilities family of programs, designed by
+community consensus.
+
+WWW: http://www.cliki.net/SPLIT-SEQUENCE
+
+-- Henrik Motakef
diff --git a/devel/cl-split-sequence-sbcl/pkg-plist b/devel/cl-split-sequence-sbcl/pkg-plist
new file mode 100644
index 000000000000..a37df7314122
--- /dev/null
+++ b/devel/cl-split-sequence-sbcl/pkg-plist
@@ -0,0 +1,2 @@
+lib/common-lisp/split-sequence/sbclfasl/split-sequence.fasl
+@dirrm lib/common-lisp/split-sequence/sbclfasl