aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-split-sequence
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 12:14:39 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 12:14:39 +0000
commit1ac224e5633aab81a4aa7a40d84308751aa6bbe1 (patch)
tree364e168d1c32783717ae24623ca009a9e3afac74 /devel/cl-split-sequence
parent0771132bce39427ace1fc0c1a360e09e40965a9d (diff)
downloadports-1ac224e5633aab81a4aa7a40d84308751aa6bbe1.tar.gz
ports-1ac224e5633aab81a4aa7a40d84308751aa6bbe1.zip
Remove redundant code and variables from the cl-* ports.
Introduce bsd.cl-asdf.mk to automate the compilation and installation of Common Lisp libraries using the ASDF framework. Currently it supports building FASL files on SBCL and CLISP, to support the ports that already exist in the ports tree. This should help bringing in more cl-* ports from the ASDF repository without excessive code duplication.
Notes
Notes: svn path=/head/; revision=247937
Diffstat (limited to 'devel/cl-split-sequence')
-rw-r--r--devel/cl-split-sequence/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/devel/cl-split-sequence/Makefile b/devel/cl-split-sequence/Makefile
index 20d0e9b19fc9..327679b4f956 100644
--- a/devel/cl-split-sequence/Makefile
+++ b/devel/cl-split-sequence/Makefile
@@ -6,6 +6,7 @@
PORTNAME= split-sequence
PORTVERSION= 20011114.1
+PORTREVISION= 1
CATEGORIES= devel lisp
MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
ftp://ftp.ntnu.no/pub/lisp/cclan/ \
@@ -16,17 +17,16 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Partitioning Common Lisp sequences
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
-
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-CL_LIBDIR= ${PREFIX}/lib/common-lisp
+
+USE_ASDF= yes
do-install:
- @${MKDIR} ${CL_LIBDIR}/split-sequence
- @${INSTALL_DATA} ${WRKSRC}/split-sequence.lisp ${CL_LIBDIR}/split-sequence/
- @${INSTALL_DATA} ${WRKSRC}/split-sequence.asd ${CL_LIBDIR}/split-sequence/
- @${LN} -sf ${CL_LIBDIR}/split-sequence/split-sequence.asd ${CL_LIBDIR}/system-registry/split-sequence.asd
+ @${MKDIR} ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/split-sequence.lisp ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/split-sequence.asd ${ASDF_PATHNAME}
+ @${LN} -sf ${ASDF_PATHNAME}/*.asd ${ASDF_REGISTRY}
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>