aboutsummaryrefslogtreecommitdiff
path: root/devel/clanlib/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-09-25 06:58:43 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-09-25 06:58:43 +0000
commit78d89936e265334c337c4a9858e8b4a26bf93b2b (patch)
tree6afe93024e33a60e5ce7d599152e7d61dca663f2 /devel/clanlib/Makefile
parentad82bf983f0713dbffc1f90aac9ab03938f49ed0 (diff)
downloadports-78d89936e265334c337c4a9858e8b4a26bf93b2b.tar.gz
ports-78d89936e265334c337c4a9858e8b4a26bf93b2b.zip
Add clanlib - a cross-platform game SDK (yes, it works with svgalib :-> ).
Notes
Notes: svn path=/head/; revision=33083
Diffstat (limited to 'devel/clanlib/Makefile')
-rw-r--r--devel/clanlib/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
new file mode 100644
index 000000000000..e626bc708733
--- /dev/null
+++ b/devel/clanlib/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: clanlib
+# Date created: 10 May 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clanlib
+PORTVERSION= 0.4.4
+CATEGORIES= devel
+MASTER_SITES= http://dark.x.dtu.dk/~mbn/clanlib/download/
+DISTNAME= ClanLib-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= Hermes.1:${PORTSDIR}/graphics/Hermes \
+ png.4:${PORTSDIR}/graphics/png \
+ vga.1:${PORTSDIR}/graphics/svgalib
+
+.if defined(WITHOUT_GL)
+CONFIGURE_ARGS+= --disable-opengl
+.else
+USE_MESA= yes
+CONFIGURE_ARGS+= --enable-opengl
+PLIST= ${WRKDIR}/PLIST
+.endif
+
+USE_GMAKE= yes
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+CFLAGS+= -fpermissive
+ALL_TARGET+= clanPNG clanGL
+
+.if !defined(WITHOUT_GL)
+pre-install:
+ @cat ${PKGDIR}/PLIST.glx ${PKGDIR}/PLIST > ${PLIST}
+.endif
+
+.include <bsd.port.mk>