aboutsummaryrefslogtreecommitdiff
path: root/devel/clanlib
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-24 15:17:18 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-24 15:17:18 +0000
commita7861559af5a54df393c72151f19a9d0256eb5a8 (patch)
treeb335e06e523468b9dec87f1c1419f72a6b453e56 /devel/clanlib
parent513a769b7afbb6f37b3e800a08e65887765c6ae1 (diff)
downloadports-a7861559af5a54df393c72151f19a9d0256eb5a8.tar.gz
ports-a7861559af5a54df393c72151f19a9d0256eb5a8.zip
- Update to version 0.7.5.2
PR: 58380 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=92073
Diffstat (limited to 'devel/clanlib')
-rw-r--r--devel/clanlib/Makefile8
-rw-r--r--devel/clanlib/distinfo2
-rw-r--r--devel/clanlib/files/patch-inputbox.cpp10
-rw-r--r--devel/clanlib/files/patch-soundprovider_recorder_oss.cpp16
-rw-r--r--devel/clanlib/files/patch-thread_pthread.cpp9
-rw-r--r--devel/clanlib/pkg-plist5
6 files changed, 44 insertions, 6 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index 88234d217f50..48a63977ed21 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= clanlib
-PORTVERSION= 0.7.4.1
+PORTVERSION= 0.7.5.2
CATEGORIES= devel
MASTER_SITES= http://clanlib.org/~sphair/download/
DISTNAME= ClanLib-${PORTVERSION:R}-${PORTVERSION:E}
@@ -86,8 +86,10 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-lpthread||g'
+ @${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|SDL/SDL|SDL|g'
+ @${REINPLACE_CMD} -e 's|-lpthread||g' \
+ ${WRKSRC}/Sources/Core/Makefile.in
@${REINPLACE_CMD} -e 's|@perl_exec@|${PERL}|g' \
${WRKSRC}/Documentation/Utilities/webbuilder.pl.in
diff --git a/devel/clanlib/distinfo b/devel/clanlib/distinfo
index fc79778adfbf..306ecb0ebcb0 100644
--- a/devel/clanlib/distinfo
+++ b/devel/clanlib/distinfo
@@ -1 +1 @@
-MD5 (ClanLib-0.7.4-1.tar.bz2) = cf7aabf73590b4fedfa53907029de588
+MD5 (ClanLib-0.7.5-2.tar.bz2) = 40f56ddae5e136d126e6066dc4b6ef1a
diff --git a/devel/clanlib/files/patch-inputbox.cpp b/devel/clanlib/files/patch-inputbox.cpp
new file mode 100644
index 000000000000..6267f55bea24
--- /dev/null
+++ b/devel/clanlib/files/patch-inputbox.cpp
@@ -0,0 +1,10 @@
+--- Sources/GUI/inputbox.cpp.orig Tue Oct 21 03:51:39 2003
++++ Sources/GUI/inputbox.cpp Tue Oct 21 04:05:08 2003
+@@ -21,6 +21,7 @@
+ */
+
+ #include "precomp.h"
++#include <cstdio>
+ #include "API/Core/XML/dom_element.h"
+ #include "API/GUI/inputbox.h"
+ #include "API/GUI/stylemanager.h"
diff --git a/devel/clanlib/files/patch-soundprovider_recorder_oss.cpp b/devel/clanlib/files/patch-soundprovider_recorder_oss.cpp
new file mode 100644
index 000000000000..703d668b2cad
--- /dev/null
+++ b/devel/clanlib/files/patch-soundprovider_recorder_oss.cpp
@@ -0,0 +1,16 @@
+--- Sources/Sound/SoundProviders/Unix/soundprovider_recorder_oss.cpp.orig Tue Sep 23 07:15:13 2003
++++ Sources/Sound/SoundProviders/Unix/soundprovider_recorder_oss.cpp Tue Oct 21 02:52:21 2003
+@@ -34,6 +34,13 @@
+ #include <sys/select.h>
+ #endif
+
++#if !defined(AFMT_S16_NE)
++#if defined(BYTE_ORDER) && (BYTE_ORDER == BIG_ENDIAN)
++#define AFMT_S16_NE AFMT_S16_BE
++#else
++#define AFMT_S16_NE AFMT_S16_LE
++#endif
++#endif
+
+ /////////////////////////////////////////////////////////////////////////////
+ // CL_SoundProvider_Recorder_OSS_Session construction:
diff --git a/devel/clanlib/files/patch-thread_pthread.cpp b/devel/clanlib/files/patch-thread_pthread.cpp
new file mode 100644
index 000000000000..e9cae5ddd1ed
--- /dev/null
+++ b/devel/clanlib/files/patch-thread_pthread.cpp
@@ -0,0 +1,9 @@
+--- Sources/Core/System/Unix/thread_pthread.cpp.orig Thu Oct 9 02:43:49 2003
++++ Sources/Core/System/Unix/thread_pthread.cpp Tue Oct 21 01:22:12 2003
+@@ -158,5 +158,5 @@
+
+ int CL_Thread::get_current_id()
+ {
+- return pthread_self();
++ return (int)pthread_self();
+ }
diff --git a/devel/clanlib/pkg-plist b/devel/clanlib/pkg-plist
index 3f9e34f4d033..9d20f91a7051 100644
--- a/devel/clanlib/pkg-plist
+++ b/devel/clanlib/pkg-plist
@@ -91,6 +91,7 @@ include/ClanLib-0.7/ClanLib/Display/display_mode.h
include/ClanLib-0.7/ClanLib/Display/display_window.h
include/ClanLib-0.7/ClanLib/Display/display_window_description.h
include/ClanLib-0.7/ClanLib/Display/font.h
+include/ClanLib-0.7/ClanLib/Display/frameratecounter.h
include/ClanLib-0.7/ClanLib/Display/glyph_buffer.h
include/ClanLib-0.7/ClanLib/Display/gradient.h
include/ClanLib-0.7/ClanLib/Display/graphic_context.h
@@ -123,13 +124,11 @@ include/ClanLib-0.7/ClanLib/GUI/checkbox.h
include/ClanLib-0.7/ClanLib/GUI/component.h
include/ClanLib-0.7/ClanLib/GUI/component_manager.h
include/ClanLib-0.7/ClanLib/GUI/component_move_handler.h
-include/ClanLib-0.7/ClanLib/GUI/component_options.h
include/ClanLib-0.7/ClanLib/GUI/component_resize_handler.h
include/ClanLib-0.7/ClanLib/GUI/component_style.h
include/ClanLib-0.7/ClanLib/GUI/component_type.h
include/ClanLib-0.7/ClanLib/GUI/filedialog.h
include/ClanLib-0.7/ClanLib/GUI/frame.h
-include/ClanLib-0.7/ClanLib/GUI/gui_file_parser.h
include/ClanLib-0.7/ClanLib/GUI/gui_manager.h
include/ClanLib-0.7/ClanLib/GUI/image.h
include/ClanLib-0.7/ClanLib/GUI/inputbox.h
@@ -180,6 +179,7 @@ include/ClanLib-0.7/ClanLib/GUIStyleSilver/window_silver.h
include/ClanLib-0.7/ClanLib/Network/Browse/browse_client.h
include/ClanLib-0.7/ClanLib/Network/Browse/browse_master.h
include/ClanLib-0.7/ClanLib/Network/Browse/browse_server.h
+include/ClanLib-0.7/ClanLib/Network/IRC/dcc_download.h
include/ClanLib-0.7/ClanLib/Network/IRC/irc_connection.h
include/ClanLib-0.7/ClanLib/Network/IRC/irc_numerics.h
include/ClanLib-0.7/ClanLib/Network/NetObjects/netobject_client.h
@@ -223,6 +223,7 @@ include/ClanLib-0.7/ClanLib/Sound/SoundFilters/fadefilter.h
include/ClanLib-0.7/ClanLib/Sound/SoundFilters/inverse_echofilter.h
include/ClanLib-0.7/ClanLib/Sound/SoundProviders/soundprovider_factory.h
include/ClanLib-0.7/ClanLib/Sound/SoundProviders/soundprovider_raw.h
+include/ClanLib-0.7/ClanLib/Sound/SoundProviders/soundprovider_recorder.h
include/ClanLib-0.7/ClanLib/Sound/SoundProviders/soundprovider_type.h
include/ClanLib-0.7/ClanLib/Sound/SoundProviders/soundprovider_type_register.h
include/ClanLib-0.7/ClanLib/Sound/SoundProviders/soundprovider_wave.h