aboutsummaryrefslogtreecommitdiff
path: root/devel/clig
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-09-26 13:36:23 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-09-26 13:36:23 +0000
commit034f8ff65f88c3b88ba8d5b30611bc45ad9089c8 (patch)
treecbb93335aaf6f874625e76f1f899558ba02264cb /devel/clig
parent19745ebb805d87b98077c886a1c879353e686482 (diff)
downloadports-034f8ff65f88c3b88ba8d5b30611bc45ad9089c8.tar.gz
ports-034f8ff65f88c3b88ba8d5b30611bc45ad9089c8.zip
- Convert to USES+=tcl
- Respect PORT_OPTIONS:MDOCS - Support STAGE
Notes
Notes: svn path=/head/; revision=328356
Diffstat (limited to 'devel/clig')
-rw-r--r--devel/clig/Makefile15
-rw-r--r--devel/clig/files/patch-install14
-rw-r--r--devel/clig/files/patch-makefile9
-rw-r--r--devel/clig/pkg-plist26
4 files changed, 44 insertions, 20 deletions
diff --git a/devel/clig/Makefile b/devel/clig/Makefile
index 07e2d6070cc7..0af889199988 100644
--- a/devel/clig/Makefile
+++ b/devel/clig/Makefile
@@ -10,22 +10,21 @@ MASTER_SITES= http://wsd.iitb.fhg.de/~geg/clighome/
MAINTAINER= ports@FreeBSD.org
COMMENT= Auto-generate an (argc, argv) processor, usage message, and manpage
+OPTIONS_DEFINE= DOCS
+
NO_BUILD= yes
-USE_TCL_BUILD= yes
-USE_TCL= yes
+USES+= tcl
MAKEFILE= makefile
+MAKE_ENV+= NOPORTDOCS=${NOPORTDOCS}
WRKSRC= ${WRKDIR}/${PORTNAME}
+PORTDOCS= *
-MAN1= clig.1
-MANN= clig_Commandline.n clig_Description.n clig_Double.n clig_Flag.n \
- clig_Float.n clig_Int.n clig_Long.n clig_Name.n clig_Rest.n \
- clig_String.n clig_Usage.n clig_Version.n clig_parseCmdline.n
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-patch:
@${RM} ${WRKSRC}/example/.cvsignore
@${FIND} -d ${WRKSRC} -type d -and -name CVS -exec ${RM} -r {} \;
- @${REINPLACE_CMD} -e 's|prefix =/usr|prefix=${PREFIX}|; \
+ @${REINPLACE_CMD} -e 's|prefix =/usr|prefix=${STAGEDIR}${PREFIX}|; \
s|/usr/bin/tclsh|${TCLSH}|; \
s|/doc/|/share/doc/|; \
s|-$$(VERSION)||;' \
diff --git a/devel/clig/files/patch-install b/devel/clig/files/patch-install
new file mode 100644
index 000000000000..01af6fbd1075
--- /dev/null
+++ b/devel/clig/files/patch-install
@@ -0,0 +1,14 @@
+--- install.orig 2000-01-16 18:15:32.000000000 +0100
++++ install 2013-09-26 15:30:00.000000000 +0200
+@@ -64,9 +64,11 @@
+ }
+
+ # doc and examples
++if {$env(NOPORTDOCS) eq {}} {
+ file copy -force CHANGES ANNOUNCE index.html README WISHLIST \
+ COPYING-2.0 LICENSE example \
+ $env(DOCDIR)
++}
+ ########################################################################
+ ## Local Variables: ##
+ ## mode:tcl ##
diff --git a/devel/clig/files/patch-makefile b/devel/clig/files/patch-makefile
new file mode 100644
index 000000000000..7c7a407f5b40
--- /dev/null
+++ b/devel/clig/files/patch-makefile
@@ -0,0 +1,9 @@
+--- makefile.orig 2013-09-26 15:22:07.000000000 +0200
++++ makefile 2013-09-26 15:22:46.000000000 +0200
+@@ -104,4 +104,5 @@
+ M1SUFFIX=$(M1SUFFIX) \
+ MANnDIR=$(build_root)$(MANnDIR) MnFILES="$(MnFILES.f)" \
+ MnSUFFIX=$(MnSUFFIX) \
+- DOCDIR=$(build_root)$(DOCDIR) VERSION=$(VERSION)
++ DOCDIR=$(build_root)$(DOCDIR) VERSION=$(VERSION) \
++ NOPORTDOCS=${NOPORTDOCS}
diff --git a/devel/clig/pkg-plist b/devel/clig/pkg-plist
index b6969517eb53..601ebf532152 100644
--- a/devel/clig/pkg-plist
+++ b/devel/clig/pkg-plist
@@ -55,19 +55,21 @@ lib/clig/tcllib/parse.tcl
lib/clig/tcllib/setSpec.tcl
lib/clig/tcllib/usage.tcl
lib/clig/tcllib/version.tcl
-share/doc/clig/ANNOUNCE
-share/doc/clig/CHANGES
-share/doc/clig/COPYING-2.0
-share/doc/clig/LICENSE
-share/doc/clig/README
-share/doc/clig/WISHLIST
-share/doc/clig/example/cmdline.cli
-share/doc/clig/example/main.c
-share/doc/clig/example/makefile
-share/doc/clig/index.html
+man/man1/clig.1.gz
+man/mann/clig_Commandline.n.gz
+man/mann/clig_Description.n.gz
+man/mann/clig_Double.n.gz
+man/mann/clig_Flag.n.gz
+man/mann/clig_Float.n.gz
+man/mann/clig_Int.n.gz
+man/mann/clig_Long.n.gz
+man/mann/clig_Name.n.gz
+man/mann/clig_Rest.n.gz
+man/mann/clig_String.n.gz
+man/mann/clig_Usage.n.gz
+man/mann/clig_Version.n.gz
+man/mann/clig_parseCmdline.n.gz
@dirrm lib/clig/c
@dirrm lib/clig/tcl
@dirrm lib/clig/tcllib
@dirrm lib/clig
-@dirrm share/doc/clig/example
-@dirrm share/doc/clig