aboutsummaryrefslogtreecommitdiff
path: root/devel/clixon
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2018-04-25 19:03:14 +0000
committerRenato Botelho <garga@FreeBSD.org>2018-04-25 19:03:14 +0000
commitc41da5e159263e63339dafab8bc16dc8f1327b73 (patch)
tree1907ba55ffae4d642424fce7c16beb1da0e2f46d /devel/clixon
parent857d77f1a95ac9a1e85bc0a610b383629b689554 (diff)
downloadports-c41da5e159263e63339dafab8bc16dc8f1327b73.tar.gz
ports-c41da5e159263e63339dafab8bc16dc8f1327b73.zip
Clixon is a CLI/network interfaced configuration database tool
Using Clixon you can create CLI, RESTCONF, and NETCONF interfaces to manage a configuration database. It also provides the mechanism to validate and configure system components. WWW: http://www.clicon.org/ PR: 227681 Submitted by: dcornejo@netgate.com Sponsored by: Rubicon Communications, LLC (Netgate)
Notes
Notes: svn path=/head/; revision=468289
Diffstat (limited to 'devel/clixon')
-rw-r--r--devel/clixon/Makefile28
-rw-r--r--devel/clixon/distinfo3
-rw-r--r--devel/clixon/files/patch-apps_netconf_Makefile.in11
-rw-r--r--devel/clixon/files/patch-apps_restconf_Makefile.in30
-rw-r--r--devel/clixon/pkg-descr7
-rw-r--r--devel/clixon/pkg-plist30
6 files changed, 109 insertions, 0 deletions
diff --git a/devel/clixon/Makefile b/devel/clixon/Makefile
new file mode 100644
index 000000000000..4cd26be1db9c
--- /dev/null
+++ b/devel/clixon/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= clixon
+DISTVERSION= 3.6.0.b.20180424
+CATEGORIES= devel
+
+MAINTAINER= dcornejo@netgate.com
+COMMENT= CLIgen is a Command-Line Interface generator
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+LIB_DEPENDS= libcligen.so:devel/cligen \
+ libfcgi.so:www/fcgi
+
+USES= gmake
+
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= clicon
+GH_TAGNAME= d57a6cf53cdda4a3e5da122eb34de5ce069676f0
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-cligen=${LOCALBASE} --sysconfdir=${ETCDIR}
+
+MAKE_JOBS_UNSAFE=yes
+
+.include <bsd.port.mk>
diff --git a/devel/clixon/distinfo b/devel/clixon/distinfo
new file mode 100644
index 000000000000..e31b31703cba
--- /dev/null
+++ b/devel/clixon/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1524681931
+SHA256 (clicon-clixon-3.6.0.b.20180424-d57a6cf53cdda4a3e5da122eb34de5ce069676f0_GH0.tar.gz) = 3985436b89f0e1547ac8d49b277877a1cd5b4001bc2fbca14ffc217d81dcdca9
+SIZE (clicon-clixon-3.6.0.b.20180424-d57a6cf53cdda4a3e5da122eb34de5ce069676f0_GH0.tar.gz) = 697630
diff --git a/devel/clixon/files/patch-apps_netconf_Makefile.in b/devel/clixon/files/patch-apps_netconf_Makefile.in
new file mode 100644
index 000000000000..42896da2bab2
--- /dev/null
+++ b/devel/clixon/files/patch-apps_netconf_Makefile.in
@@ -0,0 +1,11 @@
+--- apps/netconf/Makefile.in.orig 2018-04-15 09:53:12 UTC
++++ apps/netconf/Makefile.in
+@@ -44,7 +44,7 @@ bindir = @bindir@
+ libdir = @libdir@
+ mandir = @mandir@
+ libexecdir = @libexecdir@
+-wwwdir = /www-data
++wwwdir = @prefix@/sbin
+ localstatedir = @localstatedir@
+ sysconfdir = @sysconfdir@
+ includedir = @includedir@
diff --git a/devel/clixon/files/patch-apps_restconf_Makefile.in b/devel/clixon/files/patch-apps_restconf_Makefile.in
new file mode 100644
index 000000000000..510a55f056d8
--- /dev/null
+++ b/devel/clixon/files/patch-apps_restconf_Makefile.in
@@ -0,0 +1,30 @@
+--- apps/restconf/Makefile.in.orig 2018-04-24 15:43:19 UTC
++++ apps/restconf/Makefile.in
+@@ -44,7 +44,7 @@ bindir = @bindir@
+ libdir = @libdir@
+ mandir = @mandir@
+ libexecdir = @libexecdir@
+-wwwdir = /www-data
++wwwdir = @sbindir@
+ localstatedir = @localstatedir@
+ sysconfdir = @sysconfdir@
+ includedir = @includedir@
+@@ -101,14 +101,14 @@ install: install-lib $(APPL)
+ install -m 0755 -s $(APPL) $(DESTDIR)$(wwwdir)
+
+ install-lib: $(MYLIB)
+- install -d $(DESTDIR)$(libdir)
+- install $(MYLIB) $(DESTDIR)$(libdir)
++ install -d -m 0755 $(DESTDIR)$(libdir)
++ install -m 0644 -s $(MYLIB) $(DESTDIR)$(libdir)
+ ln -sf $(MYLIB) $(DESTDIR)$(libdir)/$(MYLIBSO) # -l:libclixon_restconf.so.2
+ ln -sf $(MYLIBSO) $(DESTDIR)$(libdir)/$(MYLIBLINK) # -l:libclixon_restconf.so
+
+ install-include: clixon_restconf.h
+- install -d $(DESTDIR)$(includedir)/clixon
+- install -m 644 $^ $(DESTDIR)$(includedir)/clixon
++ install -d -m 0755 $(DESTDIR)$(includedir)/clixon
++ install -m 0644 $^ $(DESTDIR)$(includedir)/clixon
+
+ uninstall:
+ rm -f $(DESTDIR)$(wwwdir)/$(APPL)
diff --git a/devel/clixon/pkg-descr b/devel/clixon/pkg-descr
new file mode 100644
index 000000000000..aa61ad0982ab
--- /dev/null
+++ b/devel/clixon/pkg-descr
@@ -0,0 +1,7 @@
+Clixon is a CLI/network interfaced configuration database tool
+
+Using Clixon you can create CLI, RESTCONF, and NETCONF interfaces to manage a
+configuration database. It also provides the mechanism to validate and configure
+system components.
+
+WWW: http://www.clicon.org/
diff --git a/devel/clixon/pkg-plist b/devel/clixon/pkg-plist
new file mode 100644
index 000000000000..3951bbb3e9cc
--- /dev/null
+++ b/devel/clixon/pkg-plist
@@ -0,0 +1,30 @@
+bin/clixon_cli
+bin/clixon_netconf
+bin/datastore_client
+%%ETCDIR%%/clixonrc
+lib/libclixon.so
+lib/libclixon.so.3
+lib/libclixon.so.3.6
+lib/libclixon_backend.so
+lib/libclixon_backend.so.3
+lib/libclixon_backend.so.3.6
+lib/libclixon_cli.so
+lib/libclixon_cli.so.3
+lib/libclixon_cli.so.3.6
+lib/libclixon_netconf.so
+lib/libclixon_netconf.so.3
+lib/libclixon_netconf.so.3.6
+lib/libclixon_restconf.so
+lib/libclixon_restconf.so.3
+lib/libclixon_restconf.so.3.6
+lib/xmldb/text.so
+sbin/clixon_backend
+sbin/clixon_restconf
+%%DATADIR%%/clixon-config@2018-02-12.yang
+%%DATADIR%%/clixon.mk
+%%DATADIR%%/ietf-inet-types@2013-07-15.yang
+%%DATADIR%%/ietf-netconf-acm@2018-02-14.yang
+%%DATADIR%%/ietf-netconf@2011-06-01.yang
+%%DATADIR%%/ietf-yang-types@2013-07-15.yang
+@dir lib/clixon/plugins/backend
+@dir lib/clixon/plugins/cli