aboutsummaryrefslogtreecommitdiff
path: root/devel/codeworker
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-02 06:01:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-02 06:01:32 +0000
commit3816c2d654798ffefedccdcb45ea3db59d13747c (patch)
treedfcc832cd7fe6811cbab3cced79d674dc536d2eb /devel/codeworker
parente97e99a67df31d6597bbec0725138c75985cdc8d (diff)
downloadports-3816c2d654798ffefedccdcb45ea3db59d13747c.tar.gz
ports-3816c2d654798ffefedccdcb45ea3db59d13747c.zip
- Update to 4.5.3
- Trim header - Update pkg-desc PR: 176575 Submitted by: ports fury
Notes
Notes: svn path=/head/; revision=313200
Diffstat (limited to 'devel/codeworker')
-rw-r--r--devel/codeworker/Makefile23
-rw-r--r--devel/codeworker/distinfo4
-rw-r--r--devel/codeworker/files/patch-GrfForeach.h14
-rw-r--r--devel/codeworker/files/patch-NetSocket.cpp23
-rw-r--r--devel/codeworker/pkg-descr22
5 files changed, 27 insertions, 59 deletions
diff --git a/devel/codeworker/Makefile b/devel/codeworker/Makefile
index 494ce9471b6d..de4a1e651189 100644
--- a/devel/codeworker/Makefile
+++ b/devel/codeworker/Makefile
@@ -1,34 +1,37 @@
-# ex:ts=8
-# Ports collection makefile for: CodeWorker
-# Date created: Dec 31, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= codeworker
-PORTVERSION= 4.2
+PORTVERSION= 4.5.3
CATEGORIES= devel
MASTER_SITES= http://codeworker.free.fr/downloads/
DISTNAME= CodeWorker_SRC${PORTVERSION:S/./_/g}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A parsing tool and a source code generator
+COMMENT= Versatile parsing tool and source code generator
-EXTRACT_BEFORE_ARGS= -qo -aa
+LICENSE= LGPL21
WRKSRC= ${WRKDIR}/CodeWorker${PORTVERSION:S/./_/g}
USE_ZIP= yes
+USE_DOS2UNIX= yes
USE_GMAKE= yes
MAKE_ARGS= CC="${CXX}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" LFLAGS="-lm"
ALL_TARGET= build
+MAKE_JOBS_SAFE= yes
CFLAGS+= -Dstricmp=strcasecmp
PLIST_FILES= bin/codeworker
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.cpp" -or -name "*.h" | ${XARGS} \
+ ${REINPLACE_CMD} -e \
+ 's|<features.h>|<cstdio>| ; \
+ s|__GNUC_PREREQ |__GNUC_PREREQ__|'
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/codeworker ${PREFIX}/bin
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} codeworker ${PREFIX}/bin)
.include <bsd.port.mk>
diff --git a/devel/codeworker/distinfo b/devel/codeworker/distinfo
index 307a5200c9f2..7706a98b1f72 100644
--- a/devel/codeworker/distinfo
+++ b/devel/codeworker/distinfo
@@ -1,2 +1,2 @@
-SHA256 (CodeWorker_SRC4_2.zip) = b6749f97ca5ba16ed6fd3be4fbb0ad6e98056f8c43c5854da17f3cd7325c5756
-SIZE (CodeWorker_SRC4_2.zip) = 3178438
+SHA256 (CodeWorker_SRC4_5_3.zip) = b5fdf7b01d280d37b5534fe29890cb21357e11393bcab6f129c1a141485f799f
+SIZE (CodeWorker_SRC4_5_3.zip) = 3277274
diff --git a/devel/codeworker/files/patch-GrfForeach.h b/devel/codeworker/files/patch-GrfForeach.h
deleted file mode 100644
index 8ad4584eae36..000000000000
--- a/devel/codeworker/files/patch-GrfForeach.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- GrfForeach.h.orig
-+++ GrfForeach.h
-@@ -83,7 +83,7 @@
- virtual SEQUENCE_INTERRUPTION_LIST executeReverseSortedForeach(DtaScriptVariable& theVariable, DtaScriptVariable& stackForeach);
- virtual SEQUENCE_INTERRUPTION_LIST executeReverseSortedIndirectForeach(DtaScriptVariable& theVariable, DtaScriptVariable& stackForeach);
-
-- SEQUENCE_INTERRUPTION_LIST GrfForeach::iterate(DtaArrayIterator& iteratorData, DtaScriptVariable& stackForeach);
-+ SEQUENCE_INTERRUPTION_LIST iterate(DtaArrayIterator& iteratorData, DtaScriptVariable& stackForeach);
- };
- }
-
diff --git a/devel/codeworker/files/patch-NetSocket.cpp b/devel/codeworker/files/patch-NetSocket.cpp
deleted file mode 100644
index 6620067f24e1..000000000000
--- a/devel/codeworker/files/patch-NetSocket.cpp
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- NetSocket.cpp.orig
-+++ NetSocket.cpp
-@@ -45,7 +45,7 @@
- namespace CodeWorker {
- bool socketReaderCBK(ScpStream& theStream, void* pData) {
- char tcBuffer[2048];
-- int hSocket = (int) pData;
-+ int hSocket = (intptr_t) pData;
- int iLength = recv(hSocket, tcBuffer, 2047, 0);
- if (iLength <= 0) return false;
- theStream.writeBinaryData(tcBuffer, iLength);
-@@ -53,7 +53,7 @@
- }
-
- bool socketWriterCBK(ScpStream& theStream, void* pData) {
-- int hSocket = (int) pData;
-+ int hSocket = (intptr_t) pData;
- int iLength = theStream.size();
- if (iLength <= 0) return false;
- return NetSocket::sendToSocket(hSocket, theStream.readBuffer(), iLength);
diff --git a/devel/codeworker/pkg-descr b/devel/codeworker/pkg-descr
index 38f980f728f7..baaf9e0bbfc8 100644
--- a/devel/codeworker/pkg-descr
+++ b/devel/codeworker/pkg-descr
@@ -1,13 +1,15 @@
-CodeWorker is a parsing tool and a source code generator, available in Open
-Source (distributed under the GNU Lesser General Public License) devoted to
-cover many aspects of the generative programming. Generative programming is
-a software engineering approach for producing reusable, tailor-made, evolvable
-and reliable IT systems with a high level of automation.
+CodeWorker is a parsing tool and a source code generator, available in
+Open Source (distributed under the GNU Lesser General Public License)
+devoted to cover many aspects of the generative programming. Generative
+programming is a software engineering approach for producing reusable,
+tailor-made, evolvable and reliable IT systems with a high level of
+automation.
-The tool interprets a scripting language that drives the processing of parsing
-and source code generation in a quite familiar syntax for developers. It
-insists on adapting the syntax of the language to the particularities of tasks
-to resolve (parse, code generation, procedural) and on offering powerful
-functionalities to do intensive source code generation.
+The tool interprets a scripting language that drives the processing of
+parsing and source code generation in a quite familiar syntax for
+developers. It insists on adapting the syntax of the language to the
+particularities of tasks to resolve (parse, code generation, procedural)
+and on offering powerful functionalities to do intensive source code
+generation.
WWW: http://codeworker.free.fr/