aboutsummaryrefslogtreecommitdiff
path: root/devel/commoncpp/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-02 14:42:31 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-02 14:42:31 +0000
commit96187d7a683eb632df0f5de98bea7d96161c7bc7 (patch)
tree5370830ed78f7ad6e8cee899d68cf0812accb64f /devel/commoncpp/Makefile
parent455eee4b11d54925c15bb02ec61fd3b6548562c4 (diff)
downloadports-96187d7a683eb632df0f5de98bea7d96161c7bc7.tar.gz
ports-96187d7a683eb632df0f5de98bea7d96161c7bc7.zip
- Update to 1.5.7
PR: 116300 Submitted by: alepulver
Notes
Notes: svn path=/head/; revision=200655
Diffstat (limited to 'devel/commoncpp/Makefile')
-rw-r--r--devel/commoncpp/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index 0562f6397a50..c83a6c54940f 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -6,35 +6,35 @@
#
PORTNAME= commoncpp
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.7
PORTEPOCH= 2
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= gnutelephony
+MASTER_SITES= GNU
DISTNAME= ${PORTNAME:S/$/2/}-${PORTVERSION}
MAINTAINER= acm@FreeBSD.org
COMMENT= GNU project portable class framework for C++
+USE_LDCONFIG= yes
USE_GNOME= gnomehack gnometarget
-
-.if !defined(WITHOUT_LIBXML2)
-USE_GNOME+= libxml2
-.else
-CONFIGURE_ARGS= --without-libxml2
-.endif
-
-USE_GETOPT_LONG=yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GCC= 3.4+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
ac_cv_path_DOXYGEN=no
-USE_LDCONFIG= yes
+
+OPTIONS= LIBXML2 "Enable libxml2 support" on
INFO= commoncpp2
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_LIBXML2)
+USE_GNOME+= libxml2
+.else
+CONFIGURE_ARGS+=--without-libxml2
+.endif
+
+.include <bsd.port.post.mk>