aboutsummaryrefslogtreecommitdiff
path: root/devel/commoncpp
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-12-23 10:48:05 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-12-23 10:48:05 +0000
commit602729a7e1011447a86e475547468addfdaad6af (patch)
treefc640edd090dd7126a1e14240591147ebfbc2927 /devel/commoncpp
parent00c5c75ce39e2a5972a850248000da5c1e556d00 (diff)
downloadports-602729a7e1011447a86e475547468addfdaad6af.tar.gz
ports-602729a7e1011447a86e475547468addfdaad6af.zip
Fix build with GCC 3.4.2, and unbreak.
Notes
Notes: svn path=/head/; revision=124963
Diffstat (limited to 'devel/commoncpp')
-rw-r--r--devel/commoncpp/Makefile8
-rw-r--r--devel/commoncpp/files/patch-include_cc++_thread.h11
2 files changed, 12 insertions, 7 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index d6e8acae0a90..9246596f8c8b 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -26,10 +26,4 @@ INSTALLS_SHLIB= yes
INFO= commoncpp2
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/commoncpp/files/patch-include_cc++_thread.h b/devel/commoncpp/files/patch-include_cc++_thread.h
new file mode 100644
index 000000000000..8b976b1ac738
--- /dev/null
+++ b/devel/commoncpp/files/patch-include_cc++_thread.h
@@ -0,0 +1,11 @@
+--- include/cc++/thread.h.orig Sat Jan 17 17:51:01 2004
++++ include/cc++/thread.h Thu Dec 23 16:38:55 2004
+@@ -914,7 +914,7 @@
+ static Thread* _main;
+
+ Thread *_parent;
+- enum Cancel _cancel;
++ Cancel _cancel;
+ Semaphore *_start;
+
+ // private data