aboutsummaryrefslogtreecommitdiff
path: root/devel/cook/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-30 16:21:33 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-30 16:21:33 +0000
commit931c32fc4b80a4d07bd5c3da9c19587b9f95382e (patch)
tree3f74d4e987ae5e2913ee93a2257b0bf2c26e358c /devel/cook/Makefile
parent1afb4ad236a3ea4e89fd55b8630f8b1f4c56d26b (diff)
downloadports-931c32fc4b80a4d07bd5c3da9c19587b9f95382e.tar.gz
ports-931c32fc4b80a4d07bd5c3da9c19587b9f95382e.zip
Support stage
Notes
Notes: svn path=/head/; revision=352687
Diffstat (limited to 'devel/cook/Makefile')
-rw-r--r--devel/cook/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/devel/cook/Makefile b/devel/cook/Makefile
index acec6addbb82..5d5447bdc4d8 100644
--- a/devel/cook/Makefile
+++ b/devel/cook/Makefile
@@ -18,20 +18,17 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
-MAN1= c_incl.1 cook.1 cook_bom.1 cook_lic.1 cook_rsh.1 cookfp.1 cooktime.1 \
- find_libs.1 make2cook.1 roffpp.1
-MANCOMPRESSED= no
-USES= gettext
+USES= gettext perl5
+DESTDIRNAME= RPM_BUILD_ROOT
# Make sure that the whole directory tree exists.
-NO_STAGE= yes
pre-install:
- ${MKDIR} ${PREFIX}/share/cook/en/man1
- ${MKDIR} ${PREFIX}/lib/cook/en/LC_MESSAGES
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/cook/en/man1
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/cook/en/LC_MESSAGES
# cook installs extra copies of the manpages in a directory that MANLANG can't
# cope with. Delete the extra copies.
post-install:
- @${RM} -rf ${PREFIX}/share/cook/en/man1
+ @${RM} -rf ${STAGEDIR}${PREFIX}/share/cook/en/man1
.include <bsd.port.mk>