aboutsummaryrefslogtreecommitdiff
path: root/devel/cook
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-11-29 23:14:27 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-11-29 23:14:27 +0000
commit040d812646234cdbc9b3417e549249889d90b413 (patch)
tree7865a7c9bca64265e7d729cc30da35b366107b38 /devel/cook
parentbec80830fda230bac621286e01d5367da4551323 (diff)
downloadports-040d812646234cdbc9b3417e549249889d90b413.tar.gz
ports-040d812646234cdbc9b3417e549249889d90b413.zip
Fix build on alpha and make sure we don't pick up (and break on) bison.
Notes
Notes: svn path=/head/; revision=71235
Diffstat (limited to 'devel/cook')
-rw-r--r--devel/cook/Makefile3
-rw-r--r--devel/cook/files/patch-common_ac_time.h14
2 files changed, 16 insertions, 1 deletions
diff --git a/devel/cook/Makefile b/devel/cook/Makefile
index 9ca46053a6bf..89636f335396 100644
--- a/devel/cook/Makefile
+++ b/devel/cook/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= ports@freebsd.org
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib \
+ YACC=yacc
MAN1= c_incl.1 cook.1 cook_bom.1 cook_lic.1 cook_rsh.1 cookfp.1 cooktime.1 \
find_libs.1 make2cook.1 roffpp.1
diff --git a/devel/cook/files/patch-common_ac_time.h b/devel/cook/files/patch-common_ac_time.h
new file mode 100644
index 000000000000..f86555c514a3
--- /dev/null
+++ b/devel/cook/files/patch-common_ac_time.h
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- common/ac/time.h.orig Fri Nov 29 23:15:13 2002
++++ common/ac/time.h Fri Nov 29 23:15:27 2002
+@@ -29,7 +29,7 @@
+ * Catch-22: Dec Alpha OSF/1: need to include time.h before sys/time.h
+ * before time.h
+ */
+-#ifdef __alpha__
++#ifdef __osf1__
+ #ifndef _CLOCK_ID_T
+ #define _CLOCK_ID_T
+ typedef int clockid_t;