aboutsummaryrefslogtreecommitdiff
path: root/devel/csoap
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-11-10 16:13:36 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-11-10 16:13:36 +0000
commit2998608b86475a0b89b26ea1d315772a3eb857d6 (patch)
tree786355b590cfd99721a02e8b013e053dab922b3d /devel/csoap
parent7181e4a4efd0a55fd2ab9def9381d30a19dbd68f (diff)
downloadports-2998608b86475a0b89b26ea1d315772a3eb857d6.tar.gz
ports-2998608b86475a0b89b26ea1d315772a3eb857d6.zip
- New port: devel/csoap
csoap is a client/server SOAP library implemented in pure C. It comes with an embedded HTTP server called nanohttp. The transfered XML structures are handled by libxml2. csoap comes with the followin features: - client/server HTTP engine - Attachments via MIME - https (SSL) with OpenSSL WWW: http://csoap.sourceforge.net/
Notes
Notes: svn path=/head/; revision=244070
Diffstat (limited to 'devel/csoap')
-rw-r--r--devel/csoap/Makefile23
-rw-r--r--devel/csoap/distinfo3
-rw-r--r--devel/csoap/pkg-descr9
-rw-r--r--devel/csoap/pkg-plist38
4 files changed, 73 insertions, 0 deletions
diff --git a/devel/csoap/Makefile b/devel/csoap/Makefile
new file mode 100644
index 000000000000..afc2f701c34e
--- /dev/null
+++ b/devel/csoap/Makefile
@@ -0,0 +1,23 @@
+# New ports collection Makefile for: csoap
+# Date created: 10 November 2009
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= csoap
+PORTVERSION= 1.1.0
+CATEGORIES= devel net www
+MASTER_SITES= SF/${PORTNAME}/libsoap/${PORTVERSION}
+DISTNAME= libsoap-${PORTVERSION}
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A client/server SOAP library written in pure C
+
+GNU_CONFIGURE= yes
+USE_GNOME= libxml2 gnomehack
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/libsoap-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/csoap/distinfo b/devel/csoap/distinfo
new file mode 100644
index 000000000000..d2eff8f1f7e6
--- /dev/null
+++ b/devel/csoap/distinfo
@@ -0,0 +1,3 @@
+MD5 (libsoap-1.1.0.tar.gz) = 725eba71ec3eb2d6d878f50cee334022
+SHA256 (libsoap-1.1.0.tar.gz) = cd62d82bbbdc1962ff425a4eb014cbc287b95681f272147234b7a7744762d344
+SIZE (libsoap-1.1.0.tar.gz) = 895727
diff --git a/devel/csoap/pkg-descr b/devel/csoap/pkg-descr
new file mode 100644
index 000000000000..aab0d715cf2f
--- /dev/null
+++ b/devel/csoap/pkg-descr
@@ -0,0 +1,9 @@
+csoap is a client/server SOAP library implemented in pure C.
+It comes with an embedded HTTP server called nanohttp.
+The transfered XML structures are handled by libxml2.
+csoap comes with the followin features:
+- client/server HTTP engine
+- Attachments via MIME
+- https (SSL) with OpenSSL
+
+WWW: http://csoap.sourceforge.net/
diff --git a/devel/csoap/pkg-plist b/devel/csoap/pkg-plist
new file mode 100644
index 000000000000..04439215ab6c
--- /dev/null
+++ b/devel/csoap/pkg-plist
@@ -0,0 +1,38 @@
+bin/soapclient
+bin/csoap-config
+lib/libcsoap.la
+lib/libcsoap.a
+lib/libcsoap-1.1.so.2
+lib/libcsoap-1.1.so
+lib/libcsoap.so
+lib/libnanohttp.la
+lib/libnanohttp.a
+lib/libnanohttp-1.1.so.2
+lib/libnanohttp-1.1.so
+lib/libnanohttp.so
+include/nanohttp-1.1/nanohttp/nanohttp-common.h
+include/nanohttp-1.1/nanohttp/nanohttp-socket.h
+include/nanohttp-1.1/nanohttp/nanohttp-client.h
+include/nanohttp-1.1/nanohttp/nanohttp-server.h
+include/nanohttp-1.1/nanohttp/nanohttp-stream.h
+include/nanohttp-1.1/nanohttp/nanohttp-mime.h
+include/nanohttp-1.1/nanohttp/nanohttp-request.h
+include/nanohttp-1.1/nanohttp/nanohttp-response.h
+include/nanohttp-1.1/nanohttp/nanohttp-base64.h
+include/nanohttp-1.1/nanohttp/nanohttp-ssl.h
+include/nanohttp-1.1/nanohttp/nanohttp-logging.h
+include/libcsoap-1.1/libcsoap/soap-xml.h
+include/libcsoap-1.1/libcsoap/soap-fault.h
+include/libcsoap-1.1/libcsoap/soap-env.h
+include/libcsoap-1.1/libcsoap/soap-service.h
+include/libcsoap-1.1/libcsoap/soap-router.h
+include/libcsoap-1.1/libcsoap/soap-client.h
+include/libcsoap-1.1/libcsoap/soap-server.h
+include/libcsoap-1.1/libcsoap/soap-ctx.h
+include/libcsoap-1.1/libcsoap/soap-admin.h
+share/aclocal/libcsoap.m4
+libdata/pkgconfig/libcsoap.pc
+@dirrm include/nanohttp-1.1/nanohttp
+@dirrm include/nanohttp-1.1
+@dirrm include/libcsoap-1.1/libcsoap
+@dirrm include/libcsoap-1.1