aboutsummaryrefslogtreecommitdiff
path: root/devel/cvs+ipv6/Makefile
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-01-22 23:14:24 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-01-22 23:14:24 +0000
commit072d6bd76c0b227ac591f517e2599bc2b334b6e2 (patch)
treec327efa8ebf801fe5ccab462af79df40f00ff200 /devel/cvs+ipv6/Makefile
parentf52558755158a0063b261fd14cc0c34cdd67cef8 (diff)
downloadports-072d6bd76c0b227ac591f517e2599bc2b334b6e2.tar.gz
ports-072d6bd76c0b227ac591f517e2599bc2b334b6e2.zip
- style fix
- use --with-tmpdir and --with-editor Submitted by: knu
Notes
Notes: svn path=/head/; revision=73828
Diffstat (limited to 'devel/cvs+ipv6/Makefile')
-rw-r--r--devel/cvs+ipv6/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/devel/cvs+ipv6/Makefile b/devel/cvs+ipv6/Makefile
index 9e5369b21f10..562c4c8ab2da 100644
--- a/devel/cvs+ipv6/Makefile
+++ b/devel/cvs+ipv6/Makefile
@@ -5,32 +5,35 @@
# $FreeBSD$
#
-PORTNAME= cvs+ipv6
+PORTNAME= cvs
PORTVERSION= 1.11.5
+PORTREVISION= 1
CATEGORIES= devel ipv6
MASTER_SITES= http://ftp.cvshome.org/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/cvs/&,}
-MASTER_SITE_SUBDIR= cvs-${PORTVERSION}
-DISTNAME= cvs-${PORTVERSION}
+MASTER_SITE_SUBDIR= ${DISTNAME}
+PKGNAMESUFFIX= +ipv6
PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/
-PATCHFILES= cvs-1.11.5-v6-20030123.diff.gz
+PATCHFILES= ${DISTNAME}-v6-20030123.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= sumikawa@FreeBSD.org
GNU_CONFIGURE= yes
#USE_GMAKE= yes
-CONFIGURE_ARGS= --enable-ipv6 --without-gssapi
+CONFIGURE_ARGS= --enable-ipv6 --without-gssapi \
+ --with-editor="vi" \
+ --with-tmpdir="/tmp"
MAN1= cvs.1
MAN5= cvs.5
MAN8= cvsbug.8
CVS_SITE?= :pserver:anoncvs@anoncvs.FreeBSD.org:/home/ncvs
-CVS_VER?= v1_11_5
+CVS_VER?= v${PORTVERSION:S/./_/g}
-USE_REINPLACE= yes
+USE_REINPLACE= yes
post-patch:
${REINPLACE_CMD} 's/${PORTVERSION:S/./\./g}/&+IPv6/g' ${WRKSRC}/configure