aboutsummaryrefslogtreecommitdiff
path: root/devel/cvs2html
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-07-02 23:36:27 +0000
committerWill Andrews <will@FreeBSD.org>2000-07-02 23:36:27 +0000
commit9069be9393b8d2501d5cfe2ccc36c10967431c37 (patch)
tree5ad809e124e6758854f5e634c146bc4ea17fe76e /devel/cvs2html
parent88478d099fed6551e395d9d5a82f0bb069b8c532 (diff)
downloadports-9069be9393b8d2501d5cfe2ccc36c10967431c37.tar.gz
ports-9069be9393b8d2501d5cfe2ccc36c10967431c37.zip
Add cvs2html, a perl script that turns cvs log output into HTML.
Notes
Notes: svn path=/head/; revision=30090
Diffstat (limited to 'devel/cvs2html')
-rw-r--r--devel/cvs2html/Makefile28
-rw-r--r--devel/cvs2html/distinfo1
-rw-r--r--devel/cvs2html/pkg-comment1
-rw-r--r--devel/cvs2html/pkg-descr6
-rw-r--r--devel/cvs2html/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/cvs2html/Makefile b/devel/cvs2html/Makefile
new file mode 100644
index 000000000000..cdf559c403d4
--- /dev/null
+++ b/devel/cvs2html/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: groach
+# Date created: Sun 02 Jul 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvs2html
+PORTVERSION= 1.65
+CATEGORIES= devel perl5
+MASTER_SITES= http://www.sslug.dk/cvs2html/utils/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX=
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/${DISTNAME} ${WRKDIR}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/cvs2html/distinfo b/devel/cvs2html/distinfo
new file mode 100644
index 000000000000..45741af2ad61
--- /dev/null
+++ b/devel/cvs2html/distinfo
@@ -0,0 +1 @@
+MD5 (cvs2html) = 16ff159fb585353bbff902bd4a829d50
diff --git a/devel/cvs2html/pkg-comment b/devel/cvs2html/pkg-comment
new file mode 100644
index 000000000000..8b3c83bbd0a5
--- /dev/null
+++ b/devel/cvs2html/pkg-comment
@@ -0,0 +1 @@
+Perl script to turn ``cvs log'' output into HTML
diff --git a/devel/cvs2html/pkg-descr b/devel/cvs2html/pkg-descr
new file mode 100644
index 000000000000..5f99d6c87df9
--- /dev/null
+++ b/devel/cvs2html/pkg-descr
@@ -0,0 +1,6 @@
+cvs2html is a perl script that turns ``cvs log''
+output into HTML for easy log persual.
+
+WWW: http://www.sslug.dk/cvs2html/
+
+- Will <andrews@technologist.com>
diff --git a/devel/cvs2html/pkg-plist b/devel/cvs2html/pkg-plist
new file mode 100644
index 000000000000..95f801851436
--- /dev/null
+++ b/devel/cvs2html/pkg-plist
@@ -0,0 +1 @@
+bin/cvs2html