aboutsummaryrefslogtreecommitdiff
path: root/devel/cvs
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-09-12 00:11:54 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-09-12 00:11:54 +0000
commit448d7b6874c474116799b4ddcda59b6e0aac1f01 (patch)
treef94eb923b9a4a8bb31ce9897b042cdefb1b3e759 /devel/cvs
parenta5cbb74d50ead9b6987ea4b0f5b8741a8a17dc8f (diff)
downloadports-448d7b6874c474116799b4ddcda59b6e0aac1f01.tar.gz
ports-448d7b6874c474116799b4ddcda59b6e0aac1f01.zip
devel/cvs: enslave devel/cvs+ipv6 to avoid bitrot
- devel/cvs: allow slave ports (?= vars) - devel/cvs: define CONFLICTS against the slave and -devel - devel/cvs: adjust for easier patching source (i.e. no ../cvs/ prefix) - devel/cvs+ipv6: move most logic as IPV6 option to devel/cvs - devel/cvs+ipv6: don't define HAVE_GETGROUPS twice or unused ENABLE_IPV6 - devel/cvs+ipv6: drop devel/cvsnt from CONFLICTS after 4.6 years being gone - devel/cvs+ipv6: bump PORTREVISION for changes inherited from devel/cvs - Convert CONFLICTS into CONFLICTS_INSTALL PR: 199542 Reviewed by: bapt Approved by: maintainer timeout (5 months) Differential Revision: https://reviews.freebsd.org/D3636
Notes
Notes: svn path=/head/; revision=396729
Diffstat (limited to 'devel/cvs')
-rw-r--r--devel/cvs/Makefile17
-rw-r--r--devel/cvs/distinfo2
-rw-r--r--devel/cvs/files/patch-cvs.info.texinfo-5.x4
-rw-r--r--devel/cvs/files/patch-cvs__Makefile4
4 files changed, 19 insertions, 8 deletions
diff --git a/devel/cvs/Makefile b/devel/cvs/Makefile
index cbb741cc304c..c88f37b2230b 100644
--- a/devel/cvs/Makefile
+++ b/devel/cvs/Makefile
@@ -2,18 +2,26 @@
PORTNAME= cvs
PORTVERSION= 1.20120905
-PORTREVISION= 4
+PORTREVISION?= 4
CATEGORIES= devel
MASTER_SITES= LOCAL/eadler
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Version control system
+MAINTAINER?= ports@FreeBSD.org
+COMMENT?= Version control system
LICENSE= GPLv2 # or any later version
-OPTIONS_DEFINE= KERBEROS EXAMPLES
+CONFLICTS_INSTALL?= cvs+ipv6-[12]* cvs-devel-[12]*
+
+OPTIONS_DEFINE= IPV6 KERBEROS EXAMPLES
OPTIONS_DEFAULT=KERBEROS
+.if !make(makesum)
+OPTIONS_EXCLUDE?=IPV6
+.endif
+IPV6_CATEGORIES= ipv6
+IPV6_PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/
+IPV6_PATCHFILES= ${DISTNAME}-v6-20140105.diff.gz:-p1
KERBEROS_MAKE_ARGS= KERBEROS_SUPPORT=yes
USES= makeinfo shebangfix tar:xz uidfix
@@ -22,6 +30,7 @@ SHEBANG_FILES= contrib/clmerge contrib/cln_hist \
contrib/easy-import contrib/log \
contrib/log_accum contrib/mfpipe \
contrib/rcslock
+PATCH_WRKSRC= ${WRKDIR}/call/cvs
WRKSRC= ${WRKDIR}/call/cvs-build
INFO= cvs cvsclient
diff --git a/devel/cvs/distinfo b/devel/cvs/distinfo
index 9da3b3d2353b..f461692216d4 100644
--- a/devel/cvs/distinfo
+++ b/devel/cvs/distinfo
@@ -1,2 +1,4 @@
SHA256 (cvs-1.20120905.tar.xz) = 39f23fa6e574a060425737c893423af8f0682d694a7875a472fc0c06215e21bb
SIZE (cvs-1.20120905.tar.xz) = 1413320
+SHA256 (cvs-1.20120905-v6-20140105.diff.gz) = 6fdb4a0342275bb5668877b7f08f557b6505d7dee390a41a108f491b9b93f84e
+SIZE (cvs-1.20120905-v6-20140105.diff.gz) = 6333
diff --git a/devel/cvs/files/patch-cvs.info.texinfo-5.x b/devel/cvs/files/patch-cvs.info.texinfo-5.x
index 5ce5044b92c6..ad920c450275 100644
--- a/devel/cvs/files/patch-cvs.info.texinfo-5.x
+++ b/devel/cvs/files/patch-cvs.info.texinfo-5.x
@@ -6,8 +6,8 @@ Subject: Make cvs.texinfo compatible with newer makeinfo (Closes: #711298)
diff --git a/doc/cvs.texinfo b/doc/cvs.texinfo
index a0136a5..d11a5e1 100644
---- ../cvs/doc/cvs.texinfo
-+++ ../cvs/doc/cvs.texinfo
+--- doc/cvs.texinfo
++++ doc/cvs.texinfo
@@ -113,9 +113,9 @@ approved by the Free Software Foundation.
@sp 4
@comment The title is printed in a large font.
diff --git a/devel/cvs/files/patch-cvs__Makefile b/devel/cvs/files/patch-cvs__Makefile
index 490b16745d09..d2b0c67fbfe3 100644
--- a/devel/cvs/files/patch-cvs__Makefile
+++ b/devel/cvs/files/patch-cvs__Makefile
@@ -1,5 +1,5 @@
---- cvs/Makefile.orig 2012-09-06 06:25:43.000000000 +0400
-+++ cvs/Makefile 2014-07-15 12:37:28.000000000 +0400
+--- ../cvs-build/cvs/Makefile.orig 2012-09-06 06:25:43.000000000 +0400
++++ ../cvs-build/cvs/Makefile 2014-07-15 12:37:28.000000000 +0400
@@ -32,7 +32,7 @@
DPADD= ${LIBCVS} ${LIBDIFF} ${LIBGNUREGEX} ${LIBMD} ${LIBCRYPT} ${LIBZ}
LDADD= ${LIBCVS} ${LIBDIFF} -lgnuregex -lmd -lcrypt -lz