aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsd
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-31 05:33:17 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-31 05:33:17 +0000
commitcc33eebf1b5cc176cfdcc1af58def6a11c9052c3 (patch)
tree11c2f528533c5c55799f0f4c6dd240e22dd52738 /devel/cvsd
parent56b7fb1d70f02abd934dd9c01960dfd6626abe68 (diff)
downloadports-cc33eebf1b5cc176cfdcc1af58def6a11c9052c3.tar.gz
ports-cc33eebf1b5cc176cfdcc1af58def6a11c9052c3.zip
add cvsd 0.9.3
cvs pserver daemon
Notes
Notes: svn path=/head/; revision=52438
Diffstat (limited to 'devel/cvsd')
-rw-r--r--devel/cvsd/Makefile38
-rw-r--r--devel/cvsd/distinfo1
-rw-r--r--devel/cvsd/pkg-comment1
-rw-r--r--devel/cvsd/pkg-descr20
-rw-r--r--devel/cvsd/pkg-message2
-rw-r--r--devel/cvsd/pkg-plist8
6 files changed, 70 insertions, 0 deletions
diff --git a/devel/cvsd/Makefile b/devel/cvsd/Makefile
new file mode 100644
index 000000000000..b173a1f84ee6
--- /dev/null
+++ b/devel/cvsd/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: cvsd
+# Date Created: Dec 31, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvsd
+PORTVERSION= 0.9.3
+CATEGORIES= devel
+MASTER_SITES= http://tiefighter.et.tudelft.nl/~arthur/cvsd/
+
+MAINTAINER= porst@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt"
+
+MAN5= cvsd.conf.5
+MAN8= cvsd.8 cvsd-buildroot.8 cvsd-passwd.8
+
+post-patch:
+ @${PERL} -pi -e "s|init.d|rc.d|g" ${WRKSRC}/Makefile.in
+
+post-install:
+ @${MV} ${PREFIX}/etc/rc.d/cvsd ${PREFIX}/etc/rc.d/cvsd.sh
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/devel/cvsd/distinfo b/devel/cvsd/distinfo
new file mode 100644
index 000000000000..3c73b379270a
--- /dev/null
+++ b/devel/cvsd/distinfo
@@ -0,0 +1 @@
+MD5 (cvsd-0.9.3.tar.gz) = 67fd0369c3c5a9a42c19c669fb3d97cf
diff --git a/devel/cvsd/pkg-comment b/devel/cvsd/pkg-comment
new file mode 100644
index 000000000000..204cf1d9b3f6
--- /dev/null
+++ b/devel/cvsd/pkg-comment
@@ -0,0 +1 @@
+cvs pserver daemon
diff --git a/devel/cvsd/pkg-descr b/devel/cvsd/pkg-descr
new file mode 100644
index 000000000000..7c7638f076a6
--- /dev/null
+++ b/devel/cvsd/pkg-descr
@@ -0,0 +1,20 @@
+cvsd is a wrapper program for cvs in pserver mode. It will run 'cvs pserver'
+under a special uid/gid in a chroot jail.
+
+cvsd is run as a daemon and is controlled through a configuration file. It
+is relatively easy to configure and tools are provided for easily setting up
+a rootjail.
+
+This server can be useful if you want to run a public cvs pserver. You should
+however be aware of the security limitations of running a cvs pserver. If you
+want any kind of authentication you should really consider using secure shell
+as a secure authentication mechanism and transport. Passwords used in cvs
+pserver are transmitted in plaintext and this wrapper won't change that.
+
+This server adds a layer of security to cvs. cvs is a very powerful tool and
+is capable of running scripts and other things. By running cvs in a rootjail
+it is possible to limit the amount of "damage" cvs can do if it is exploited.
+It is generally a good idea to run cvsd without any write permissions to any
+directory on the system.
+
+WWW: http://tiefighter.et.tudelft.nl/~arthur/cvsd/
diff --git a/devel/cvsd/pkg-message b/devel/cvsd/pkg-message
new file mode 100644
index 000000000000..9c8331b382cd
--- /dev/null
+++ b/devel/cvsd/pkg-message
@@ -0,0 +1,2 @@
+You should set up user and group ids for cvsd, create a chrooted filesystem
+and create repositories.
diff --git a/devel/cvsd/pkg-plist b/devel/cvsd/pkg-plist
new file mode 100644
index 000000000000..6f1e984df612
--- /dev/null
+++ b/devel/cvsd/pkg-plist
@@ -0,0 +1,8 @@
+sbin/cvsd
+sbin/cvsd-buildroot
+sbin/cvsd-passwd
+etc/cvsd/cvsd.conf
+etc/rc.d/cvsd.sh
+@dirrm etc/cvsd
+%%PORTDOCS%%share/doc/cvsd/README
+%%PORTDOCS%%@dirrm share/doc/cvsd