aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsd
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2002-09-21 17:58:40 +0000
committerPeter Pentchev <roam@FreeBSD.org>2002-09-21 17:58:40 +0000
commita84636f067b6d9a42d10e493a9e800777909f728 (patch)
treef352b85bb90045c86dd7c789e702b439eae3f3fe /devel/cvsd
parent4fa9bd98d6815036ce448e5e1efce44437e60199 (diff)
downloadports-a84636f067b6d9a42d10e493a9e800777909f728.tar.gz
ports-a84636f067b6d9a42d10e493a9e800777909f728.zip
Fix the problems in my last commit to make cvsd actually build:
- actually add files/patch-cvsd.c, which *was* in the PR; - add files/patch-configure, which was mentioned but missing from the PR; - remove autoconf/make/etc invocation from the Makefile so our changes to the configure script are not lost. Pointed out by: kris, Ports Fury Pointy hat to: roam (myself)
Notes
Notes: svn path=/head/; revision=67014
Diffstat (limited to 'devel/cvsd')
-rw-r--r--devel/cvsd/Makefile6
-rw-r--r--devel/cvsd/files/patch-configure18
-rw-r--r--devel/cvsd/files/patch-cvsd.c16
3 files changed, 38 insertions, 2 deletions
diff --git a/devel/cvsd/Makefile b/devel/cvsd/Makefile
index 754b0ba85902..5a0ba77e3e52 100644
--- a/devel/cvsd/Makefile
+++ b/devel/cvsd/Makefile
@@ -25,8 +25,10 @@ MAN5= cvsd.conf.5
MAN8= cvsd.8 cvsd-buildroot.8 cvsd-passwd.8
post-patch:
- @${REINPLACE_CMD} -e 's|init.d/cvsd|rc.d/cvsd.sh.sample|g ; \
- s|init.d|rc.d|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -E -e 's|init.d/cvsd|rc.d/cvsd.sh.sample|g ; \
+ s|init.d|rc.d|g ; \
+ s,@(ACLOCAL|AUTO(CONF|MAKE|HEADER))@,/usr/bin/true,' \
+ ${WRKSRC}/Makefile.in
post-install:
.if !defined(NOPORTDOCS)
diff --git a/devel/cvsd/files/patch-configure b/devel/cvsd/files/patch-configure
new file mode 100644
index 000000000000..850b5815ba6f
--- /dev/null
+++ b/devel/cvsd/files/patch-configure
@@ -0,0 +1,18 @@
+--- configure Sat Sep 14 18:11:40 2002
++++ configure Sat Sep 21 20:39:57 2002
+@@ -5498,6 +5498,7 @@
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ #include "confdefs.h"
++#include <sys/types.h>
+ #include <sys/socket.h>
+
+ #ifdef F77_DUMMY_MAIN
+@@ -5557,6 +5558,7 @@
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ #include "confdefs.h"
++#include <sys/types.h>
+ #include <sys/socket.h>
+
+ #ifdef F77_DUMMY_MAIN
diff --git a/devel/cvsd/files/patch-cvsd.c b/devel/cvsd/files/patch-cvsd.c
new file mode 100644
index 000000000000..2482d54b030e
--- /dev/null
+++ b/devel/cvsd/files/patch-cvsd.c
@@ -0,0 +1,16 @@
+diff -urN /usr/ports/devel/cvsd/files/patch-cvsd.c devel/cvsd/files/patch-cvsd.c
+--- /usr/ports/devel/cvsd/files/patch-cvsd.c Thu Jan 1 09:00:00 1970
++++ devel/cvsd/files/patch-cvsd.c Tue Sep 17 19:26:39 2002
+@@ -0,0 +1,12 @@
++--- cvsd.c.orig Sun Aug 25 09:44:33 2002
+++++ cvsd.c Tue Sep 17 19:26:31 2002
++@@ -60,7 +60,9 @@
++ #include <sys/wait.h>
++ #include <sys/socket.h>
++ #include <sys/time.h>
+++#ifndef __FreeBSD__
++ #include <netinet/in.h>
+++#endif
++ #include <arpa/inet.h>
++ #ifdef HAVE_NETDB_H
++ #include <netdb.h>