aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsgraph/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2001-03-15 11:29:21 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2001-03-15 11:29:21 +0000
commitac9b7fbf76f0919830005f25387fee08e329f031 (patch)
tree11884ec9cafca2b27aa02e6a5be21afee9199cbc /devel/cvsgraph/Makefile
parenta753ad4bf9636aeded79afb0541cdf8188e1ab67 (diff)
downloadports-ac9b7fbf76f0919830005f25387fee08e329f031.tar.gz
ports-ac9b7fbf76f0919830005f25387fee08e329f031.zip
Update to 1.1.1. Quash an unnecessary "#include <getopt.h>" that
was breaking bento builds. Submitted by: Michael Lyngbol <michael@lyngbol.dk> PR: 25808 Mention patch to cvsweb.
Notes
Notes: svn path=/head/; revision=39879
Diffstat (limited to 'devel/cvsgraph/Makefile')
-rw-r--r--devel/cvsgraph/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/devel/cvsgraph/Makefile b/devel/cvsgraph/Makefile
index 84c5cb347a6e..17687b0194a1 100644
--- a/devel/cvsgraph/Makefile
+++ b/devel/cvsgraph/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= cvsgraph
-PORTVERSION= 1.0.1
+PORTVERSION= 1.1.1
CATEGORIES= devel graphics
-MASTER_SITES= http://www.akhphd.au.dk/~bertho/cvsgraph/
+MASTER_SITES= http://www.akhphd.au.dk/~bertho/cvsgraph/release/
MAINTAINER= trevor@FreeBSD.org
@@ -17,15 +17,22 @@ LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN1= cvsgraph.1
+MAN5= cvsgraph.conf.5
+
ALL_TARGET= cvsgraph
DOCDIR= share/doc/${PORTNAME}
DOCS= ChangeLog LICENCE README
PLIST= ${WRKDIR}/pkg-plist
USE_AUTOCONF= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gd=${LOCALBASE} \
+CONFIGURE_ARGS= --with-gd-inc=${LOCALBASE}/include/gd \
+ --with-gd-lib=${LOCALBASE}/lib \
--with-png=${LOCALBASE} \
- --with-z=/usr
+ --with-z-inc=/usr/include \
+ --with-z-lib=/usr/lib
post-configure:
${PERL} -pi -e \
@@ -46,6 +53,8 @@ pre-install:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/cvsgraph.conf ${PREFIX}/etc
+ ${INSTALL_MAN} ${WRKSRC}/cvsgraph.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/cvsgraph.conf.5 ${PREFIX}/man/man5
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/${DOCDIR}
.for i in ${DOCS}