aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsgraph/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-02-12 03:53:21 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-02-12 03:53:21 +0000
commitd2e7754c7725f0af1669b45e009a34bfdafb45d8 (patch)
tree12a5f5ff8e619b757f99a61ceeff56c9d6bcf8b1 /devel/cvsgraph/Makefile
parentf93c194072925f63ec944889d490ec3a176daa09 (diff)
downloadports-d2e7754c7725f0af1669b45e009a34bfdafb45d8.tar.gz
ports-d2e7754c7725f0af1669b45e009a34bfdafb45d8.zip
Update to 1.6.0.
- Suffix default configuration file with .sample - Give maintainership to submitter PR: ports/93221 Submitted by: Serge Gagnon <serge.gagnon@b2b2c.ca>
Notes
Notes: svn path=/head/; revision=155814
Diffstat (limited to 'devel/cvsgraph/Makefile')
-rw-r--r--devel/cvsgraph/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/devel/cvsgraph/Makefile b/devel/cvsgraph/Makefile
index 4d4ea319d2cd..fb50b8064d91 100644
--- a/devel/cvsgraph/Makefile
+++ b/devel/cvsgraph/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= cvsgraph
-PORTVERSION= 1.5.2
-PORTREVISION= 0
+PORTVERSION= 1.6.0
CATEGORIES= devel graphics
MASTER_SITES= http://www.akhphd.au.dk/~bertho/cvsgraph/release/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= serge.gagnon@b2b2c.ca
COMMENT= Graph the life story of a file under CVS or RCS
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
@@ -27,18 +26,18 @@ EXAMPLES= cvsgraphwrapper.php3 mkimage.php3
MORE_EXAMPLES= README.Automatic_documentation checkoutlist commit_action.sh \
commitinfo cvswrappers tag_action.sh taginfo
PLIST= ${WRKDIR}/pkg-plist
+SUB_FILES= pkg-message
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gd-inc=${LOCALBASE}/include \
--with-gd-lib=${LOCALBASE}/lib
+REINPLACE_ARGS= -i ""
pre-patch:
- ${MV} ${WRKSRC}/cvsgraph.conf ${WRKSRC}/cvsgraph.conf.orig
- ${SED} -e "s:/home/bertho/tmp/cvstest:/home/ncvs:g" \
- < ${WRKSRC}/cvsgraph.conf.orig > ${WRKSRC}/cvsgraph.conf
+ @${REINPLACE_CMD} -e "s:/home/bertho/tmp/cvstest:/home/ncvs:g" ${WRKSRC}/cvsgraph.conf
pre-install:
${ECHO_CMD} bin/cvsgraph > ${PLIST}
- ${ECHO_CMD} etc/cvsgraph.conf >> ${PLIST}
+ ${ECHO_CMD} etc/cvsgraph.conf.sample >> ${PLIST}
.if !defined(NOPORTDOCS)
.for i in ${DOCS}
${ECHO_CMD} ${DOCDIR}/${i} >> ${PLIST}
@@ -56,7 +55,7 @@ pre-install:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/cvsgraph.conf ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/cvsgraph.conf ${PREFIX}/etc/cvsgraph.conf.sample
${INSTALL_MAN} ${WRKSRC}/cvsgraph.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/cvsgraph.conf.5 ${PREFIX}/man/man5
.if !defined(NOPORTDOCS)
@@ -74,4 +73,8 @@ do-install:
.endfor
.endif
+post-install:
+ @${ECHO_CMD} " "
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>