aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsgraph
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2001-03-27 10:40:39 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2001-03-27 10:40:39 +0000
commit9db07173bc2135c90cdef8e5419d07c41e2e5b1e (patch)
tree063112d14c1452b6df44c78b0158531ed21aada6 /devel/cvsgraph
parent9f0183ed5afc8071a4ec34cbe4b0f9cc7416edcd (diff)
downloadports-9db07173bc2135c90cdef8e5419d07c41e2e5b1e.tar.gz
ports-9db07173bc2135c90cdef8e5419d07c41e2e5b1e.zip
Update to 1.1.2.
Notes
Notes: svn path=/head/; revision=40431
Diffstat (limited to 'devel/cvsgraph')
-rw-r--r--devel/cvsgraph/Makefile24
-rw-r--r--devel/cvsgraph/distinfo2
-rw-r--r--devel/cvsgraph/files/patch-configure.in17
3 files changed, 24 insertions, 19 deletions
diff --git a/devel/cvsgraph/Makefile b/devel/cvsgraph/Makefile
index 17687b0194a1..ef6778e2315d 100644
--- a/devel/cvsgraph/Makefile
+++ b/devel/cvsgraph/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cvsgraph
-PORTVERSION= 1.1.1
+PORTVERSION= 1.1.2
CATEGORIES= devel graphics
MASTER_SITES= http://www.akhphd.au.dk/~bertho/cvsgraph/release/
@@ -17,7 +17,7 @@ LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= cvsgraph.1
MAN5= cvsgraph.conf.5
@@ -25,14 +25,22 @@ MAN5= cvsgraph.conf.5
ALL_TARGET= cvsgraph
DOCDIR= share/doc/${PORTNAME}
DOCS= ChangeLog LICENCE README
+EXAMPLES= cvsgraphwrapper.php3 mkimage.php3
PLIST= ${WRKDIR}/pkg-plist
USE_AUTOCONF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gd-inc=${LOCALBASE}/include/gd \
--with-gd-lib=${LOCALBASE}/lib \
- --with-png=${LOCALBASE} \
+ --with-jpeg-inc=${LOCALBASE}/include \
+ --with-jpeg-lib=${LOCALBASE}/lib \
+ --with-png-inc=${LOCALBASE}/include \
+ --with-png-lib=${LOCALBASE}/lib \
--with-z-inc=/usr/include \
- --with-z-lib=/usr/lib
+ --with-z-lib=/usr/lib \
+ --with-gd \
+ --with-jpeg \
+ --with-png \
+ --with-z
post-configure:
${PERL} -pi -e \
@@ -47,6 +55,10 @@ pre-install:
.for i in ${DOCS}
${ECHO} ${DOCDIR}/${i} >> ${PLIST}
.endfor
+.for i in ${EXAMPLES}
+ ${ECHO} ${PREFIX}/share/examples/${PORTNAME}/${i} >> ${PLIST}
+.endfor
+ ${ECHO} @dirrm share/examples/${PORTNAME} >> ${PLIST}
${ECHO} @dirrm ${DOCDIR} >> ${PLIST}
.endif
@@ -57,9 +69,13 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/cvsgraph.conf.5 ${PREFIX}/man/man5
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/${DOCDIR}
+ ${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
.for i in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/${DOCDIR}
.endfor
+.for i in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/examples/${PORTNAME}
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/devel/cvsgraph/distinfo b/devel/cvsgraph/distinfo
index 6455d19e3fb7..5c731a156eea 100644
--- a/devel/cvsgraph/distinfo
+++ b/devel/cvsgraph/distinfo
@@ -1 +1 @@
-MD5 (cvsgraph-1.1.1.tar.gz) = 616ca7209f3aebdb93ff3cac0b36574b
+MD5 (cvsgraph-1.1.2.tar.gz) = 16cd4834aee1c635835b02d2d238e240
diff --git a/devel/cvsgraph/files/patch-configure.in b/devel/cvsgraph/files/patch-configure.in
index 9a74fff55bb8..82097de1ccdc 100644
--- a/devel/cvsgraph/files/patch-configure.in
+++ b/devel/cvsgraph/files/patch-configure.in
@@ -1,17 +1,6 @@
---- configure.in.orig Sun Mar 4 10:24:10 2001
-+++ configure.in Thu Mar 15 03:19:00 2001
-@@ -30,8 +30,8 @@
- ])
-
- AC_ARG_WITH(png,[ --with-png=DIR location of png lib/inc],
-- [LDFLAGS="${LDFLAGS} -L${withval} -lpng"
-- CFLAGS="${CFLAGS} -I${withval}"
-+ [LDFLAGS="${LDFLAGS} -L${withval}/lib -lpng"
-+ CFLAGS="${CFLAGS} -I${withval}/include"
- ])
-
- AC_ARG_ENABLE(speed,[ --disable-speed Turn off lex table optimization reducing speed and size of executable],
-@@ -90,7 +90,7 @@
+--- configure.in.orig Mon Mar 12 11:50:22 2001
++++ configure.in Tue Mar 27 02:00:54 2001
+@@ -102,7 +102,7 @@
dnl Make sure the header is here
AC_CHECK_HEADER( gd.h,[ have_gd_h="yes" ],[ have_gd_h="no" ])