aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsps-devel
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-12-14 07:25:54 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-12-14 07:25:54 +0000
commit93c106475472632f74ff4aae4d9e19574844a76f (patch)
treeaf88db808c488e3baaaeef3e255e38ff53b5a8f7 /devel/cvsps-devel
parenteaa5cbadd007bd7f97652bc4f5bd35a685bad0c2 (diff)
downloadports-93c106475472632f74ff4aae4d9e19574844a76f.tar.gz
ports-93c106475472632f74ff4aae4d9e19574844a76f.zip
- Upgrade to 2.2b1
- Bring the Makefile in sync with the stable devel/cvsps port. - Fix CONFLICTS= PR: ports/129624 Submitted by: Yarema <yds@CoolRat.org>
Notes
Notes: svn path=/head/; revision=224205
Diffstat (limited to 'devel/cvsps-devel')
-rw-r--r--devel/cvsps-devel/Makefile18
-rw-r--r--devel/cvsps-devel/distinfo6
-rw-r--r--devel/cvsps-devel/files/patch-cvsps.c13
3 files changed, 23 insertions, 14 deletions
diff --git a/devel/cvsps-devel/Makefile b/devel/cvsps-devel/Makefile
index 2e41c64aedd5..5c69f8fd3253 100644
--- a/devel/cvsps-devel/Makefile
+++ b/devel/cvsps-devel/Makefile
@@ -7,23 +7,33 @@
#
PORTNAME= cvsps
-DISTVERSION= 2.1
+DISTVERSION= 2.2b1
CATEGORIES= devel
MASTER_SITES= http://www.cobite.com/cvsps/
PKGNAMESUFFIX?= -devel
MAINTAINER= ports@FreeBSD.org
-COMMENT= CVS patchsets
-
-CONFLICTS= cvsps-1.*
+COMMENT= Create patchset information from CVS
USE_GMAKE= yes
+ALL_TARGET= cvsps
+
+CONFLICTS= cvsps-[12].[01]*
MAN1= cvsps.1
PLIST_FILES= bin/cvsps
+.if !defined(NOPORTDOCS)
+PORTDOCS= README
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cvsps ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/cvsps.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/cvsps-devel/distinfo b/devel/cvsps-devel/distinfo
index 55e227fd5fff..57335a46ac31 100644
--- a/devel/cvsps-devel/distinfo
+++ b/devel/cvsps-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (cvsps-2.1.tar.gz) = bde2110ed9f5d14de8f8cb04e9d596fe
-SHA256 (cvsps-2.1.tar.gz) = 91d3198b33463861a581686d5fcf99a5c484e7c4d819384c04fda9cafec1075a
-SIZE (cvsps-2.1.tar.gz) = 61634
+MD5 (cvsps-2.2b1.tar.gz) = 997580e8e283034995b9209076858c68
+SHA256 (cvsps-2.2b1.tar.gz) = 6906acb3636cdb4a4a9d608111aec22a85530037cb08a62ed5eb74ca0b218f81
+SIZE (cvsps-2.2b1.tar.gz) = 62763
diff --git a/devel/cvsps-devel/files/patch-cvsps.c b/devel/cvsps-devel/files/patch-cvsps.c
index 47b5bd155052..5df40690dd37 100644
--- a/devel/cvsps-devel/files/patch-cvsps.c
+++ b/devel/cvsps-devel/files/patch-cvsps.c
@@ -1,13 +1,12 @@
---- cvsps.c.orig Sun Jul 31 13:23:28 2005
-+++ cvsps.c Sun Jul 31 13:23:36 2005
-@@ -2550,9 +2550,9 @@
-
+--- cvsps.c.orig 2008-04-01 21:18:44.000000000 -0400
++++ cvsps.c 2008-04-01 21:18:44.000000000 -0400
+@@ -2575,8 +2575,8 @@
for (next = ps->members.next; next != &ps->members; next = next->next)
{
-+ int d1, d2;
PatchSetMember * psm = list_entry(next, PatchSetMember, link);
- rev = psm->pre_rev;
-- int d1, d2;
+- rev = psm->pre_rev;
+ int d1, d2;
++ rev = psm->pre_rev;
/* the reason this is at all complicated has to do with a
* branch off of a branch. it is possible (and indeed