aboutsummaryrefslogtreecommitdiff
path: root/devel/cvstrac
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2003-06-03 05:01:12 +0000
committerWill Andrews <will@FreeBSD.org>2003-06-03 05:01:12 +0000
commiteb5d10f4aa2fc802ccc19b5c2b36a589b70ba16e (patch)
tree5aed1d02b2120e4c14e4aa0a9e056be2cf52a6bc /devel/cvstrac
parent8ffb4a9411f75e7646f2ab2db14ddf4a06fca1af (diff)
downloadports-eb5d10f4aa2fc802ccc19b5c2b36a589b70ba16e.tar.gz
ports-eb5d10f4aa2fc802ccc19b5c2b36a589b70ba16e.zip
Add cvstrac 1.1.2, a Web-Based Bug And Patch-Set Tracking
System For CVS. PR: 51975 Submitted by: Bruce M Simpson <bms@spc.org>
Notes
Notes: svn path=/head/; revision=82161
Diffstat (limited to 'devel/cvstrac')
-rw-r--r--devel/cvstrac/Makefile27
-rw-r--r--devel/cvstrac/distinfo1
-rw-r--r--devel/cvstrac/files/patch-Makefile37
-rw-r--r--devel/cvstrac/pkg-descr11
-rw-r--r--devel/cvstrac/pkg-message4
-rw-r--r--devel/cvstrac/pkg-plist1
6 files changed, 81 insertions, 0 deletions
diff --git a/devel/cvstrac/Makefile b/devel/cvstrac/Makefile
new file mode 100644
index 000000000000..8ecca7612cc0
--- /dev/null
+++ b/devel/cvstrac/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cvstrac
+# Date created: 29 August 2002
+# Whom: Bruce M Simpson <bms@spc.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvstrac
+PORTVERSION= 1.1.2
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.cvstrac.org/cvstrac/
+
+MAINTAINER= bms@spc.org
+COMMENT= Web-Based Bug And Patch-Set Tracking System For CVS
+
+LIB_DEPENDS= sqlite.2:${PORTSDIR}/databases/sqlite
+
+USE_GMAKE= yes
+
+MAKE_ARGS= SRCDIR=${WRKSRC} PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
+
+NOMAN=
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cvstrac ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/cvstrac/distinfo b/devel/cvstrac/distinfo
new file mode 100644
index 000000000000..b3658f43889b
--- /dev/null
+++ b/devel/cvstrac/distinfo
@@ -0,0 +1 @@
+MD5 (cvstrac-1.1.2.tar.gz) = d772b3b68ee74d4c1f9899112a64f121
diff --git a/devel/cvstrac/files/patch-Makefile b/devel/cvstrac/files/patch-Makefile
new file mode 100644
index 000000000000..1defb9884fc9
--- /dev/null
+++ b/devel/cvstrac/files/patch-Makefile
@@ -0,0 +1,37 @@
+--- Makefile.orig Thu May 8 10:58:17 2003
++++ Makefile Thu May 8 10:58:32 2003
+@@ -0,0 +1,34 @@
++#!/usr/bin/make
++#
++#### The toplevel directory of the source tree.
++#
++#SRCDIR = /home/drh/cvstrac/cvstrac
++
++#### C Compiler and options for use in building executables that
++# will run on the platform that is doing the build.
++#
++BCC = gcc -g -O2 -I$(LOCALBASE)/include
++
++#### The suffix to add to executable files. ".exe" for windows.
++# Nothing for unix.
++#
++E =
++
++#### C Compile and options for use in building executables that
++# will run on the target platform. This is usually the same
++# as BCC, unless you are cross-compiling.
++#
++TCC = gcc -g -O0 -Wall -I$(LOCALBASE)/include
++
++#### Extra arguments for linking against SQLite
++#
++LIBSQLITE = -L$(LOCALBASE)/lib -lsqlite -lcrypt
++
++#### Installation directory
++#
++INSTALLDIR = $(PREFIX)/bin
++
++
++# You should not need to change anything below this line
++###############################################################################
++include $(SRCDIR)/main.mk
diff --git a/devel/cvstrac/pkg-descr b/devel/cvstrac/pkg-descr
new file mode 100644
index 000000000000..7fcf84c5c23d
--- /dev/null
+++ b/devel/cvstrac/pkg-descr
@@ -0,0 +1,11 @@
+CVSTrac is a bug and patch-set tracking system for use with CVS
+appropriate for use on projects with up to a few hundred developers.
+CVSTrac is designed for low-ceremony development - it provides
+mechanisms for tracking changes and bugs without unnecessary
+restrictions. It has a built-in Wiki and ticketing system. Both
+of these functions can be linked to the CVS tree.
+
+WWW: http://www.cvstrac.org/
+
+Bruce
+bms@spc.org
diff --git a/devel/cvstrac/pkg-message b/devel/cvstrac/pkg-message
new file mode 100644
index 000000000000..6b4c0830d027
--- /dev/null
+++ b/devel/cvstrac/pkg-message
@@ -0,0 +1,4 @@
+This port will install the cvstrac binary in ${PREFIX}/bin. Please follow
+the detailed installation instructions in the CVSTrac Wiki at
+http://cvs.cvstrac.org/wiki?p=CvstracInstallation for information on how
+to get CVSTrac up and running in your preferred configuration.
diff --git a/devel/cvstrac/pkg-plist b/devel/cvstrac/pkg-plist
new file mode 100644
index 000000000000..e189c047f183
--- /dev/null
+++ b/devel/cvstrac/pkg-plist
@@ -0,0 +1 @@
+bin/cvstrac