aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsweb3/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-05-19 21:00:43 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-05-19 21:00:43 +0000
commite26611706c39725cf85fbf8fc4b049990ea022a5 (patch)
treeb394aa5db5577d0df81d2956edd484f6fd80f672 /devel/cvsweb3/Makefile
parent097994f4881fef00b5e21fc5a51be508323e4fe7 (diff)
downloadports-e26611706c39725cf85fbf8fc4b049990ea022a5.tar.gz
ports-e26611706c39725cf85fbf8fc4b049990ea022a5.zip
Don't bother Perl with $@%'s in CVSROOT, TITLE, etc..
PR: ports/27234 Submitted by: Gordon Burditt <gordon@hammy.lonestar.org>
Notes
Notes: svn path=/head/; revision=42763
Diffstat (limited to 'devel/cvsweb3/Makefile')
-rw-r--r--devel/cvsweb3/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/devel/cvsweb3/Makefile b/devel/cvsweb3/Makefile
index 81fe4d937128..e9097038d7d2 100644
--- a/devel/cvsweb3/Makefile
+++ b/devel/cvsweb3/Makefile
@@ -52,13 +52,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
post-patch:
${PERL} -i -pe "\
- s;!!PERL!!;${PERL};g; \
- s;!!PREFIX!!;${PREFIX};g;" \
+ s'!!PERL!!'${PERL}'g; \
+ s'!!PREFIX!!'${PREFIX}'g;" \
${WRKSRC}/cvsweb.cgi
${PERL} -i -pe "\
- s;!!PREFIX!!;${PREFIX};g; \
- s;!!CVSROOT!!;${CVSROOT};g; \
- s;!!TITLE!!;${TITLE};g;" \
+ s'!!PREFIX!!'${PREFIX}'g; \
+ s'!!CVSROOT!!'${CVSROOT}'g; \
+ s'!!TITLE!!'${TITLE}'g;" \
${WRKSRC}/cvsweb.conf
do-install: