aboutsummaryrefslogtreecommitdiff
path: root/devel/cxref
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-10-12 10:25:34 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-10-12 10:25:34 +0000
commitfae0138c3ff9baccdb377b4328c908639bcf7c85 (patch)
treec592c2b8e89d6fada935ed47e97b0777dee79078 /devel/cxref
parentc81454ba82d8ee7da8d60171954745ae1d7b525a (diff)
downloadports-fae0138c3ff9baccdb377b4328c908639bcf7c85.tar.gz
ports-fae0138c3ff9baccdb377b4328c908639bcf7c85.zip
Update to version 1.6
PR: ports/72316 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=118916
Diffstat (limited to 'devel/cxref')
-rw-r--r--devel/cxref/Makefile9
-rw-r--r--devel/cxref/distinfo4
-rw-r--r--devel/cxref/files/patch-ad14
-rw-r--r--devel/cxref/files/patch-ae13
4 files changed, 21 insertions, 19 deletions
diff --git a/devel/cxref/Makefile b/devel/cxref/Makefile
index b7e755749fd7..f293c8ac4090 100644
--- a/devel/cxref/Makefile
+++ b/devel/cxref/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= cxref
-PORTVERSION= 1.5g
-PORTREVISION= 1
+PORTVERSION= 1.6
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SUNSITE} \
- http://www.gedanken.demon.co.uk/download-cxref/
+MASTER_SITES= http://www.gedanken.demon.co.uk/download-cxref/ \
+ ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= devel/lang/c
EXTRACT_SUFX= .tgz
@@ -21,6 +20,8 @@ USE_BISON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --without-cxref-cpp
+ALL_TARGET= programs
MAN1= cxref.1 cxref-query.1
PLIST_FILES= bin/cxref bin/cxref-cc bin/cxref-query
diff --git a/devel/cxref/distinfo b/devel/cxref/distinfo
index a62f3b1c386b..cd64751099eb 100644
--- a/devel/cxref/distinfo
+++ b/devel/cxref/distinfo
@@ -1,2 +1,2 @@
-MD5 (cxref-1.5g.tgz) = cf54c31438f9e5de17614f7c41fb63a5
-SIZE (cxref-1.5g.tgz) = 343174
+MD5 (cxref-1.6.tgz) = ce66211f29d73c2ffaed5a3758493afc
+SIZE (cxref-1.6.tgz) = 392060
diff --git a/devel/cxref/files/patch-ad b/devel/cxref/files/patch-ad
index ba2243e0f9a1..df7cf606de62 100644
--- a/devel/cxref/files/patch-ad
+++ b/devel/cxref/files/patch-ad
@@ -1,6 +1,6 @@
---- Makefile.in.orig Sun Mar 18 19:29:25 2001
-+++ Makefile.in Fri May 18 05:53:30 2001
-@@ -28,6 +28,9 @@
+--- src/Makefile.in.orig Wed Sep 8 01:46:17 2004
++++ src/Makefile.in Fri Oct 1 20:59:36 2004
+@@ -27,6 +27,9 @@
# The installation program.
INSTALL=@INSTALL@
@@ -10,7 +10,7 @@
# The C compiler and linker
-@@ -121,10 +124,10 @@
+@@ -70,10 +73,10 @@
install : programs
[ -d $(bindir) ] || $(INSTALL) -d $(bindir)
@@ -20,7 +20,7 @@
+ $(INSTALL_SCRIPT) $(srcdir)/cxref-cc $(bindir)
[ -d $(mandir)/man1 ] || $(INSTALL) -d $(mandir)/man1
- $(INSTALL) -m 644 $(srcdir)/README.man $(mandir)/man1/cxref.1
-+ $(INSTALL_DATA) $(srcdir)/README.man $(mandir)/man1/cxref.1
- cd cpp && $(MAKE) install
- cd query && $(MAKE) install
++ $(INSTALL_DATA) $(srcdir)/../doc/README.man $(mandir)/man1/cxref.1
+ install-win32 : programs
+ [ -d $(bindir) ] || $(INSTALL) -d $(bindir)
diff --git a/devel/cxref/files/patch-ae b/devel/cxref/files/patch-ae
index 05b2db045442..642cbdb0c0b6 100644
--- a/devel/cxref/files/patch-ae
+++ b/devel/cxref/files/patch-ae
@@ -1,5 +1,5 @@
---- query/Makefile.in.orig Sun Mar 18 19:29:26 2001
-+++ query/Makefile.in Fri May 18 05:55:49 2001
+--- query/Makefile.in.orig Wed Jun 23 02:31:53 2004
++++ query/Makefile.in Fri Oct 1 21:01:20 2004
@@ -27,6 +27,9 @@
# The installation program.
@@ -10,14 +10,15 @@
# The C compiler and linker
-@@ -59,8 +62,8 @@
- ########
+@@ -49,9 +52,9 @@
install : cxref-query
+ [ -d $(bindir) ] || $(INSTALL) -d $(bindir)
- $(INSTALL) -m 755 cxref-query $(bindir)
-- $(INSTALL) -m 644 $(srcdir)/README.man $(mandir)/man1/cxref-query.1
+ $(INSTALL_PROGRAM) cxref-query $(bindir)
+ [ -d $(mandir)/man1 ] || $(INSTALL) -d $(mandir)/man1
+- $(INSTALL) -m 644 $(srcdir)/README.man $(mandir)/man1/cxref-query.1
+ $(INSTALL_DATA) $(srcdir)/README.man $(mandir)/man1/cxref-query.1
install-win32 : cxref-query
- $(INSTALL) -m 755 cxref-query.exe $(bindir)
+ [ -d $(bindir) ] || $(INSTALL) -d $(bindir)