aboutsummaryrefslogtreecommitdiff
path: root/devel/cxref
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2003-06-12 04:33:33 +0000
committerWill Andrews <will@FreeBSD.org>2003-06-12 04:33:33 +0000
commitf0135a326ed9b98446da5c4d8df6435fd77dc581 (patch)
treea02c54556c73983e864d6b6beb8ea36dd16e4a79 /devel/cxref
parent15534ed5211ed512dc0e102d9375c49e82086563 (diff)
downloadports-f0135a326ed9b98446da5c4d8df6435fd77dc581.tar.gz
ports-f0135a326ed9b98446da5c4d8df6435fd77dc581.zip
Fix malloc problem.
PR: 47039 Submitted by: Chris Knight <chris@aims.com.au>, "Simon 'corecode' Schubert" <corecode@corecode.ath.cx>
Notes
Notes: svn path=/head/; revision=82844
Diffstat (limited to 'devel/cxref')
-rw-r--r--devel/cxref/Makefile1
-rw-r--r--devel/cxref/files/patch-af16
2 files changed, 17 insertions, 0 deletions
diff --git a/devel/cxref/Makefile b/devel/cxref/Makefile
index bce3dd563e91..c957a2322b2a 100644
--- a/devel/cxref/Makefile
+++ b/devel/cxref/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cxref
PORTVERSION= 1.5d
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
ftp://ftp.demon.co.uk/pub/unix/tools/
diff --git a/devel/cxref/files/patch-af b/devel/cxref/files/patch-af
new file mode 100644
index 000000000000..e01cfd9cfe09
--- /dev/null
+++ b/devel/cxref/files/patch-af
@@ -0,0 +1,16 @@
+--- comment.c.orig Tue Nov 16 20:11:38 1999
++++ comment.c Tue Jan 14 16:17:17 2003
+@@ -158,8 +158,11 @@
+
+ if(comment)
+ {
+- malloc_comment=Realloc(malloc_comment,strlen(comment)+1);
+- strcpy(malloc_comment,comment);
++ if(malloc_comment != comment)
++ {
++ malloc_comment=Realloc(malloc_comment,strlen(comment)+1);
++ strcpy(malloc_comment,comment);
++ }
+ current_comment=malloc_comment;
+ }
+ else