aboutsummaryrefslogtreecommitdiff
path: root/devel/cxxtest
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-17 10:08:45 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-17 10:08:45 +0000
commit071cdddc084764d16cb88ed0f9bd97669fa04bd4 (patch)
tree98bf1b8ee3cc64e0c656ae9a01f28d508192a3a7 /devel/cxxtest
parent1adeba772633055d58a62068e2ec21b68f5fd197 (diff)
downloadports-071cdddc084764d16cb88ed0f9bd97669fa04bd4.tar.gz
ports-071cdddc084764d16cb88ed0f9bd97669fa04bd4.zip
Add cxxtest 3.0.1, a simple yet powerful
JUnit/CppUnit/xUnit-like framework for C++. PR: 55606 Submitted by: andrew morton <drewish@katherinehouse.com>
Notes
Notes: svn path=/head/; revision=94162
Diffstat (limited to 'devel/cxxtest')
-rw-r--r--devel/cxxtest/Makefile51
-rw-r--r--devel/cxxtest/distinfo1
-rw-r--r--devel/cxxtest/files/patch-sample-Makefile.unix15
-rw-r--r--devel/cxxtest/pkg-descr15
-rw-r--r--devel/cxxtest/pkg-plist74
5 files changed, 156 insertions, 0 deletions
diff --git a/devel/cxxtest/Makefile b/devel/cxxtest/Makefile
new file mode 100644
index 000000000000..22e891490fea
--- /dev/null
+++ b/devel/cxxtest/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: cxxtest
+# Date created: 14 August 2003
+# Whom: andrew morton
+#
+# $FreeBSD$
+#
+
+PORTNAME= cxxtest
+PORTVERSION= 3.0.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= drewish@katherinehouse.com
+COMMENT= A simple yet powerful JUnit/CppUnit/xUnit-like framework for C++
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+EXTRACT_SUFX = .tgz
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+do-install:
+# scripts
+ @${MKDIR} ${PREFIX}/include/cxxtest
+ ${INSTALL_DATA} ${WRKSRC}/cxxtest/* ${PREFIX}/include/cxxtest/
+ ${INSTALL_SCRIPT} ${WRKSRC}/cxxtestgen.pl ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/cxxtestgen.py ${PREFIX}/bin/
+
+# docs and examples (minus the win ddk stuff)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/sample
+ @${MKDIR} ${DOCSDIR}/test
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.png ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/*.h ${DOCSDIR}/sample/
+ ${INSTALL_DATA} ${WRKSRC}/sample/*.cpp ${DOCSDIR}/sample/
+ ${INSTALL_DATA} ${WRKSRC}/sample/*.tpl ${DOCSDIR}/sample/
+ ${INSTALL_DATA} ${WRKSRC}/sample/Construct ${DOCSDIR}/sample/
+ ${INSTALL_DATA} ${WRKSRC}/sample/Makefile.unix ${DOCSDIR}/sample/Makefile
+ ${INSTALL_DATA} ${WRKSRC}/test/*.h ${DOCSDIR}/test/
+ ${INSTALL_DATA} ${WRKSRC}/test/*.cpp ${DOCSDIR}/test/
+ ${INSTALL_DATA} ${WRKSRC}/test/*.tpl ${DOCSDIR}/test/
+ ${INSTALL_DATA} ${WRKSRC}/test/*.out ${DOCSDIR}/test/
+ ${INSTALL_DATA} ${WRKSRC}/test/test.pl ${DOCSDIR}/test/
+ @${ECHO_CMD} "* Documentation and samples have been installed in ${DOCSDIR}"
+ @${ECHO_CMD} "* NOTE: the makefiles provided with the samples aren't compatible with FreeBSD's make, use ${GMAKE} instead."
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/cxxtest/distinfo b/devel/cxxtest/distinfo
new file mode 100644
index 000000000000..521109e8acf7
--- /dev/null
+++ b/devel/cxxtest/distinfo
@@ -0,0 +1 @@
+MD5 (cxxtest-3.0.1.tgz) = 1cf800ee2d7a9b3af02336655e3823fc
diff --git a/devel/cxxtest/files/patch-sample-Makefile.unix b/devel/cxxtest/files/patch-sample-Makefile.unix
new file mode 100644
index 000000000000..b512ebe8d29a
--- /dev/null
+++ b/devel/cxxtest/files/patch-sample-Makefile.unix
@@ -0,0 +1,15 @@
+--- sample/Makefile.unix.orig Fri Aug 15 02:51:52 2003
++++ sample/Makefile.unix Fri Aug 15 03:03:55 2003
+@@ -5,9 +5,9 @@
+ # For the X11 GUI
+ X11_FLAGS = -I/usr/X11R6/include -L/usr/X11R6/lib -lX11
+
+-# For the Qt GUI
+-#QTDIR = /usr/lib/qt
+-QT_FLAGS = -I$(QTDIR)/include -L$(QTDIR)/lib -lqt -O2
++# For the Qt 3.1 GUI
++QTDIR = /usr/X11R6
++QT_FLAGS = -I$(QTDIR)/include -L$(QTDIR)/lib -lqt-mt -O2
+
+ TARGETS = error_printer stdio_printer yes_no_runner file_printer aborter
+ GUI_TARGETS = x11_runner qt_runner
diff --git a/devel/cxxtest/pkg-descr b/devel/cxxtest/pkg-descr
new file mode 100644
index 000000000000..aebdb4b78979
--- /dev/null
+++ b/devel/cxxtest/pkg-descr
@@ -0,0 +1,15 @@
+CxxTest is a JUnit/CppUnit/xUnit-like framework for C++.
+
+Its advantages over existing alternatives are that it:
+ - Doesn't require RTTI
+ - Doesn't require member template functions
+ - Doesn't require exception handling
+ - Doesn't require any external libraries (including memory management,
+ file/console I/O, graphics libraries)
+
+This makes it extremely portable and usable.
+
+WWW: http://cxxtest.sourceforge.net/
+
+- andrew morton
+drewish@katherinehouse.com
diff --git a/devel/cxxtest/pkg-plist b/devel/cxxtest/pkg-plist
new file mode 100644
index 000000000000..c75564fa2f0a
--- /dev/null
+++ b/devel/cxxtest/pkg-plist
@@ -0,0 +1,74 @@
+bin/cxxtestgen.pl
+bin/cxxtestgen.py
+include/cxxtest/CountingTracker.h
+include/cxxtest/Descriptions.h
+include/cxxtest/ErrorFormatter.h
+include/cxxtest/ErrorPrinter.h
+include/cxxtest/Gui.h
+include/cxxtest/ParenPrinter.h
+include/cxxtest/QtGui.h
+include/cxxtest/SelfTest.h
+include/cxxtest/StdValueTraits.h
+include/cxxtest/StdioPrinter.h
+include/cxxtest/TeeListener.h
+include/cxxtest/TeeRunner.h
+include/cxxtest/TestListener.h
+include/cxxtest/TestRunner.h
+include/cxxtest/TestSuite.h
+include/cxxtest/TestTracker.h
+include/cxxtest/ValueTraits.h
+include/cxxtest/Win32Gui.h
+include/cxxtest/X11Gui.h
+include/cxxtest/YesNoRunner.h
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/guide.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/qt.png
+%%PORTDOCS%%%%DOCSDIR%%/qt2.png
+%%PORTDOCS%%%%DOCSDIR%%/x11.png
+%%PORTDOCS%%%%DOCSDIR%%/sample/aborter.tpl
+%%PORTDOCS%%%%DOCSDIR%%/sample/Construct
+%%PORTDOCS%%%%DOCSDIR%%/sample/CreatedTest.h
+%%PORTDOCS%%%%DOCSDIR%%/sample/DeltaTest.h
+%%PORTDOCS%%%%DOCSDIR%%/sample/ExceptionTest.h
+%%PORTDOCS%%%%DOCSDIR%%/sample/file_printer.tpl
+%%PORTDOCS%%%%DOCSDIR%%/sample/FixtureTest.h
+%%PORTDOCS%%%%DOCSDIR%%/sample/Makefile
+%%PORTDOCS%%%%DOCSDIR%%/sample/MessageTest.h
+%%PORTDOCS%%%%DOCSDIR%%/sample/SelfTest.h
+%%PORTDOCS%%%%DOCSDIR%%/sample/SimpleTest.h
+%%PORTDOCS%%%%DOCSDIR%%/sample/TraitsTest.h
+%%PORTDOCS%%%%DOCSDIR%%/sample/yes_no_runner.cpp
+%%PORTDOCS%%%%DOCSDIR%%/test/aborter.out
+%%PORTDOCS%%%%DOCSDIR%%/test/aborter_no_throw.out
+%%PORTDOCS%%%%DOCSDIR%%/test/AborterNoThrow.h
+%%PORTDOCS%%%%DOCSDIR%%/test/BadTest.h
+%%PORTDOCS%%%%DOCSDIR%%/test/EmptySuite.h
+%%PORTDOCS%%%%DOCSDIR%%/test/error.out
+%%PORTDOCS%%%%DOCSDIR%%/test/good.out
+%%PORTDOCS%%%%DOCSDIR%%/test/GoodSuite.h
+%%PORTDOCS%%%%DOCSDIR%%/test/GreenYellowRed.h
+%%PORTDOCS%%%%DOCSDIR%%/test/gui.out
+%%PORTDOCS%%%%DOCSDIR%%/test/gui_paren.out
+%%PORTDOCS%%%%DOCSDIR%%/test/main.cpp
+%%PORTDOCS%%%%DOCSDIR%%/test/one.out
+%%PORTDOCS%%%%DOCSDIR%%/test/paren.out
+%%PORTDOCS%%%%DOCSDIR%%/test/runner.out
+%%PORTDOCS%%%%DOCSDIR%%/test/test.pl
+%%PORTDOCS%%%%DOCSDIR%%/test/throw.out
+%%PORTDOCS%%%%DOCSDIR%%/test/ThrowNoStd.cpp
+%%PORTDOCS%%%%DOCSDIR%%/test/ThrowNoStd.h
+%%PORTDOCS%%%%DOCSDIR%%/test/ThrowNoStd.tpl
+%%PORTDOCS%%%%DOCSDIR%%/test/traits.out
+%%PORTDOCS%%%%DOCSDIR%%/test/TraitsTest.h
+%%PORTDOCS%%%%DOCSDIR%%/test/user.out
+%%PORTDOCS%%%%DOCSDIR%%/test/UserTraits.h
+%%PORTDOCS%%%%DOCSDIR%%/test/UserTraits.tpl
+%%PORTDOCS%%%%DOCSDIR%%/test/wchar.cpp
+%%PORTDOCS%%%%DOCSDIR%%/test/wchar.out
+%%PORTDOCS%%%%DOCSDIR%%/test/WideCharTest.h
+%%PORTDOCS%%%%DOCSDIR%%/test/wildcard.out
+@dirrm %%PORTDOCS%%%%DOCSDIR%%/test
+@dirrm %%PORTDOCS%%%%DOCSDIR%%/sample
+@dirrm %%PORTDOCS%%%%DOCSDIR%%
+@dirrm include/cxxtest