aboutsummaryrefslogtreecommitdiff
path: root/devel/cxxtest
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-27 23:33:18 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-27 23:33:18 +0000
commitb3e93674a6f5e74786d4d293a15b30dcf432868c (patch)
treeefbcbe384eb68d00ec5dd4b552c8a98663a9edc4 /devel/cxxtest
parent5bbc87c51939932b53dbf95851b4f3a34d7e4bda (diff)
downloadports-b3e93674a6f5e74786d4d293a15b30dcf432868c.tar.gz
ports-b3e93674a6f5e74786d4d293a15b30dcf432868c.zip
Support stage
Add a DOCS option Fix shebangs
Notes
Notes: svn path=/head/; revision=341476
Diffstat (limited to 'devel/cxxtest')
-rw-r--r--devel/cxxtest/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/devel/cxxtest/Makefile b/devel/cxxtest/Makefile
index 682356fe7ea5..b69c8827f931 100644
--- a/devel/cxxtest/Makefile
+++ b/devel/cxxtest/Makefile
@@ -9,31 +9,29 @@ MASTER_SITES= SF
MAINTAINER= drewish@katherinehouse.com
COMMENT= Simple and powerful JUnit/CppUnit/xUnit-like framework for C++
+OPTIONS_DEFINE= DOCS
+
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-USES= perl5
+USES= gmake perl5 shebangfix
USE_PERL5= run
-USE_GMAKE= yes
+SHEBANG_FILES= cxxtestgen.pl cxxtestgen.py
DOCS= README TODO docs/*.html docs/*.png
EXAMPLES= sample/*.cpp sample/*.h sample/*.tpl sample/Construct \
sample/Makefile.unix sample/gui/GreenYellowRed.h
-NO_STAGE= yes
do-install:
# scripts
- @${MKDIR} ${PREFIX}/include/cxxtest
- ${INSTALL_DATA} ${WRKSRC}/cxxtest/* ${PREFIX}/include/cxxtest/
- ${INSTALL_SCRIPT} ${WRKSRC}/cxxtestgen.pl ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKSRC}/cxxtestgen.py ${PREFIX}/bin/
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/cxxtest
+ ${INSTALL_DATA} ${WRKSRC}/cxxtest/* ${STAGEDIR}${PREFIX}/include/cxxtest/
+ ${INSTALL_SCRIPT} ${WRKSRC}/cxxtestgen.pl ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/cxxtestgen.py ${STAGEDIR}${PREFIX}/bin/
# docs and examples (minus the win ddk stuff)
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
- @${ECHO_MSG} "* Documentation has been installed in ${DOCSDIR}"
-.endif
- @${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
+ @@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
@${ECHO_MSG} "* Samples have been installed in ${EXAMPLESDIR}"
@${ECHO_MSG} "* The CxxTest scripts have been installed into ${PREFIX}/bin/."
@${ECHO_MSG} "* The include files are in ${PREFIX}/include/cxxtest/"