aboutsummaryrefslogtreecommitdiff
path: root/devel/cxxtools
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-10-10 21:31:30 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-10-10 21:31:30 +0000
commit3ef3461740738a4408c83087846d4b59d726eaa6 (patch)
treef3d89a0399e1e0896808a5ab7c804ecd549e47db /devel/cxxtools
parent615a3fc1bbb5a8d6dd9a7a24d8d19046049875ee (diff)
downloadports-3ef3461740738a4408c83087846d4b59d726eaa6.tar.gz
ports-3ef3461740738a4408c83087846d4b59d726eaa6.zip
For ports that are explicitly enabled on armv6, also enable them
on armv7. This has not been tested with an -exp run but should "do no harm". PR: 221894 (partial)
Notes
Notes: svn path=/head/; revision=451721
Diffstat (limited to 'devel/cxxtools')
-rw-r--r--devel/cxxtools/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/devel/cxxtools/Makefile b/devel/cxxtools/Makefile
index 79ac4916ffa3..55e8b227f7ea 100644
--- a/devel/cxxtools/Makefile
+++ b/devel/cxxtools/Makefile
@@ -27,37 +27,37 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
+.if ${ARCH} == amd64
PLIST_SUB+= X86_64_ONLY=""
.else
PLIST_SUB+= X86_64_ONLY="@comment "
.endif
-.if ${ARCH} == "i386"
+.if ${ARCH} == i386
PLIST_SUB+= I386_ONLY=""
.else
PLIST_SUB+= I386_ONLY="@comment "
.endif
-.if (${ARCH} == "amd64") || (${ARCH} == "i386")
+.if (${ARCH} == amd64) || (${ARCH} == i386)
PLIST_SUB+= X86_ONLY=""
.else
PLIST_SUB+= X86_ONLY="@comment "
.endif
-.if ${ARCH} == "arm" || ${ARCH} == "armv6"
+.if ${ARCH} == arm || ${ARCH} == armv6 || ${ARCH} == armv7
PLIST_SUB+= ARM_ONLY=""
.else
PLIST_SUB+= ARM_ONLY="@comment "
.endif
-.if ${ARCH} == "mips" || ${ARCH} == "mips64"
+.if ${ARCH} == mips || ${ARCH} == mips64
PLIST_SUB+= MIPS_ONLY=""
.else
PLIST_SUB+= MIPS_ONLY="@comment "
.endif
-.if ${ARCH} == "powerpc" || ${ARCH} == "powerpc64"
+.if ${ARCH} == powerpc || ${ARCH} == powerpc64
PLIST_SUB+= PPC_ONLY=""
.else
PLIST_SUB+= PPC_ONLY="@comment "