aboutsummaryrefslogtreecommitdiff
path: root/devel/darcs/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-02-07 01:59:19 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-02-07 01:59:19 +0000
commit99dbf79cb398c5a293b10f74009104d0244f3809 (patch)
treeebdca9f0c91ba649a37bd3ef08ffc7d32861edc0 /devel/darcs/Makefile
parentafa11322a547bc10d3fdb7b04a0d069cf3c530ea (diff)
downloadports-99dbf79cb398c5a293b10f74009104d0244f3809.tar.gz
ports-99dbf79cb398c5a293b10f74009104d0244f3809.zip
- Update to 2.2.0
- Improve PORTDOCS - Add textproc/latex2html as dependency for the better documentation generation - Add a warning message for 6.x users as there might be configure crashes - Fix pkg-descr Approved by: gabor
Notes
Notes: svn path=/head/; revision=227746
Diffstat (limited to 'devel/darcs/Makefile')
-rw-r--r--devel/darcs/Makefile31
1 files changed, 26 insertions, 5 deletions
diff --git a/devel/darcs/Makefile b/devel/darcs/Makefile
index def06117e1aa..06e76063eded 100644
--- a/devel/darcs/Makefile
+++ b/devel/darcs/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= darcs
-PORTVERSION= 2.0.2
-PORTREVISION= 1
+PORTVERSION= 2.2.0
CATEGORIES= devel
MASTER_SITES= http://darcs.net/
@@ -25,7 +24,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
CFLAGS=""
USE_GMAKE= yes
MAKEFILE= GNUmakefile
-INSTALL_TARGET= installbin
+INSTALL_TARGET= install
+PORTDOCS= manual examples
.include <bsd.port.pre.mk>
@@ -43,9 +43,12 @@ PLIST_SUB+= CGIDIR=${CGIDIR} SERVER=""
PLIST_SUB+= SERVER="@comment "
.endif
.if !defined(NOPORTDOCS)
-BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX-base
+BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX-base \
+ latex2html:${PORTSDIR}/textproc/latex2html
ALL_TARGET+= doc/manual/darcs.ps doc/manual/patch-theory.pdf doc/manual/index.html
-INSTALL_TARGET+= installdocs
+INSTALL_TARGET+= install-ps install-pdf install-html install-examples
+.else
+CONFIGURE_ARGS+= --without-manual
.endif
MAN1= darcs.1
@@ -57,6 +60,24 @@ post-patch:
${WRKSRC}/${MAKEFILE}
.endif
+pre-configure:
+.if ${OSVERSION} < 700000
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "###############################################################################"
+ @${ECHO_MSG} " "
+ @${ECHO_MSG} " A T T E N T I O N "
+ @${ECHO_MSG} " "
+ @${ECHO_MSG} "If you experience problems during the configure process, please add the "
+ @${ECHO_MSG} "following lines to your /etc/libmap.conf configuration file: "
+ @${ECHO_MSG} " "
+ @${ECHO_MSG} "libpthread.so.1 libthr.so.1 "
+ @${ECHO_MSG} "libpthread.so.2 libthr.so.2 "
+ @${ECHO_MSG} "libkse.so.3 libthr.so.3 "
+ @${ECHO_MSG} " "
+ @${ECHO_MSG} "###############################################################################"
+ @${ECHO_MSG} ""
+.endif
+
post-install:
@${STRIP_CMD} ${PREFIX}/bin/darcs