aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus-sharp/Makefile
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2014-01-31 10:54:36 +0000
committerRomain Tartière <romain@FreeBSD.org>2014-01-31 10:54:36 +0000
commit5773d9cf65fac9d48ea803d5219e1edbff2b821c (patch)
tree7ebc5e54e9e5e0d9e0d00edcc531d62911c16160 /devel/dbus-sharp/Makefile
parentdbc7e7712b297a10dd48c1d9d9da1c60927d1f62 (diff)
downloadports-5773d9cf65fac9d48ea803d5219e1edbff2b821c.tar.gz
ports-5773d9cf65fac9d48ea803d5219e1edbff2b821c.zip
Fix for FreeBSD 10.0.
While here, cleannup port.
Notes
Notes: svn path=/head/; revision=341977
Diffstat (limited to 'devel/dbus-sharp/Makefile')
-rw-r--r--devel/dbus-sharp/Makefile23
1 files changed, 19 insertions, 4 deletions
diff --git a/devel/dbus-sharp/Makefile b/devel/dbus-sharp/Makefile
index 499412703ed9..d80809a86f5b 100644
--- a/devel/dbus-sharp/Makefile
+++ b/devel/dbus-sharp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dbus-sharp
PORTVERSION= 0.7.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel gnome
MASTER_SITES= http://cloud.github.com/downloads/mono/${PORTNAME}/
@@ -10,13 +11,27 @@ MASTER_SITES= http://cloud.github.com/downloads/mono/${PORTNAME}/
MAINTAINER= mono@FreeBSD.org
COMMENT= Mono interface to the D-BUS messaging system
+LICENSE= MIT
+
BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= pathfix pkgconfig
+USES= gmake pathfix pkgconfig
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} < 1000044
+# libc.so is a symlink to the right libc.so.X
+ ${REINPLACE_CMD} -e 's|libc.so.6|libc.so|' \
+ ${WRKSRC}/src/dbus-sharp.dll.config
+.else
+# libc.so is an LD script not usable by dllmap, so we have to set a proper
+# version number.
+ ${REINPLACE_CMD} -e 's|libc.so.6|libc.so.7|' \
+ ${WRKSRC}/src/dbus-sharp.dll.config
+.endif
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>