aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus-sharp
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /devel/dbus-sharp
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
downloadports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.tar.gz
ports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.zip
Presenting GNOME 2.16.1 for FreeBSD. This release represents a massive
amount of work by the FreeBSD GNOME Team and our testers. On top of the usual GNOME update, we have taken this opportunity to move GNOME from X11BASE to LOCALBASE. This means roughly 600 ports NOT part of the GNOME Desktop also need to be changed. The bulk of the move was carried out by ahze, mezz, and pav, but it would not have been possible without cooperation from the FreeBSD KDE team who worked with us to make sure GNOME and KDE can still coexist happily. We would also like to send a shout out to kris and pointyhat for putting up with multiple test runs until we got something that was solid. Back to GNOME 2.16. This release brings a huge amount of new functionality to FreeBSD. The standard release notes can be read at http://www.gnome.org/start/2.16/ . But on top of what you will read there, jylefort and marcus have completed work on a port of HAL to FreeBSD. This will allow FreeBSD to take advantage of closer hardware interaction such as auto-mounting CD-ROMs, USB drives, and music players; auto-playing audio CDs; and managing laptop power consumption. But where would this all be without our loyal testers and contributors? Therefore, the FreeBSD GNOME team would like to thank the following users: Phillip Neumann <pneumann@gmail.com> tmclaugh mux Yuri Pankov <yuri.pankov@gmail.com> chinsan Thomas <freebsdlists@bsdunix.ch> Brian Gruber <knightbg@yahoo.com> Franz Klammer <klammer@webonaut.com> Dominique Goncalves <dominique.goncalves@gmail.com> Pascal Hofstee <caelian@gmail.com> Yasuda Keisuke <kysd@po.harenet.ne.jp> backyard <backyard1454-bsd@yahoo.com> Andris Raugulis <endrju@null.lv> <endrju@null.lv> Eric L. Chen <d9364104@mail.nchu.edu.tw> Pawel Worach <pawel.worach@gmail.com> QuiRK on #freebsd-gnome Shane Bell <decept0@gmail.com> luigi sajd on #freebsd-gnome sat Chris Coleman <chrisc@vmunix.com> kaeru on #freebsd-gnome crsd_ via irc.freenode.org/#FreeBSD-GNOME Joel Diaz <joeldiaz@mac.com> Enjoy! Approved by: portmgr (implicit, kris)
Notes
Notes: svn path=/head/; revision=175253
Diffstat (limited to 'devel/dbus-sharp')
-rw-r--r--devel/dbus-sharp/Makefile8
-rw-r--r--devel/dbus-sharp/distinfo3
-rw-r--r--devel/dbus-sharp/files/patch-mono_Makefile.in108
-rw-r--r--devel/dbus-sharp/files/patch-mono_dbus-sharp.dll.config.in9
4 files changed, 126 insertions, 2 deletions
diff --git a/devel/dbus-sharp/Makefile b/devel/dbus-sharp/Makefile
index 18f226870a04..56d3d1e01b3f 100644
--- a/devel/dbus-sharp/Makefile
+++ b/devel/dbus-sharp/Makefile
@@ -6,20 +6,23 @@
# $Id: Makefile,v 1.18 2006/01/02 20:54:03 tmclau02 Exp $
#
-PORTREVISION= 13
+PORTVERSION= 0.62
+PORTREVISION= 16
CATEGORIES= devel gnome
PKGNAMESUFFIX= -sharp
MAINTAINER= bsd-sharp-list@forge.novell.com
COMMENT= Mono interface to the D-BUS messaging system
-LIB_DEPENDS= dbus-1.2:${PORTSDIR}/devel/dbus
+LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus
BUILD_DEPENDS= monodoc:${PORTSDIR}/devel/mono-tools
RUN_DEPENDS= monodoc:${PORTSDIR}/devel/mono-tools
MASTERDIR= ${.CURDIR}/../dbus
BUILD_WRKSRC= ${WRKSRC}/mono
INSTALL_WRKSRC= ${BUILD_WRKSRC}
+PATCHDIR= ${.CURDIR}/files
+MD5_FILE= ${.CURDIR}/distinfo
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
@@ -31,6 +34,7 @@ CONFIGURE_ARGS= --enable-mono \
--disable-gcj \
--disable-gtk \
--disable-qt \
+ --with-test-socket-dir=${WRKDIR} \
--with-system-pid-file=/var/run/dbus.pid \
--with-system-socket=/var/run/dbus \
--with-session-socket-dir=/var/tmp \
diff --git a/devel/dbus-sharp/distinfo b/devel/dbus-sharp/distinfo
new file mode 100644
index 000000000000..363c5a579806
--- /dev/null
+++ b/devel/dbus-sharp/distinfo
@@ -0,0 +1,3 @@
+MD5 (dbus-0.62.tar.gz) = ba7692f63d0e9f1ef06703dff56cb650
+SHA256 (dbus-0.62.tar.gz) = 884cc2083add655df57acc7bb144c61e9beeabf08ef76fa86929a58d7bc96707
+SIZE (dbus-0.62.tar.gz) = 1737361
diff --git a/devel/dbus-sharp/files/patch-mono_Makefile.in b/devel/dbus-sharp/files/patch-mono_Makefile.in
new file mode 100644
index 000000000000..7f1d7026cf22
--- /dev/null
+++ b/devel/dbus-sharp/files/patch-mono_Makefile.in
@@ -0,0 +1,108 @@
+--- mono/Makefile.in.orig Thu Jun 30 23:27:19 2005
++++ mono/Makefile.in Thu Jun 30 23:27:43 2005
+@@ -299,7 +299,7 @@
+ target_cpu = @target_cpu@
+ target_os = @target_os@
+ target_vendor = @target_vendor@
+-SUBDIRS = . doc example
++SUBDIRS = . example
+ TARGET = $(ASSEMBLY)
+ NOINST_EXES = test-dbus-sharp.exe
+ ASSEMBLY_NAME = dbus-sharp
+@@ -345,6 +345,10 @@
+ $(ASSEMBLY).config.in \
+ dbus-sharp.snk
+
++pkgconfigdir = $(prefix)/libdata/pkgconfig
++pkgconfigDATA_INSTALL = $(INSTALL_DATA)
++pkgconfig_DATA = ../dbus-sharp.pc
++
+ all: all-recursive
+
+ .SUFFIXES:
+@@ -391,6 +395,23 @@
+ distclean-libtool:
+ -rm -f libtool
+ uninstall-info-am:
++install-pkgconfigDATA: $(pkgconfig_DATA)
++ @$(NORMAL_INSTALL)
++ test -z "$(pkgconfigdir)" || $(mkdir_p) "$(DESTDIR)$(pkgconfigdir)"
++ @list='$(pkgconfig_DATA)'; for p in $$list; do \
++ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
++ f="`echo $$p | sed -e 's|^.*/||'`"; \
++ echo " $(pkgconfigDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgconfigdir)/$$f'"; \
++ $(pkgconfigDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgconfigdir)/$$f"; \
++ done
++
++uninstall-pkgconfigDATA:
++ @$(NORMAL_UNINSTALL)
++ @list='$(pkgconfig_DATA)'; for p in $$list; do \
++ f="`echo $$p | sed -e 's|^.*/||'`"; \
++ echo " rm -f '$(DESTDIR)$(pkgconfigdir)/$$f'"; \
++ rm -f "$(DESTDIR)$(pkgconfigdir)/$$f"; \
++ done
+
+ # This directory's subdirectories are mostly independent; you can cd
+ # into them and run `make' without going through this Makefile.
+@@ -569,7 +590,7 @@
+ done
+ check-am: all-am
+ check: check-recursive
+-all-am: Makefile
++all-am: Makefile $(pkgconfig_DATA)
+ installdirs: installdirs-recursive
+ installdirs-am:
+ install: install-recursive
+@@ -614,7 +635,7 @@
+
+ info-am:
+
+-install-data-am: install-data-local
++install-data-am: install-data-local install-pkgconfigDATA
+
+ install-exec-am:
+
+@@ -640,7 +661,7 @@
+
+ ps-am:
+
+-uninstall-am: uninstall-info-am uninstall-local
++uninstall-am: uninstall-info-am uninstall-local uninstall-pkgconfigDATA
+
+ uninstall-info: uninstall-info-recursive
+
+@@ -651,12 +672,13 @@
+ html-am info info-am install install-am install-data \
+ install-data-am install-data-local install-exec \
+ install-exec-am install-info install-info-am install-man \
+- install-strip installcheck installcheck-am installdirs \
++ install-pkgconfigDATA install-strip installcheck \
++ installcheck-am installdirs \
+ installdirs-am maintainer-clean maintainer-clean-generic \
+ maintainer-clean-recursive mostlyclean mostlyclean-generic \
+ mostlyclean-libtool mostlyclean-recursive pdf pdf-am ps ps-am \
+ tags tags-recursive uninstall uninstall-am uninstall-info-am \
+- uninstall-local
++ uninstall-pkgconfigDATA uninstall-local
+
+
+ all-am: $(TARGET)
+@@ -672,14 +694,14 @@
+
+ install-data-local:
+ @if test -n '$(TARGET)'; then \
+- echo "$(GACUTIL) /i $(ASSEMBLY) /f /package dbus-sharp /gacdir $(DESTDIR)$(libdir)"; \
+- $(GACUTIL) /i $(ASSEMBLY) /f /package dbus-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir) || exit 1; \
++ echo "$(GACUTIL) /i $(ASSEMBLY) /f /package dbus-sharp /gacdir $(DESTDIR)$(libdir) /root $(DESTDIR)$(libdir)"; \
++ $(GACUTIL) /i $(ASSEMBLY) /f /package dbus-sharp /gacdir $(DESTDIR)$(libdir) /root $(DESTDIR)$(libdir) || exit 1; \
+ fi
+
+ uninstall-local:
+ @if test -n '$(TARGET)'; then \
+- echo "$(GACUTIL) /u $(ASSEMBLY_NAME) /package dbus-sharp /gacdir $(DESTDIR)$(libdir)"; \
+- $(GACUTIL) /u $(ASSEMBLY_NAME) /package dbus-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir) || exit 1; \
++ echo "$(GACUTIL) /u $(ASSEMBLY_NAME) /package dbus-sharp /gacdir $(DESTDIR)$(libdir) /root $(DESTDIR)$(libdir)"; \
++ $(GACUTIL) /u $(ASSEMBLY_NAME) /package dbus-sharp /gacdir $(DESTDIR)$(libdir) /root $(DESTDIR)$(libdir)|| exit 1; \
+ fi
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/devel/dbus-sharp/files/patch-mono_dbus-sharp.dll.config.in b/devel/dbus-sharp/files/patch-mono_dbus-sharp.dll.config.in
new file mode 100644
index 000000000000..b7c0032aad1f
--- /dev/null
+++ b/devel/dbus-sharp/files/patch-mono_dbus-sharp.dll.config.in
@@ -0,0 +1,9 @@
+--- mono/dbus-sharp.dll.config.in.orig Sat Mar 12 20:56:29 2005
++++ mono/dbus-sharp.dll.config.in Wed Apr 13 21:19:06 2005
+@@ -1,4 +1,4 @@
+ <configuration>
+- <dllmap dll="dbus-1" target="libdbus-1@LIB_PREFIX@.@LT_CURRENT@@LIB_SUFFIX@"/>
+- <dllmap dll="dbus-glib-1" target="libdbus-glib-1@LIB_PREFIX@.@LT_CURRENT@@LIB_SUFFIX@"/>
++ <dllmap dll="dbus-1" target="libdbus-1@LIB_PREFIX@@LIB_SUFFIX@"/>
++ <dllmap dll="dbus-glib-1" target="libdbus-glib-1@LIB_PREFIX@@LIB_SUFFIX@"/>
+ </configuration>