aboutsummaryrefslogtreecommitdiff
path: root/devel/dconf
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-08-29 21:24:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-08-29 21:24:04 +0000
commit80df0689f766f21df4b3502879cf4d9bdf83d83f (patch)
tree3a95e81caf084846d09e769e7af42ae80694bc83 /devel/dconf
parentc134e852717e1dfdd7829378b3afa502060b2443 (diff)
downloadports-80df0689f766f21df4b3502879cf4d9bdf83d83f.tar.gz
ports-80df0689f766f21df4b3502879cf4d9bdf83d83f.zip
Fix dconf-editor at run-time.
Submitted by: Eric Turgeon Obtained from: GNOME dev repo, patch from dconf upstream
Notes
Notes: svn path=/head/; revision=325634
Diffstat (limited to 'devel/dconf')
-rw-r--r--devel/dconf/Makefile11
-rw-r--r--devel/dconf/files/patch-editor_ca.desrt.dconf-editor.gschema.xml31
2 files changed, 36 insertions, 6 deletions
diff --git a/devel/dconf/Makefile b/devel/dconf/Makefile
index fa96e4d9c962..c7947cd410ce 100644
--- a/devel/dconf/Makefile
+++ b/devel/dconf/Makefile
@@ -1,6 +1,6 @@
# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/devel/dconf/Makefile 18634 2013-07-26 10:42:35Z kwm $
+# $MCom: ports/trunk/devel/dconf/Makefile 18669 2013-08-29 21:14:12Z kwm $
PORTNAME?= dconf
PORTVERSION= 0.14.1
@@ -11,12 +11,11 @@ DISTNAME= dconf-${PORTVERSION}
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A configuration database system for GNOME
+COMMENT= Configuration database system for GNOME
BUILD_DEPENDS= vala>=0.18.1:${PORTSDIR}/lang/vala \
docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl
-
-LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
+LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
USE_XZ= yes
USES= gettext gmake pathfix pkgconfig
@@ -33,7 +32,7 @@ DCONF_SLAVE?= no
USE_GNOME+= gtk30
INSTALLS_ICONS= yes
GLIB_SCHEMAS= ca.desrt.dconf-editor.gschema.xml
-LIB_DEPENDS+= dconf:${PORTSDIR}/devel/dconf
+LIB_DEPENDS+= libdconf.so:${PORTSDIR}/devel/dconf
.else
CONFIGURE_ARGS+=--disable-editor
.endif
@@ -56,7 +55,7 @@ post-patch:
${WRKSRC}/client/Makefile.in \
${WRKSRC}/editor/Makefile.in
-pre-build:
+#pre-build:
# ${GMAKE} -C ${WRKSRC}/client dconf-client.c libdconf.so.0
# ${GMAKE} -C ${WRKSRC}/dbus-1 dconf-dbus-1.c libdconf-dbus-1.so.0
diff --git a/devel/dconf/files/patch-editor_ca.desrt.dconf-editor.gschema.xml b/devel/dconf/files/patch-editor_ca.desrt.dconf-editor.gschema.xml
new file mode 100644
index 000000000000..bacfb9411e85
--- /dev/null
+++ b/devel/dconf/files/patch-editor_ca.desrt.dconf-editor.gschema.xml
@@ -0,0 +1,31 @@
+--- editor/ca.desrt.dconf-editor.gschema.xml.orig 2013-08-29 22:55:54.000000000 +0200
++++ editor/ca.desrt.dconf-editor.gschema.xml 2013-08-29 23:08:00.000000000 +0200
+@@ -1,20 +1,25 @@
+ <?xml version="1.0" encoding="UTF-8"?>
+ <schemalist gettext-domain='dconf'>
+ <schema id="ca.desrt.dconf-editor.Settings" path="/ca/desrt/dconf-editor/">
+- <key name="width" type="i">
++ <key name="window-width" type="i">
+ <default>800</default>
+ <summary>The width of the window</summary>
+ <description>The width of the main window in pixels.</description>
+ </key>
+- <key name="height" type="i">
++ <key name="window-height" type="i">
+ <default>600</default>
+ <summary>The height of the window</summary>
+ <description>The height of the main window in pixels.</description>
+ </key>
+- <key name="maximized" type="b">
++ <key name="window-is-maximized" type="b">
+ <default>false</default>
+ <summary>A flag to enable maximized mode</summary>
+ <description>A flag to enable maximized mode</description>
+ </key>
++ <key name="window-is-fullscreen" type="b">
++ <default>false</default>
++ <summary>A flag to enable fullscreen mode</summary>
++ <description>A flag to enable fullscreen mode</description>
++ </key>
+ </schema>
+ </schemalist>