aboutsummaryrefslogtreecommitdiff
path: root/devel/ddd
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-03-29 05:34:39 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-03-29 05:34:39 +0000
commit0afced6fb3e4b6493233f1ecca475397ed0b40be (patch)
treed79acbfe20fe5453e86d8a053f9bd927bae5fbc9 /devel/ddd
parent8de93e29fc7a76acac06705e2b0c309e289d3079 (diff)
downloadports-0afced6fb3e4b6493233f1ecca475397ed0b40be.tar.gz
ports-0afced6fb3e4b6493233f1ecca475397ed0b40be.zip
UPDATE: ddd-3.3.1 to 3.3.8
The port was marked broken, but compiled anyway when BROKEN= was commnted out. I took it upon myself to fix it so the lates version builds. For whatever reason the libiberty configure script bombs. Instead of patching/and fixing it I added a dependency on devel/freelibiberty. That solves that problem. Cleaned up the installation of PORTDOCS in the Makefile and pkg-plist. Regenerated all the patch files since many of the original ones had no contextual lines and would apply without error where the patch should have bombed. So the following patch files are to be removed: PR: ports/63473 Submitted by: Yarema <yds@CoolRat.org> Approved by: Maintainer timeout
Notes
Notes: svn path=/head/; revision=105577
Diffstat (limited to 'devel/ddd')
-rw-r--r--devel/ddd/Makefile59
-rw-r--r--devel/ddd/distinfo4
-rw-r--r--devel/ddd/files/extra-patch-ddd::streampos.h12
-rw-r--r--devel/ddd/files/patch-0112
-rw-r--r--devel/ddd/files/patch-0214
-rw-r--r--devel/ddd/files/patch-035
-rw-r--r--devel/ddd/files/patch-config.guess5
-rw-r--r--devel/ddd/files/patch-configure20
-rw-r--r--devel/ddd/files/patch-ddd::Ddd.in12
-rw-r--r--devel/ddd/files/patch-ddd::LiterateA.C (renamed from devel/ddd/files/patch-LiterateA.C)4
-rw-r--r--devel/ddd/files/patch-ddd::Makefile.in11
-rw-r--r--devel/ddd/files/patch-ddd::TTYAgent.C (renamed from devel/ddd/files/patch-TTYAgent.C)6
-rw-r--r--devel/ddd/files/patch-libiberty::strerror.c (renamed from devel/ddd/files/patch-strerror.c)13
-rw-r--r--devel/ddd/files/patch-libiberty::strsignal.c (renamed from devel/ddd/files/patch-strsignal.c)9
-rw-r--r--devel/ddd/pkg-plist19
15 files changed, 103 insertions, 102 deletions
diff --git a/devel/ddd/Makefile b/devel/ddd/Makefile
index a80a7cb619b5..ca82c810ef56 100644
--- a/devel/ddd/Makefile
+++ b/devel/ddd/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= ddd
-PORTVERSION= 3.3.1
-PORTREVISION= 1
+PORTVERSION= 3.3.8
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ddd
@@ -16,20 +16,31 @@ MASTER_SITE_SUBDIR= ddd
MAINTAINER= lioux@FreeBSD.org
COMMENT= Data Display Debugger -- a common graphical front-end for GDB/DBX/XDB
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-motif-libraries="${LIBXMDIR}" \
- --with-readline-libraries=/usr/lib
+LIB_DEPENDS= iberty.1:${PORTSDIR}/devel/freelibiberty
+
USE_GMAKE= yes
USE_REINPLACE= yes
USE_SIZE= yes
USE_XPM= yes
USE_MOTIF= yes
+USE_LIBTOOL= yes
+
+CFLAGS+= -Wno-deprecated
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS='${CPPFLAGS}' \
+ LDFLAGS='${LDFLAGS}'
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-motif-libraries="${LIBXMDIR}" \
+ --with-readline-libraries=/usr/lib
+
PLIST_SUB= VERSION=${PORTVERSION}
MAN1= ddd.1
-
-CFLAGS+= -Wno-deprecated
+DOCS= AUTHORS INSTALL PROBLEMS README TIPS TODO \
+ doc/html/ddd.html doc/ddd-paper.ps \
+ doc/ddd-themes.ps doc/ddd.ps \
+ doc/ddd-themes.pdf doc/ddd.pdf
.if defined(MOTIFLIB)
.if defined(MOTIF_STATIC)
@@ -43,38 +54,24 @@ LIBXMDIR= ${X11BASE}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
-.endif
-
-.if ${OSVERSION} >= 500113
-# XXX - configure is not detecting our streampos
-# provide better solution later
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ddd::streampos.h
-.endif
-
pre-patch:
- ${RM} -fv ${WRKSRC}/ddd/ddd.info*
- ${RM} -fv ${WRKSRC}/ddd/ddd-themes.info*
+ @${RM} -fv ${WRKSRC}/ddd/ddd.info*
+ @${RM} -fv ${WRKSRC}/ddd/ddd-themes.info*
pre-configure:
@${FIND} ${WRKSRC} -name configure | ${XARGS} \
- ${REINPLACE_CMD} -e "s|-O2|-g|"
+ ${REINPLACE_CMD} -e "s|-O2||"
post-configure:
- ${ECHO_CMD} "LIBXM = ${MOTIFLIB}" >> ${WRKSRC}/ddd/Makefile
+ @${ECHO_CMD} "LIBXM = ${MOTIFLIB}" >> ${WRKSRC}/ddd/Makefile
post-install:
- @${RM} ${PREFIX}/lib/libiberty.a
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/ddd
- ${INSTALL_DATA} ${WRKSRC}/PROBLEMS ${PREFIX}/share/doc/ddd
- ${INSTALL_DATA} ${WRKSRC}/doc/README ${PREFIX}/share/doc/ddd
- ${INSTALL_DATA} ${WRKSRC}/doc/ddd-paper.ps ${PREFIX}/share/doc/ddd
- ${INSTALL_DATA} ${WRKSRC}/doc/ddd.ps ${PREFIX}/share/doc/ddd
- ${INSTALL_DATA} ${WRKSRC}/doc/sample.dddinit ${PREFIX}/share/doc/ddd
- ${GZIP_CMD} ${PREFIX}/share/doc/ddd/ddd-paper.ps
- ${GZIP_CMD} ${PREFIX}/share/doc/ddd/ddd.ps
+ @${INSTALL} -d -o ${DOCOWN} -g ${DOCGRP} ${DOCSDIR}
+.for file in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+ @${GZIP_CMD} ${DOCSDIR}/*.ps
.endif
check:
diff --git a/devel/ddd/distinfo b/devel/ddd/distinfo
index c9803188a58a..1b440bfdae68 100644
--- a/devel/ddd/distinfo
+++ b/devel/ddd/distinfo
@@ -1,2 +1,2 @@
-MD5 (ddd-3.3.1.tar.gz) = 38589618d7cd02a03d062bb116bbf1d2
-SIZE (ddd-3.3.1.tar.gz) = 5820713
+MD5 (ddd-3.3.8.tar.gz) = 60c5bfbfe1564926edda629ffcf01e52
+SIZE (ddd-3.3.8.tar.gz) = 8606382
diff --git a/devel/ddd/files/extra-patch-ddd::streampos.h b/devel/ddd/files/extra-patch-ddd::streampos.h
deleted file mode 100644
index f8a0fd9b00a7..000000000000
--- a/devel/ddd/files/extra-patch-ddd::streampos.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- ddd/streampos.h.orig Mon Jan 17 09:53:42 2000
-+++ ddd/streampos.h Fri Jun 6 03:49:41 2003
-@@ -40,7 +40,9 @@
- #include "config.h"
-
- #if !HAVE_STREAMPOS
-+#ifndef __FreeBSD__
- typedef long streampos;
-+#endif
- #endif
-
- #endif // _DDD_streampos_h
diff --git a/devel/ddd/files/patch-01 b/devel/ddd/files/patch-01
deleted file mode 100644
index bed72b09777f..000000000000
--- a/devel/ddd/files/patch-01
+++ /dev/null
@@ -1,12 +0,0 @@
---- ddd/Ddd.in.orig Mon Dec 22 06:54:49 1997
-+++ ddd/Ddd.in Mon Jan 26 16:34:25 1998
-@@ -197,7 +197,8 @@
-
-
- ! Paper size, in format WIDTH x HEIGHT. (Default: A4).
--@Ddd@*paperSize: 210mm x 297mm
-+!@Ddd@*paperSize: 210mm x 297mm
-+@Ddd@*paperSize: 8.5" x 11"
-
-
- ! The `edit' command to invoke an editor on the specific file.
diff --git a/devel/ddd/files/patch-02 b/devel/ddd/files/patch-02
deleted file mode 100644
index 0b18169c733a..000000000000
--- a/devel/ddd/files/patch-02
+++ /dev/null
@@ -1,14 +0,0 @@
---- ddd/configure.orig Fri Feb 2 07:47:25 2001
-+++ ddd/configure Sat Mar 10 17:18:16 2001
-@@ -1003 +1003 @@
-- MAKEINFO=makeinfo
-+ MAKEINFO="makeinfo --no-split"
-@@ -1961 +1961 @@
--for ac_prog in 'bison -y' byacc
-+for ac_prog in byacc
-@@ -6168 +6168 @@
--#include <iostream.h>
-+#include <fstream.h>
-@@ -13358 +13358 @@
-- egrep "${ice_re_word}ioctl *\(" >/dev/null 2>&1; then
-+ egrep "${ice_re_word}\(?ioctl\)? *\(" >/dev/null 2>&1; then
diff --git a/devel/ddd/files/patch-03 b/devel/ddd/files/patch-03
deleted file mode 100644
index e45322ef1e21..000000000000
--- a/devel/ddd/files/patch-03
+++ /dev/null
@@ -1,5 +0,0 @@
---- ddd/Makefile.in.orig Fri Feb 2 07:47:11 2001
-+++ ddd/Makefile.in Thu Mar 8 04:48:10 2001
-@@ -134 +134 @@
--MAKEINFO = @MAKEINFO@
-+MAKEINFO = @MAKEINFO@ --no-split
diff --git a/devel/ddd/files/patch-config.guess b/devel/ddd/files/patch-config.guess
deleted file mode 100644
index 8cef952cf538..000000000000
--- a/devel/ddd/files/patch-config.guess
+++ /dev/null
@@ -1,5 +0,0 @@
---- config.guess.orig Thu Oct 21 02:10:44 1999
-+++ config.guess Thu Mar 8 05:14:29 2001
-@@ -516 +516 @@
-- echo ${UNAME_MACHINE}-unknown-freebsdelf`echo${UNAME_RELEASE}|sed -e 's/[-_].*//'`
-+ echo ${UNAME_MACHINE}-unknown-freebsdelf`echo ${UNAME_RELEASE}|sed -e 's/[-_].*//'`
diff --git a/devel/ddd/files/patch-configure b/devel/ddd/files/patch-configure
new file mode 100644
index 000000000000..004fc879ee4a
--- /dev/null
+++ b/devel/ddd/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Wed Oct 22 15:29:40 2003
++++ configure Fri Feb 27 13:33:02 2004
+@@ -3811,7 +3811,7 @@
+ RANLIB="$ac_cv_prog_RANLIB"
+ fi
+
+-for ac_prog in 'bison -y' byacc
++for ac_prog in byacc
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+ set dummy $ac_prog; ac_word=$2
+@@ -23156,7 +23156,7 @@
+
+ _ACEOF
+ if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
+- egrep "${ice_re_word}ioctl *\(" >/dev/null 2>&1; then
++ egrep "${ice_re_word}\(?ioctl\)? *\(" >/dev/null 2>&1; then
+ ice_cv_have_ioctl_decl=yes
+ fi
+ rm -f conftest*
diff --git a/devel/ddd/files/patch-ddd::Ddd.in b/devel/ddd/files/patch-ddd::Ddd.in
new file mode 100644
index 000000000000..ca0ec28526a2
--- /dev/null
+++ b/devel/ddd/files/patch-ddd::Ddd.in
@@ -0,0 +1,12 @@
+--- ddd/Ddd.in.orig Wed Oct 22 15:25:51 2003
++++ ddd/Ddd.in Fri Feb 27 13:33:02 2004
+@@ -284,7 +284,8 @@
+
+
+ ! Paper size, in format WIDTH x HEIGHT. (Default: A4).
+-@Ddd@*paperSize: 210mm x 297mm
++!@Ddd@*paperSize: 210mm x 297mm
++@Ddd@*paperSize: 8.5" x 11"
+
+
+
diff --git a/devel/ddd/files/patch-LiterateA.C b/devel/ddd/files/patch-ddd::LiterateA.C
index cd25c91cf0d5..f1b3c4ea7aa2 100644
--- a/devel/ddd/files/patch-LiterateA.C
+++ b/devel/ddd/files/patch-ddd::LiterateA.C
@@ -1,5 +1,5 @@
---- ddd/LiterateA.C.orig Thu Aug 19 04:27:40 1999
-+++ ddd/LiterateA.C Sun Aug 27 02:37:48 2000
+--- ddd/LiterateA.C.orig Sat May 24 11:27:03 2003
++++ ddd/LiterateA.C Fri Feb 27 13:33:02 2004
@@ -220,8 +220,12 @@
int flags = fcntl(fileno(fp), F_GETFL, 0);
if (flags == -1)
diff --git a/devel/ddd/files/patch-ddd::Makefile.in b/devel/ddd/files/patch-ddd::Makefile.in
new file mode 100644
index 000000000000..a478af869911
--- /dev/null
+++ b/devel/ddd/files/patch-ddd::Makefile.in
@@ -0,0 +1,11 @@
+--- ddd/Makefile.in.orig Wed Oct 22 15:29:49 2003
++++ ddd/Makefile.in Fri Feb 27 13:33:02 2004
+@@ -2170,7 +2170,7 @@
+ && $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) \
+ `echo $< | sed 's,.*/,,'`
+
+-MAKEINFO = @MAKEINFO@
++MAKEINFO = @MAKEINFO@ --no-split
+ TEXI2DVI = texi2dvi
+
+ uninstall-info-am:
diff --git a/devel/ddd/files/patch-TTYAgent.C b/devel/ddd/files/patch-ddd::TTYAgent.C
index 2bc5c9083cdb..59b6cd09fee3 100644
--- a/devel/ddd/files/patch-TTYAgent.C
+++ b/devel/ddd/files/patch-ddd::TTYAgent.C
@@ -1,6 +1,6 @@
---- ddd/TTYAgent.C.orig Thu Aug 19 04:27:58 1999
-+++ ddd/TTYAgent.C Sun Aug 27 02:37:48 2000
-@@ -697,8 +697,19 @@
+--- ddd/TTYAgent.C.orig Sat May 24 11:27:05 2003
++++ ddd/TTYAgent.C Fri Feb 27 13:33:02 2004
+@@ -719,8 +719,19 @@
}
else
{
diff --git a/devel/ddd/files/patch-strerror.c b/devel/ddd/files/patch-libiberty::strerror.c
index 47264c0c0979..d36cce74d790 100644
--- a/devel/ddd/files/patch-strerror.c
+++ b/devel/ddd/files/patch-libiberty::strerror.c
@@ -1,17 +1,18 @@
---- libiberty/strerror.c.orig Wed Sep 4 12:56:21 2002
-+++ libiberty/strerror.c Wed Sep 4 12:56:45 2002
-@@ -454,7 +454,7 @@
- We don't export it for use in other modules because even though it has the
+--- libiberty/strerror.c.orig Wed Oct 22 14:46:55 2003
++++ libiberty/strerror.c Fri Feb 27 13:53:29 2004
+@@ -460,6 +460,7 @@
same name, it differs from other implementations in that it is dynamically
initialized rather than statically initialized. */
--
+
+#ifndef __FreeBSD__
#ifndef HAVE_SYS_ERRLIST
static int sys_nerr;
-@@ -465,6 +465,7 @@
+@@ -470,6 +471,7 @@
extern int sys_nerr;
extern char *sys_errlist[];
+#endif
#endif
+
+
diff --git a/devel/ddd/files/patch-strsignal.c b/devel/ddd/files/patch-libiberty::strsignal.c
index ea358a9e9142..12af26746dde 100644
--- a/devel/ddd/files/patch-strsignal.c
+++ b/devel/ddd/files/patch-libiberty::strsignal.c
@@ -1,6 +1,6 @@
---- libiberty/strsignal.c.orig Wed Sep 4 12:32:03 2002
-+++ libiberty/strsignal.c Wed Sep 4 12:32:52 2002
-@@ -236,6 +236,7 @@
+--- libiberty/strsignal.c.orig Wed Oct 22 14:46:55 2003
++++ libiberty/strsignal.c Fri Feb 27 13:33:02 2004
+@@ -241,6 +241,7 @@
same name, it differs from other implementations in that it is dynamically
initialized rather than statically initialized. */
@@ -8,10 +8,11 @@
#ifndef HAVE_SYS_SIGLIST
static int sys_nsig;
-@@ -252,6 +253,7 @@
+@@ -257,6 +258,7 @@
#endif
extern const char * const sys_siglist[];
+#endif
#endif
+
diff --git a/devel/ddd/pkg-plist b/devel/ddd/pkg-plist
index 208c987e2d04..0c92aaaf4634 100644
--- a/devel/ddd/pkg-plist
+++ b/devel/ddd/pkg-plist
@@ -34,12 +34,19 @@ share/ddd-%%VERSION%%/vsllib/verbose.vsl
share/ddd-%%VERSION%%/vsllib/vsl.vsl
share/ddd-%%VERSION%%/vsllib/vsldef.vsl
share/ddd-%%VERSION%%/vsllib/vsllib.vsl
-share/doc/ddd/PROBLEMS
-share/doc/ddd/README
-share/doc/ddd/ddd-paper.ps.gz
-share/doc/ddd/ddd.ps.gz
-share/doc/ddd/sample.dddinit
-@dirrm share/doc/ddd
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/PROBLEMS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TIPS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/ddd-paper.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/ddd-themes.pdf
+%%PORTDOCS%%%%DOCSDIR%%/ddd-themes.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/ddd.html
+%%PORTDOCS%%%%DOCSDIR%%/ddd.pdf
+%%PORTDOCS%%%%DOCSDIR%%/ddd.ps.gz
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/ddd-%%VERSION%%/vsllib
@dirrm share/ddd-%%VERSION%%/themes
@dirrm share/ddd-%%VERSION%%/ddd