aboutsummaryrefslogtreecommitdiff
path: root/devel/deforaos-libsystem/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-12-19 00:49:34 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-12-19 00:49:34 +0000
commit73ce74bbae98df4a98ed042dc563121231aea1d1 (patch)
treeb4ec9e144e51198fabee6c59aba88a7c68874b27 /devel/deforaos-libsystem/Makefile
parent618d32c2fd322770a8b1f0a057271e057045c325 (diff)
downloadports-73ce74bbae98df4a98ed042dc563121231aea1d1.tar.gz
ports-73ce74bbae98df4a98ed042dc563121231aea1d1.zip
DeforaOS system library
PR: ports/172987 Submitted by: Olivier Cochard-Labbe <olivier@cochard.me>
Notes
Notes: svn path=/head/; revision=309213
Diffstat (limited to 'devel/deforaos-libsystem/Makefile')
-rw-r--r--devel/deforaos-libsystem/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/deforaos-libsystem/Makefile b/devel/deforaos-libsystem/Makefile
new file mode 100644
index 000000000000..c1cac76da507
--- /dev/null
+++ b/devel/deforaos-libsystem/Makefile
@@ -0,0 +1,23 @@
+# Created by: Olivier Cochard-Labbe <olivier@cochard.me>
+# $FreeBSD$
+
+PORTNAME= libsystem
+PORTVERSION= 0.1.6
+CATEGORIES= devel
+MASTER_SITES= http://www.defora.org/os/download/download/3527/
+DISTNAME= libSystem-${PORTVERSION}
+PKGNAMEPREFIX= deforaos-
+
+MAINTAINER= olivier@cochard.me
+COMMENT= DeforaOS core system library
+
+LICENSE= GPLv3
+
+USE_LDCONFIG= yes
+USE_PKGCONFIG= build
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/lib/|/libdata/|g' \
+ ${WRKSRC}/data/pkgconfig.sh
+
+.include <bsd.port.mk>