aboutsummaryrefslogtreecommitdiff
path: root/devel/deforaos-libsystem/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-12-12 22:43:24 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-12-12 22:43:24 +0000
commitfe7d35de728fff452daca23b8427e70bc3a5da09 (patch)
tree4d79b02cf6bd1ff0e1a0e3a975a715f4e2ad7992 /devel/deforaos-libsystem/Makefile
parent62287039dd15c6eba0e547cbdbf375996852d11b (diff)
downloadports-fe7d35de728fff452daca23b8427e70bc3a5da09.tar.gz
ports-fe7d35de728fff452daca23b8427e70bc3a5da09.zip
Respect WITH_OPENSSL_PORT=yes
Notes
Notes: svn path=/head/; revision=374608
Diffstat (limited to 'devel/deforaos-libsystem/Makefile')
-rw-r--r--devel/deforaos-libsystem/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/deforaos-libsystem/Makefile b/devel/deforaos-libsystem/Makefile
index d387749d4f40..8d27058ec7b9 100644
--- a/devel/deforaos-libsystem/Makefile
+++ b/devel/deforaos-libsystem/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libsystem
PORTVERSION= 0.1.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.defora.org/os/download/download/3527/
DISTNAME= libSystem-${PORTVERSION}
@@ -16,10 +16,15 @@ LICENSE= GPLv3
USES= pkgconfig
USE_LDCONFIG= yes
+USE_OPENSSL= yes
+CPPFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
MAKE_ARGS+= PREFIX=${PREFIX}
post-patch:
- ${REINPLACE_CMD} -e 's|/lib/|/libdata/|g' \
+ ${REINPLACE_CMD} 's|/lib/|/libdata/|g' \
${WRKSRC}/data/pkgconfig.sh
+ ${REINPLACE_CMD} 's|CPPFLAGS=|CPPFLAGS+=|' \
+ ${WRKSRC}/src/Makefile
.include <bsd.port.mk>