aboutsummaryrefslogtreecommitdiff
path: root/devel/devhelp/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-07-08 08:17:18 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-07-08 08:17:18 +0000
commit81e19be8c67b635fb62a699ee7a28006df34b374 (patch)
treed6facc58aa1a9d71c2a5555d8afdb83cf7fc4d94 /devel/devhelp/Makefile
parent4728f4f68580c9c9e8d57c358b3b2bbc56799bc3 (diff)
downloadports-81e19be8c67b635fb62a699ee7a28006df34b374.tar.gz
ports-81e19be8c67b635fb62a699ee7a28006df34b374.zip
Update to 0.15.
Notes
Notes: svn path=/head/; revision=195210
Diffstat (limited to 'devel/devhelp/Makefile')
-rw-r--r--devel/devhelp/Makefile38
1 files changed, 27 insertions, 11 deletions
diff --git a/devel/devhelp/Makefile b/devel/devhelp/Makefile
index 17e156a5ed9c..612324e667e4 100644
--- a/devel/devhelp/Makefile
+++ b/devel/devhelp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= devhelp
-PORTVERSION= 0.10
-PORTREVISION= 6
+PORTVERSION= 0.15
CATEGORIES?= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C,^([[:digit:]]+\.[[:digit:]]+).*,\1,}
@@ -19,43 +18,60 @@ COMMENT= Developer help browser for GNOME 2
BUILD_DEPENDS= ${LOCALBASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
RUN_DEPENDS= ${LOCALBASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-MOZILLA= mozilla
+MOZILLA= firefox
.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla
-.else
-.if ${WITH_MOZILLA} == "firefox"
MOZILLA= firefox
+.else
+.if ${WITH_MOZILLA} == "xulrunner"
+MOZILLA= xulrunner
.elif ${WITH_MOZILLA} == "seamonkey"
MOZILLA= seamonkey
.endif
.endif
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_XLIB= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
USE_LDCONFIG= ${LOCALBASE}/lib/${MOZILLA}
GCONF_SCHEMAS= devhelp.schemas
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-mozilla=${MOZILLA}
+CONFIGURE_ARGS= --with-gecko=${MOZILLA}
+
+OPTIONS= GEDIT "Enable GEdit plug-in support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GEDIT)
+BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
+RUN_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
+PLIST_SUB+= GEDIT=""
+.else
+PLIST_SUB+= GEDIT="@comment "
+.endif
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX}|${SED} -E 's,.*share/nls/.+$$,,g;s,^@dirrm share/((gnome/[^d]|pixmaps|application|locale).*|gnome$$),,;s,^@dirrm etc/gconf.*,,;s,^etc/gconf/gconf.*,,'|${TR} -s '\n') > temp-pkg-plist
-.include <bsd.port.pre.mk>
+post-patch:
+.if defined(WITHOUT_GEDIT)
+ @${REINPLACE_CMD} -e 's|gedit-plugin||' \
+ ${WRKSRC}/misc/Makefile.in
+.endif
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} " By default the port uses www/mozilla for html rendering, but you can"
+ @${ECHO_MSG} " By default the port uses www/firefox for html rendering, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
- @${ECHO_MSG} " firefox seamonkey "
+ @${ECHO_MSG} " xulrunner seamonkey "
@${ECHO_MSG} ""
.include <bsd.port.post.mk>