aboutsummaryrefslogtreecommitdiff
path: root/devel/devhelp
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-30 17:34:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-30 17:34:39 +0000
commit36a1e22ed286b69216dc69bafb228f8587012907 (patch)
treee9ce82bde537483fa86a6f0191af61bcffba8a07 /devel/devhelp
parent2a845564968641f2162651a81811e64e87f7e582 (diff)
downloadports-36a1e22ed286b69216dc69bafb228f8587012907.tar.gz
ports-36a1e22ed286b69216dc69bafb228f8587012907.zip
Make sure we link against ${PTHREAD_LIBS}. This fixes a build problem
on -STABLE, and some runtime threading issues on -CURRENT. PR: 53918 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=83916
Diffstat (limited to 'devel/devhelp')
-rw-r--r--devel/devhelp/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/devhelp/Makefile b/devel/devhelp/Makefile
index 172ba45a74be..fe764fa1d902 100644
--- a/devel/devhelp/Makefile
+++ b/devel/devhelp/Makefile
@@ -7,9 +7,10 @@
PORTNAME= devhelp
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES?= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.7
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C,^([[:digit:]]+\.[[:digit:]]+).*,\1,}
DIST_SUBDIR= gnome2
MAINTAINER= rui@ruilopes.com
@@ -21,7 +22,7 @@ USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix libgtkhtml libgnomeui
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
.include <bsd.port.mk>